SUNWgnome-games.spec
changeset 11761 b03c704294e7
parent 11758 ea99458c010b
child 11822 0dbf5957a013
--- a/SUNWgnome-games.spec	Thu Feb 28 19:29:05 2008 +0000
+++ b/SUNWgnome-games.spec	Thu Feb 28 21:17:05 2008 +0000
@@ -15,7 +15,6 @@
 %use gnome_games = gnome-games.spec
 %use libggz = libggz.spec
 %use ggz_client_libs = ggz-client-libs.spec
-%use ggz_python = ggz-python.spec
 
 Name:                    SUNWgnome-games
 Summary:                 GNOME games
@@ -68,7 +67,6 @@
 mkdir %name-%version
 %libggz.prep -d %name-%version
 %ggz_client_libs.prep -d %name-%version
-%ggz_python.prep -d %name-%version
 %gnome_games.prep -d %name-%version
 
 %build
@@ -95,19 +93,19 @@
 
 %libggz.build -d %name-%version
 %ggz_client_libs.build -d %name-%version
-%ggz_python.build -d %name-%version
 %gnome_games.build -d %name-%version
 
 %install
 rm -rf $RPM_BUILD_ROOT
 %libggz.install -d %name-%version
 %ggz_client_libs.install -d %name-%version
-%ggz_python.install -d %name-%version
 %gnome_games.install -d %name-%version
 
+# Remove the empty dir.
+rmdir $RPM_BUILD_ROOT%{_libdir}/ggz
+
 rm -rf $RPM_BUILD_ROOT%{_localstatedir}/lib/games
 rmdir $RPM_BUILD_ROOT%{_localstatedir}/lib
-rm -rf $RPM_BUILD_ROOT%{_localstatedir}/tmp
 rmdir $RPM_BUILD_ROOT%{_localstatedir}
 # Delete the include files as we're not delivering a devel package. It's not
 # useful.
@@ -183,9 +181,6 @@
 %{_bindir}/*
 %dir %attr (0755, root, bin) %{_libdir}
 %{_libdir}/gnome-games
-%{_libdir}/ggz
-%{_libdir}/ggzd
-%{_libdir}/ggz-python
 %{_libdir}/libggz*
 %{_libdir}/python?.?/vendor-packages
 %dir %attr (0755, root, sys) %{_datadir}
@@ -249,7 +244,6 @@
 %{_sysconfdir}/gconf/schemas/same-gnome.schemas
 %{_sysconfdir}/gconf/schemas/mahjongg.schemas
 %{_sysconfdir}/xdg
-%{_sysconfdir}/ggzd
 
 #%files devel
 #%defattr (-, root, bin)
@@ -257,6 +251,8 @@
 #%{_includedir}/*
 
 %changelog
+* Thu Feb 28 2008 - [email protected]
+- Remove ggz-python since it isn't needed.  Sorry about the churn.
 * Wed Feb 27 2008 - [email protected]
 - Add gst-python, since glchess needs it.  Rename %{ggzmod_build_dir} to
   %{ggzclient_build_dir} since this is more accurate - the module is named