SUNWgnome-camera.spec
changeset 9397 b16e349d18c5
child 10248 35a83f63b2d9
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/SUNWgnome-camera.spec	Wed Feb 28 18:57:18 2007 +0000
@@ -0,0 +1,242 @@
+#
+# spec file for package SUNWgnome-camera
+#
+# includes module(s): libgphoto2, gphoto2, gtkam
+#
+# Copyright (c) 2004 Sun Microsystems, Inc.
+# This file and all modifications and additions to the pristine
+# package are under the same license as the package itself.
+#
+# Owner: mattman
+#
+%include Solaris.inc
+%use libgphoto2 = libgphoto2.spec
+%use gphoto2 = gphoto2.spec
+%use gtkam = gtkam.spec
+
+Name:                    SUNWgnome-camera
+Summary:                 GNOME digital camera tool
+Version:                 %{default_pkg_version}
+SUNW_BaseDir:            %{_basedir}
+BuildRoot:               %{_tmppath}/%{name}-%{version}-build
+
+%include default-depend.inc
+Requires: SUNWgnome-libs
+Requires: SUNWgnome-base-libs
+Requires: SUNWlibusb
+Requires: SUNWgnome-component
+Requires: SUNWgnome-img-editor
+Requires: SUNWjpg
+Requires: SUNWlibexif
+Requires: SUNWlibms
+Requires: SUNWlibpopt
+Requires: SUNWmlib
+Requires: SUNWpostrun
+Requires: SUNWdbus
+BuildRequires: SUNWgnome-component-devel
+BuildRequires: SUNWlibexif-devel
+BuildRequires: SUNWlibpopt-devel
+# gtkam builds a gimp plug-in, so SUNWgnome-img-editor is a dependancy
+BuildRequires: SUNWgnome-img-editor-devel
+BuildRequires: SUNWlibusb
+BuildRequires: SUNWdbus-devel
+
+%if %build_l10n
+%package l10n
+Summary:                 %{summary} - l10n files
+SUNW_BaseDir:            %{_basedir}
+%include default-depend.inc
+Requires:                %{name}
+%endif
+
+%package devel
+Summary:                 %{summary} - development files
+SUNW_BaseDir:            %{_basedir}
+%include default-depend.inc
+
+%prep
+rm -rf %name-%version
+mkdir %name-%version
+%libgphoto2.prep -d %name-%version
+%gphoto2.prep -d %name-%version
+%gtkam.prep -d %name-%version
+
+%build
+export PKG_CONFIG_PATH=../libgphoto2-%{libgphoto2.version}/libgphoto2:%{_pkg_config_path}
+export CFLAGS="%optflags -I%{_includedir}"
+export RPM_OPT_FLAGS="$CFLAGS"
+export LDFLAGS="%_ldflags -R/usr/sfw/lib"
+
+%libgphoto2.build -d %name-%version
+%gphoto2.build -d %name-%version
+%gtkam.build -d %name-%version
+
+%install
+rm -rf $RPM_BUILD_ROOT
+%libgphoto2.install -d %name-%version
+%gphoto2.install -d %name-%version
+%gtkam.install -d %name-%version
+
+rm -rf $RPM_BUILD_ROOT%{_prefix}/var
+# Remove source code files (AUTHORS, README, CHANGELOG etc)
+rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
+# Remove Linux specific hotplug stuff
+rm -rf $RPM_BUILD_ROOT%{_sysconfdir}
+
+%if %build_l10n
+%else
+# REMOVE l10n FILES
+rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
+rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/help/*/[a-z]*
+rm -rf $RPM_BUILD_ROOT%{_datadir}/omf/*/*-[a-z][a-z].omf
+%endif
+
+%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):unsupported" $RPM_BUILD_ROOT}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+( echo 'test -x /usr/bin/update-desktop-database || exit 0';
+  echo '/usr/bin/update-desktop-database'
+) | $BASEDIR/lib/postrun -b -u -c JDS_wait
+( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
+  echo '/usr/bin/scrollkeeper-update'
+) | $BASEDIR/lib/postrun -b -u -c JDS
+
+%postun
+test -x $BASEDIR/lib/postrun || exit 0
+( echo 'test -x /usr/bin/update-desktop-database || exit 0';
+  echo '/usr/bin/update-desktop-database'
+) | $BASEDIR/lib/postrun -b -u -c JDS
+( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
+  echo '/usr/bin/scrollkeeper-update'
+) | $BASEDIR/lib/postrun -b -u -c JDS
+
+%files
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %{_bindir}
+%{_bindir}/gphoto2
+%{_bindir}/gtkam
+%{_bindir}/gexif
+%dir %attr (0755, root, bin) %{_libdir}
+%{_libdir}/lib*.so*
+%{_libdir}/libgphoto2
+%{_libdir}/libgphoto2_port
+%{_libdir}/gimp
+%{_libdir}/udev
+%dir %attr (0755, root, sys) %{_datadir}
+%dir %attr (0755, root, other) %{_datadir}/applications
+%{_datadir}/applications/*
+%dir %attr (0755, root, other) %{_datadir}/doc
+%{_datadir}/doc/*
+%dir %attr (0755, root, other) %{_datadir}/gnome
+%{_datadir}/gnome/help/gtkam/C
+%{_datadir}/gtkam
+%{_datadir}/images
+%{_datadir}/libgphoto2
+%{_datadir}/omf/*/*-C.omf
+%dir %attr (0755, root, other) %{_datadir}/pixmaps
+%{_datadir}/pixmaps/*
+%dir %attr(0755, root, bin) %{_mandir}
+%dir %attr(0755, root, bin) %{_mandir}/man1
+%{_mandir}/man1/*
+%dir %attr(0755, root, bin) %{_mandir}/man3
+%{_mandir}/man3/*
+
+%if %build_l10n
+%files l10n
+%defattr (-, root, bin)
+%dir %attr (0755, root, sys) %{_datadir}
+%dir %attr (0755, root, other) %{_datadir}/gnome
+%attr (-, root, other) %{_datadir}/locale
+%{_datadir}/gnome/help/*/[a-z]*
+%{_datadir}/omf/*/*-[a-z]*.omf
+%endif
+
+%files devel
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %{_bindir}
+%{_bindir}/gphoto2-port-config
+%{_bindir}/gphoto2-config
+%dir %attr (0755, root, bin) %{_includedir}
+%{_includedir}/*
+%dir %attr (0755, root, bin) %{_libdir}
+%dir %attr (0755, root, other) %{_libdir}/pkgconfig
+%{_libdir}/pkgconfig/*
+
+%changelog
+* Tue Feb 13 2007 - [email protected]
+- Add lib/udev to packaging - new directory in 2.3.1.
+* Fri Feb 09 2007 - [email protected]
+- Add SUNWdbus dependency since libgphoto2 requires D-Bus.
+* Tue Dec 19 2006 - [email protected]
+- Rework spec file after updating gtkam, libgphoto2, gphoto2 spec files.
+* Sat Aug 12 2006 - [email protected]
+- delete some unnecessary env variables
+* Tue Jul 25 2006 - [email protected]
+- Fix 'rm .omf' line to not delete the C locale file.
+* Fri Jul 14 2006 - [email protected]
+- update %post/%postun/etc scripts to support diskless client setup,
+  part of 6448317
+* Thu Jun 29 2006 - [email protected]
+- update postrun scripts
+* Sun Jun 11 2006 - [email protected]
+- change group from other to bin/sys
+* Mon May 15 2006 - [email protected]
+- Correct l10n package perms.
+* Tue May 09 2006 - [email protected]
+- merge -share pkg(s) into the base pkg(s)
+* Tue Apr 4 2006 - [email protected]
+- Remove the hotplug stuff which is Linux specific. This
+  cuts out the -root package currently.
+* Tue Apr 4 2006 - [email protected]
+- Move gphoto2-config into the -devel package.
+* Wed Mar 15 2006 - [email protected]
+- Add to Build/Requires after running check-deps.pl.
+* Mon Jan 09 2006 - [email protected]
+- Add SUNWlibusb dependency to get libusb-config.
+* Sat Dec  3 2005 - [email protected]
+- add %post script that runs update-desktop-database
+* Tue Nov 29 2005 - [email protected]
+- remove javahelp stuff
+* Fri Sep 30 2005 - [email protected]
+- Add root package for _sysconfdir files. Remove javahelp references.
+  Delete .la files and others before packaging.
+* Mon Dec 13 2004 - [email protected]
+- Move to /usr/sfw to implement ARC decision.
+* Sun Nov 14 2004 - [email protected]
+- add /usr/demo/jds/lib to RPATH
+* Fri Nov 12 2004 - [email protected]
+- move to /usr/demo/jds
+* Mon Oct 11 2004 - [email protected]
+- Corrected packaging of gimp plugin.
+* Wed Oct 06 2004 - [email protected]
+- added l10n help files section
+* Sat Oct 02 2004 - [email protected]
+- added %pkgbuild_postprocess
+* Mon Sep 13 2004  [email protected]
+- Added code to install javahelp documents. Fixes #5096653.
+* Thu Sep 09 2004  [email protected]
+- Moved %{_datadir}/pixmaps to '%files share' from '%files l10n'.
+  Put %{_datadir}/omf/*/*-C.omf under '%files share'.
+* Sun Sep 05 2004 - [email protected]
+- removed root subpkg as it only contained 2 linux specific files (#5097102)
+* Tue Aug 24 2004 - [email protected]
+- Remove %{_datadir}/doc from install since these docs are not useful
+  to install
+* Mon Aug 23 2004 - [email protected]
+- s/SUNWpl5u/SUNWperl584usr/
+* Sun Jun 27 2004  [email protected]
+- Changed install location to /usr/...
+* Mon Jun 07 2004 - [email protected]
+- Moved libexif to SUNWlibexif and libexif-gtk to SUNWgnome-libs since
+  nautilus also uses these libraries if available.
+* Wed Jun 02 2004 - [email protected]
+- Added gtkam to package.
+* Wed Jun 02 2004 - [email protected]
+- Added %{_datadir}/locale to install l10n messages
+* Mon May 03 2004 - [email protected]
+- renamed to SUNWgnome-camera
+* Fri Mar 31 2004 - [email protected]
+- Created,