SUNWgnome-gui-test.spec
changeset 9397 b16e349d18c5
child 9655 9777352ae777
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/SUNWgnome-gui-test.spec	Wed Feb 28 18:57:18 2007 +0000
@@ -0,0 +1,89 @@
+#
+# spec file for package SUNWgnome-gui-test
+#
+# includes module(s): dogtail
+#
+# Copyright (c) 2005 Sun Microsystems, Inc.
+# This file and all modifications and additions to the pristine
+# package are under the same license as the package itself.
+#
+# Owner: dcarbery
+#
+%include Solaris.inc
+%use dogtail = dogtail.spec
+
+Name:                    SUNWgnome-gui-test
+Summary:                 GUI test tool and automation framework
+Version:                 %{default_pkg_version}
+SUNW_BaseDir:            %{_basedir}
+BuildRoot:               %{_tmppath}/%{name}-%{version}-build
+
+%include default-depend.inc
+Requires: SUNWPython
+Requires: SUNWPython-extra
+Requires: SUNWgnome-a11y-libs
+BuildRequires: SUNWPython-devel
+BuildRequires: SUNWPython-extra
+BuildRequires: SUNWgnome-a11y-libs-devel
+Requires: SUNWpostrun
+
+%prep
+rm -rf %name-%version
+mkdir %name-%version
+%dogtail.prep -d %name-%version
+
+%build
+
+%install
+[ "$RPM_BUILD_ROOT" != "" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT
+%dogtail.install -d %name-%version
+
+%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post
+( echo 'test -x /usr/bin/update-desktop-database || exit 0';
+  echo '/usr/bin/update-desktop-database'
+) | $BASEDIR/lib/postrun -b -u -c JDS_wait
+
+%postun
+test -x $BASEDIR/lib/postrun || exit 0
+( echo 'test -x /usr/bin/update-desktop-database || exit 0';
+  echo '/usr/bin/update-desktop-database'
+) | $BASEDIR/lib/postrun -b -u -c JDS
+
+%files
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %{_bindir}
+%{_bindir}/*
+%dir %attr (0755, root, bin) %{_libdir}
+%{_libdir}/*
+%dir %attr (0755, root, sys) %{_datadir}
+%dir %attr (0755, root, other) %{_datadir}/applications
+%{_datadir}/applications/*
+%dir %attr (0755, root, other) %{_datadir}/doc
+%{_datadir}/doc/*
+%{_datadir}/dogtail
+%attr (-, root, other) %{_datadir}/icons
+
+%changelog
+* Sat Aug 12 2006 - [email protected]
+- change datadir/icons permissions back to root:other since it's a stable
+  interface and wasn't supposed to be changed
+* Fri Jul 14 2006 - [email protected]
+- update %post/%postun/etc scripts to support diskless client setup,
+  part of 6448317
+* Thu Jun 29 2006 - [email protected]
+- update postrun scripts
+* Sun Jun 11 2006 - [email protected]
+- change group from other to bin/sys
+* Tue Feb 21 2006 - [email protected]
+- Update packaging for new tarball.
+* Sat Dec  3 2005 - [email protected]
+- add %post script that runs update-desktop-database
+* Mon Oct 21 2005 - [email protected]
+- fix permissions
+* Thu Oct 20 2005 - [email protected]
+- Initial version.