SUNWlibpopt.spec
changeset 9397 b16e349d18c5
child 9565 4f6ed9cc5ede
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/SUNWlibpopt.spec	Wed Feb 28 18:57:18 2007 +0000
@@ -0,0 +1,147 @@
+#
+# spec file for package SUNWlibpopt
+#
+# includes module(s): popt
+#
+# Copyright (c) 2004 Sun Microsystems, Inc.
+# This file and all modifications and additions to the pristine
+# package are under the same license as the package itself.
+#
+# Owner: laca
+#
+%include Solaris.inc
+
+%define _prefix /usr
+
+Name:                    SUNWlibpopt
+Summary:                 Command line parsing library
+Version:                 1.7
+Source:                  ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.1.x/popt-%{version}.tar.gz
+Source1:                 %{name}-manpages-0.1.tar.gz
+Source2:                 l10n-configure.sh
+SUNW_BaseDir:            %{_prefix}
+BuildRoot:               %{_tmppath}/%{name}-%{version}-build
+
+%include default-depend.inc
+
+%package devel
+Summary:                 %{summary} - development files
+SUNW_BaseDir:            %{_prefix}
+%include default-depend.inc
+
+%prep
+%setup -c -n %name-%version
+gzcat %SOURCE1 | tar xf -
+
+%ifarch amd64 sparcv9
+cp -rp popt-%version popt-%version-64
+%endif
+
+cd popt-%version
+bash -x %SOURCE2
+
+%build
+CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
+if test "x$CPUS" = "x" -o $CPUS = 0; then
+    CPUS=1
+fi
+
+CONFLAGS="--prefix=%{_prefix} --mandir=%{_mandir} --disable-nls"
+export LDFLAGS="%_ldflags"
+
+%ifarch amd64 sparcv9
+cd popt-%version-64
+CFLAGS32="$RPM_OPT_FLAGS"
+RPM_OPT_FLAGS="%optflags64"
+export RPM_OPT_FLAGS
+CFLAGS="$RPM_OPT_FLAGS"
+export CFLAGS
+export CC=${CC64:-$CC}
+
+./configure $CONFLAGS					\
+            --libdir=%{_libdir}/%{_arch64}		\
+            --libexecdir=%{_libexecdir}/%{_arch64}	\
+            --sysconfdir=%{_sysconfdir}/%{_arch64}
+
+make -j $CPUS
+cd ..
+export CC=${CC32:-$CC}
+%endif
+
+cd popt-%version
+CFLAGS="$CFLAGS32"	\
+./configure $CONFLAGS
+make -j $CPUS
+
+
+%install
+%ifarch amd64 sparcv9
+cd popt-%version-64
+make install DESTDIR=$RPM_BUILD_ROOT
+cd ..
+rm -f $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/lib*a
+%endif
+
+cd popt-%version
+make install DESTDIR=$RPM_BUILD_ROOT
+
+rm -rf $RPM_BUILD_ROOT%{_mandir}
+cd ../sun-manpages
+make install DESTDIR=$RPM_BUILD_ROOT
+
+rm -f $RPM_BUILD_ROOT%{_libdir}/lib*a
+
+%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %{_libdir}
+%{_libdir}/lib*.so*
+%ifarch amd64 sparcv9
+%dir %attr (0755, root, bin) %{_libdir}/%{_arch64}
+%{_libdir}/%{_arch64}/lib*.so*
+%endif
+%dir %attr(0755, root, sys) %{_datadir}
+%dir %attr(0755, root, bin) %{_mandir}
+%dir %attr(0755, root, bin) %{_mandir}/man3
+%{_mandir}/man3/*
+
+%files devel
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %{_includedir}
+%{_includedir}/*
+
+
+%changelog
+* Sun Feb 11 2007 - [email protected]
+- delete PATH changes in the 64-bit build: not needed anymore and break
+  the build on SXDE
+* Mon Sep 04 2006 - [email protected]
+- New Manpage tarball
+* Sun Jun 11 2006 - [email protected]
+- change group from other to bin/sys
+* Wed May 10 2006 - [email protected]
+- merge -share pkg(s) into the base pkg(s)
+* Fri Sep 02 2005 - [email protected]
+- remove unpackaged files
+* Fri Oct 29 2004 - [email protected]
+- use $CC64 as the 64-bit C compiler, if defined
+* Sat Oct 02 2004 - [email protected]
+- added %pkgbuild_postprocess
+* Sat Oct  2 2004 - [email protected]
+- Create 64bit libraries for Solaris
+* Mon Aug 30 2004 - [email protected]
+- Bug 5091588 : include files should be in a separate devel package
+  		renamed SUNWlibpopt-share to SUNWlibpopt-devel-share
+	        removed SUNWlibpopt depend on SUNWlibpopt-share
+* Wed Aug 18 2004 - [email protected]
+- Change manpage perms for Solaris integration.
+* Wed May 19 2004 - [email protected]
+- added man page.
+* Fri Feb 13 2004 - [email protected]
+- added 64-bit version
+* Mon Jan 28 2004 - [email protected]
+- initial version added to CVS