SUNWgnome-a11y-libs.spec
changeset 15614 bbbfe1b4b965
parent 15612 07e541fbfffd
child 15623 7f4d27f0d4a2
--- a/SUNWgnome-a11y-libs.spec	Tue Apr 14 14:31:53 2009 +0000
+++ b/SUNWgnome-a11y-libs.spec	Wed Apr 15 01:11:01 2009 +0000
@@ -144,7 +144,7 @@
 %build
 PKG_CONFIG_DISABLE_UNINSTALLED=
 unset PKG_CONFIG_DISABLE_UNINSTALLED
-export PKG_CONFIG_PATH="%{_pkg_config_path}:../at-spi-%{at_spi.version}"
+export PKG_CONFIG_PATH="%{_pkg_config_path}"
 export CFLAGS="%optflags -I/usr/X11/include"
 export RPM_OPT_FLAGS="$CFLAGS"
 export LDFLAGS="%_ldflags"
@@ -167,16 +167,7 @@
 %at_spi_py24.build -d %name-%version/%base_arch-py24
 %at_spi_py26.build -d %name-%version/%base_arch-py26
 
-# set PKG_CONFIG_TOP_BUILD_DIR to fix top_builddir
-# issue when using at-spi uninstalled pc file
-export PKG_CONFIG_TOP_BUILD_DIR="%{_builddir}/%name-%version/%base_arch-py24/pyspi-%{pyspi_py24.version}"
-%pyspi_py24.build -d %name-%version/%base_arch-py24
-
-export PKG_CONFIG_TOP_BUILD_DIR="%{_builddir}/%name-%version/%base_arch-py26/pyspi-%{pyspi_py26.version}"
-%pyspi_py26.build -d %name-%version/%base_arch-py26
-
 %install
-export PKG_CONFIG_PATH="%{_pkg_config_path}:../at-spi-%{at_spi.version}"
 
 %ifarch amd64 sparcv9
 %at_spi_64.install -d %name-%version/%_arch64
@@ -259,6 +250,9 @@
 %at_spi_py24.install -d %name-%version/%base_arch-py24
 %at_spi_py26.install -d %name-%version/%base_arch-py26
 
+# set PKG_CONFIG_PATH to let pyspi to pick up the uninstalled pc file 
+export PKG_CONFIG_PATH="%{_pkg_config_path}:../at-spi-%{at_spi.version}"
+
 # set PKG_CONFIG_TOP_BUILD_DIR to fix top_builddir
 # issue when using at-spi uninstalled pc file
 export PKG_CONFIG_TOP_BUILD_DIR="%{_builddir}/%name-%version/%base_arch-py24/pyspi-%{pyspi_py24.version}"