base-specs/clutter-gtk.spec
changeset 14643 c3f84f569e31
child 15205 e499ca8139b4
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/base-specs/clutter-gtk.spec	Mon Nov 24 09:55:31 2008 +0000
@@ -0,0 +1,55 @@
+#
+# spec file for package clutter-gtk
+#
+# Copyright 2008 Sun Microsystems, Inc.
+# This file and all modifications and additions to the pristine
+# package are under the same license as the package itself.
+#
+# Owner: bewitche
+#
+
+Summary:      clutter-gtk - GTK+ integration library for clutter
+Name:         clutter-gtk
+Version:      0.8.2
+Release:      1
+License:      GPL
+Group:        System/Libraries
+Distribution: Java Desktop System
+Vendor:       Sun Microsystems, Inc.
+Source:	  http://www.clutter-project.org/sources/clutter-gtk/0.8/clutter-gtk-%{version}.tar.bz2
+URL:          http://www.clutter-project.org/
+BuildRoot:               %{_tmppath}/%{name}-%{version}-build
+
+
+%prep
+%setup -q -n clutter-gtk-%version
+
+%build
+CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
+if test "x$CPUS" = "x" -o $CPUS = 0; then
+    CPUS=1
+fi
+./configure --prefix=%{_prefix}              \
+            --libexecdir=%{_libexecdir}      \
+            --sysconfdir=%{_sysconfdir}      \
+            --disable-static
+make -j$CPUS 
+
+%install
+rm -rf $RPM_BUILD_ROOT
+make install DESTDIR=$RPM_BUILD_ROOT
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr (-, root, bin)
+%dir %attr (0755, root, bin) %{_libdir}
+%{_libdir}/lib*.so*
+
+
+%changelog
+* Tue Jul  1 2008  [email protected]
+- Initial build.
+
+