blueprint.spec
changeset 312 d271fec35241
parent 308 eff1e20509e2
child 397 d973ea38447f
--- a/blueprint.spec	Thu Jun 26 10:29:28 2003 +0000
+++ b/blueprint.spec	Thu Jun 26 12:49:05 2003 +0000
@@ -1,3 +1,5 @@
+#
+# spec file for package blueprint
 #
 # Copyright (c) 2003 Sun Microsystems Inc.
 # This file and all modifications and additions to the pristine
@@ -6,21 +8,18 @@
 
 Name:         blueprint
 Summary:      Engines for GTK2 Blue Print Theme
-Group:        System/GUI/GNOM
-Version:      0.7
-Release:      3
+Version:      0.7.3
+Release:      1 
 License:      GPL
 Distribution: Mercury
 Vendor:	      Sun Microsystems Inc.
-Source:       blueprint-%{version}.tar.bz2
+Group:        System/GUI/GNOME
+Source:       %{name}-%{version}.tar.bz2
 BuildRoot:    %{_tmppath}/%{name}-%{version}-build
 URL:          http://www.gnome.org
-AutoReqProv:  on
 
 %define gtk2_version 2.2.1
 
-BuildRequires: gtk2-devel >= %{gtk2_version}
-
 %description
 The results of this RPM installation should strictly be seen as
 an example of the upcoming Sun Blueprint theme and does in no
@@ -40,10 +39,10 @@
 %setup -q
 
 %build
-CFLAGS="$RPM_OPT_FLAGS" \
-  ./configure \
-	--prefix=%{_prefix}  \
-	--sysconfdir=%{_sysconfdir}
+CFLAGS="$RPM_OPT_FLAGS"
+./configure --prefix=%{_prefix}  \
+	    --libdir=%{_prefix}/%_lib \
+	    --sysconfdir=%{_sysconfdir} 
 make
 cd -
 
@@ -52,6 +51,7 @@
 make DESTDIR=$RPM_BUILD_ROOT install
 mkdir -p $RPM_BUILD_ROOT%{_defaultdocdir}/blueprint-engine
 cp -a AUTHORS COPYING ChangeLog NEWS README $RPM_BUILD_ROOT%{_defaultdocdir}/blueprint-engine
+cp -a index.theme $RPM_BUILD_ROOT%{_prefix}/share/themes/%{name}/
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -63,9 +63,10 @@
 %{_defaultdocdir}/blueprint-engine/COPYING
 %{_defaultdocdir}/blueprint-engine/README
 %{_defaultdocdir}/blueprint-engine/NEWS
-%{_libdir}/gtk-2.0/*/engines/*
-%{_datadir}/themes/*/*
+%{_prefix}/%_lib/gtk-2.0/*/engines/*
+%{_prefix}/share/themes/*/*
 
 %changelog
 * Mon May 12 2003 Erwann Chenede - <[email protected]>
 - initial implementation of the spec file
+