SUNWgnome-a11y-libs.spec
changeset 9546 d3f1546e9b49
parent 9441 24105511a782
child 10017 11acbc57a6bf
--- a/SUNWgnome-a11y-libs.spec	Tue Mar 13 15:51:27 2007 +0000
+++ b/SUNWgnome-a11y-libs.spec	Tue Mar 13 18:32:25 2007 +0000
@@ -145,11 +145,11 @@
 #  I am testing if /usr/java/jre/lib/ is writable as this is the only dir touched by this postinstall script
 #  If there are other dirs that are touched later then need to add them here as well
 LocalZones () {
-    /usr/bin/touch /usr/java/jre/lib/.test.$$ > /dev/null 2>&1
+    /usr/bin/touch  ${BASEDIR}/java/jre/lib/.test.$$ > /dev/null 2>&1
     if [ $? !=	0 ]; then
 	   return 0
     fi
-    rm -f /usr/java/jre/lib/.test.$$ > /dev/null 2>&1
+    rm -f  ${BASEDIR}/java/jre/lib/.test.$$ > /dev/null 2>&1
     ExecuteDefaultCmds
     return $?
 
@@ -455,7 +455,11 @@
 else
    CheckZones
    if [ "${GLOBAL_ZONE}" = "true" ]; then
-	ExecuteDefaultCmds
+        # Call LocalZones() to verify that the /usr/java/jre/lib dir is
+        # writeable before trying to create the symlink and copy the file. The
+	# function name is unfortunate. To minimize changes it is not being
+	# renamed nor this 'if' statement removed. Fixes 6531193.
+	LocalZones
    else
 	LocalZones
    fi
@@ -463,6 +467,7 @@
 
 exit 0
 
+
 %files
 %defattr (-, root, bin)
 %dir %attr (0755, root, bin) %{_bindir}
@@ -503,6 +508,8 @@
 %endif
 
 %changelog
+* Tue Mar 13 2007 - [email protected]
+- Incorporate %post changes from Mary Ding. Fixes 6531193.
 * Mon Mar 05 2007 - [email protected]
 - Add Build/Requires SUNWgnome-config/-devel as gconf-2.0.pc is needed.
 * Fri Sep 01 2006 - [email protected]