glib2.spec
changeset 4365 d8676a6421af
parent 4276 2a2c7f354601
child 4387 1b0580c5041e
--- a/glib2.spec	Fri Oct 29 01:25:47 2004 +0000
+++ b/glib2.spec	Fri Oct 29 01:28:51 2004 +0000
@@ -88,6 +88,10 @@
 
 export CFLAGS="$CFLAGS64"
 export PKG_CONFIG_PATH="$PKG_CONFIG_PATH64"
+export CC=${CC64:-$CC}
+save_PATH="$PATH"
+ccdir=`dirname $CC`
+export PATH=$ccdir:$PATH
 
 ./configure $CONFLAGS					\
 	    --bindir=%{_bindir}/%{_arch64}		\
@@ -100,7 +104,11 @@
 
 cd ../glib-%version
 
+export CC=${CC32:-$CC}
+export PATH="$save_PATH"
 export PKG_CONFIG_PATH="$PKG_CONFIG_PATH32"
+export CFLAGS="$CFLAGS32"
+export RPM_OPT_FLAGS="$CFLAGS"
 %endif
 %endif
 
@@ -165,6 +173,9 @@
 %{_mandir}/man3/*
 
 %changelog
+* Fri Oct 29 2004 - [email protected]
+- use $CC64 for the 64-bit build if defined
+
 * Wed Oct 05 2004 - [email protected]
 - Added glib-04-convert-utf8.diff to fix CR 5055972