libglade.spec
changeset 4365 d8676a6421af
parent 4276 2a2c7f354601
child 4409 4fec71e58697
--- a/libglade.spec	Fri Oct 29 01:25:47 2004 +0000
+++ b/libglade.spec	Fri Oct 29 01:28:51 2004 +0000
@@ -75,6 +75,10 @@
 export CFLAGS="$CFLAGS64"
 export LDFLAGS="$LDFLAGS64"
 export PKG_CONFIG_PATH="$PKG_CONFIG_PATH64"
+export CC=${CC64:-$CC}
+save_PATH="$PATH"
+ccdir=`dirname $CC`
+export PATH=$ccdir:$PATH
 
 libtoolize --force
 aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros
@@ -91,8 +95,12 @@
 
 cd ../libglade-%version
 
+export CFLAGS="$CFLAGS32"
+export RPM_OPT_FLAGS="$CFLAGS"
 export LDFLAGS="$LDFLAGS32"
 export PKG_CONFIG_PATH="$PKG_CONFIG_PATH32"
+export CC=${CC32:-$CC}
+export PATH="$save_PATH"
 
 %endif
 %endif
@@ -146,6 +154,9 @@
 %{_mandir}/man3/*
 
 %changelog
+* Fri Oct 29 2004 - [email protected]
+- use $CC64 for the 64-bit build if defined
+
 * Sat Oct  2 2004 - [email protected]
 - Create 64bit libraries for Solaris