SUNWgnome-games.spec
changeset 11406 f7cca2fe3b26
parent 11402 6645f16b8ab2
child 11429 445e7cd61bfb
--- a/SUNWgnome-games.spec	Mon Jan 07 23:03:50 2008 +0000
+++ b/SUNWgnome-games.spec	Mon Jan 07 23:45:10 2008 +0000
@@ -55,6 +55,12 @@
 Requires: SUNWpostrun-root
 Requires: SUNWgnome-config
 
+#%package devel
+#Summary:                 %{summary} - development files
+#SUNW_BaseDir:            %{_basedir}
+#%include default-depend.inc
+#Requires:                %{name}
+
 %prep
 rm -rf %name-%version
 mkdir %name-%version
@@ -66,7 +72,7 @@
 %define libggz_build_dir %{_builddir}/%name-%version/libggz-%{libggz.version}
 %define ggzmod_build_dir %{_builddir}/%name-%version/ggz-client-libs-%{ggz_client_libs.version}
 export PKG_CONFIG_PATH=%{_pkg_config_path}
-export CFLAGS="%optflags -I%{_includedir} -I/usr/sfw/include -xc99 -I%{libggz_build_dir}/src -I%{ggzmod_build_dir}/ggzmod"
+export CFLAGS="%optflags -I%{_includedir} -I/usr/sfw/include -xc99 -I%{libggz_build_dir}/src -I%{ggzmod_build_dir}/ggzmod -I%{ggzmod_build_dir}/ggzcore"
 export RPM_OPT_FLAGS="$CFLAGS"
 export LDFLAGS="%_ldflags -lX11 -L/usr/sfw/lib -lexpat -L%{libggz_build_dir}/src/.libs -L%{ggzmod_build_dir}/ggzmod/.libs"
 export LD_LIBRARY_PATH="%{libggz_build_dir}/src/.libs:%{ggzmod_build_dir}/ggzmod/.libs"
@@ -86,7 +92,11 @@
 rm -rf $RPM_BUILD_ROOT%{_localstatedir}/lib/games
 rmdir $RPM_BUILD_ROOT%{_localstatedir}/lib
 rmdir $RPM_BUILD_ROOT%{_localstatedir}
+# Delete the include files as we're not delivering a devel package. It's not
+# useful.
 rm -rf $RPM_BUILD_ROOT%{_includedir}
+rm $RPM_BUILD_ROOT%{_libdir}/*.a
+rm $RPM_BUILD_ROOT%{_libdir}/*.la
 
 %if %build_l10n
 %else
@@ -156,6 +166,7 @@
 %{_bindir}/*
 %dir %attr (0755, root, bin) %{_libdir}
 %{_libdir}/gnome-games
+%{_libdir}/libggz*
 %{_libdir}/python?.?/vendor-packages
 %dir %attr (0755, root, sys) %{_datadir}
 %dir %attr (0755, root, other) %{_datadir}/applications
@@ -178,6 +189,18 @@
 %dir %attr (0755, root, other) %{_datadir}/pixmaps
 %{_datadir}/pixmaps/*
 %attr (-, root, other) %{_datadir}/icons
+%{_datadir}/desktop-directories
+%dir %attr(0755, root, bin) %{_mandir}
+%dir %attr(0755, root, bin) %{_mandir}/man1
+%{_mandir}/man1/*
+%dir %attr(0755, root, bin) %{_mandir}/man3
+%{_mandir}/man3/*
+%dir %attr(0755, root, bin) %{_mandir}/man5
+%{_mandir}/man5/*
+%dir %attr(0755, root, bin) %{_mandir}/man6
+%{_mandir}/man6/*
+%dir %attr(0755, root, bin) %{_mandir}/man7
+%{_mandir}/man7/*
 
 %if %build_l10n
 %files l10n
@@ -205,10 +228,18 @@
 %{_sysconfdir}/gconf/schemas/iagno.schemas
 %{_sysconfdir}/gconf/schemas/same-gnome.schemas
 %{_sysconfdir}/gconf/schemas/mahjongg.schemas
+%{_sysconfdir}/xdg
 
+#%files devel
+#%defattr (-, root, bin)
+#%dir %attr (0755, root, bin) %dir %{_includedir}
+#%{_includedir}/*
 
 %changelog
 * Mon Jan 07 2008 - [email protected]
+- Update CFLAGS to find ggzcore.h. Update %files. Add devel package but don't
+  enable it as it is probably not useful.
+* Mon Jan 07 2008 - [email protected]
 - Add variable to specify location of ggzmod sources (in ggz-client-libs) and
   add info to CFLAGS and LDFLAGS.
 * Thu Jan  3 2008 - [email protected]