Solaris/SUNWapoc.spec
changeset 3173 fce529be6620
child 3201 8db12a275a1f
--- /dev/null	Thu Jan 01 00:00:00 1970 +0000
+++ b/Solaris/SUNWapoc.spec	Mon Jun 21 13:46:20 2004 +0000
@@ -0,0 +1,177 @@
+#
+# Copyright (c) 2003 Sun Microsystems Inc.
+# This file and all modifications and additions to the pristine
+# package are under the same license as the package itself.
+#
+
+%include Solaris.inc
+
+%ifarch sparc
+%define PLATFORM unxsols4
+%else
+%define PLATFORM unxsoli4
+%endif
+
+Name:			SUNWapoc
+License:		Sun Microsystems Binary Code License (BCL)
+Group:			User Interface/Desktops
+Version:		1.0
+Distribution:	Cinnabar
+Vendor:			Sun Microsystems, Inc.
+Summary:		Configuration Agent
+URL:			http://sundt.sfbay.sun.com
+Autoreqprov:	off
+BuildRoot:		%{_builddir}/apoc/%{PLATFORM}/class/apocd_pkg
+Source:			apoc-0.1.tar.bz2
+Requires:		SUNWlxml
+Requires:		SUNWgss
+SUNW_ProdName:	Sun Java(tm) Desktop System 
+SUNW_ProdVers:	2
+
+%description
+Sun Java[tm] Desktop System Configuration Agent
+
+%post
+rm -rf /var/opt/SUNWapoc
+
+grep -v apocd /etc/services > /tmp/services
+cp /tmp/services /etc/services
+rm -f /tmp/services
+echo "apocd		38900/udp" >> /etc/services
+
+%preun
+grep -v apocd /etc/services > /tmp/services
+cp /tmp/services /etc/services
+rm -f /tmp/services
+
+/opt/SUNWapoc/bin/apocd disable
+
+%files
+%defattr(0644, root, other)
+%dir %attr(0755,root,sys) /opt
+%dir %attr(0755,root,other) /opt/SUNWapoc
+%dir %attr(0755,root,other) /opt/SUNWapoc/bin
+%dir %attr(0755,root,other) /opt/SUNWapoc/lib
+%attr(0744,root,other) /opt/SUNWapoc/bin/apocd
+/opt/SUNWapoc/lib/apocd.jar
+%config /opt/SUNWapoc/lib/apocd.properties
+/opt/SUNWapoc/lib/db.jar
+/opt/SUNWapoc/lib/ldapjdk.jar
+/opt/SUNWapoc/lib/libFileAccess.so
+/opt/SUNWapoc/lib/libdb_java-3.2.so
+%config /opt/SUNWapoc/lib/os.properties
+/opt/SUNWapoc/lib/policymgr.jar
+%config %attr(0600,root,other) /opt/SUNWapoc/lib/policymgr.properties
+%dir %attr(0755,root,sys) /usr
+%dir %attr(0755,root,bin) /usr/lib
+/usr/lib/libapoc.so
+/usr/lib/libdb-3.2.so
+
+%prep
+%setup -n apoc
+
+%build
+export JAVA_HOME=/usr/j2se
+export PATH=${JAVA_HOME}/bin:$PATH
+make PLATFORM=%{PLATFORM} apoc 
+
+%changelog
+*Mon May 31 2004 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 1.0-0
+	Changes relating to inetd enabled startup
+
+*Tue May 04 2004 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-26
+	Reverting to "inetd enabled install"
+
+*Tue Apr 27 2004 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-25
+	Merging apocd, apocdctl & setenv.sh into apocd
+
+*Mon Apr 26 2004 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-24
+	Including os.properties in apocd.jar to provide correct default
+
+*Thu Apr 15 2004 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-23
+	Turning off Autoreqprov
+
+*Tue Apr 13 2004 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0-1-22
+	Changing name of libapi.so to libapoc.so
+
+*Fri Feb 20 2004 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-20
+	Performance improvements
+
+*Mon Feb 16 2004 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-19
+	Increasing MaxRequestSize to support larger Active Directory tokens
+
+*Mon Feb 11 2004 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-18
+	papi reconnection & GSSAPI/Active Directory support
+
+*Mon Feb 9 2004 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-17
+	ServiceName & ServiceContainer no longer configurable
+
+*Wed Feb 4 2004 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-16
+	Don't overwrite properties files
+
+*Mon Feb 2 2004 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-15
+	Change detection timers
+
+*Fri Jan 30 2004 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-14
+	Exception logging, timers etc.
+
+*Mon Jan 19 2004 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-13
+	Add argument for inetd start
+
+*Tue Jan 13 2004 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-12
+	And back to inetd again
+
+*Mon Dec 22 2003 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-11
+	Switching from inetd to init
+
+*Fri Dec 19 2003 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-10
+	Changing policymgr.properties permissions
+
+*Mon Dec 1 2003 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-9
+	Update license
+
+*Thu Nov 27 2003 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-8
+	Fix for 4960347
+
+*Tue Nov 20 2003 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-7
+	Moving back to berkeley db 4 due to incompatability with StarOffice
+
+*Tue Nov 18 2003 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-6
+	YaST modules moved to seperate rpm
+
+*Fri Nov 14 2003 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-5
+	Moving to berkeley db version 4
+
+*Wed Nov 12 2003 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-4
+	Fix for 4952794
+
+*Thu Nov 6 2003 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-2
+	Feature complete apocd
+
+*Fri Jul 11 2003 Geoff Higgins <geoff.higgins@@sun.com>
+	Version 0.1-1
+	Initial apocd