gnome-menus.spec
author laca
Thu, 27 Oct 2005 20:17:24 +0000
changeset 6193 011617068c65
parent 5943 5a45a5c3d49e
child 6200 19ff8721b8f2
permissions -rw-r--r--
2005-10-27 Laszlo Peter <[email protected]> * Pyrex.spec: move to vendor-packages from site-packages * gnome-menus.spec: move to vendor-packages from site-packages * gnome-python.spec: move to vendor-packages from site-packages; include pyc files * orca.spec: move to vendor-packages from site-packages * planner.spec: move python module to vendor-packages * pygtk2.spec: move to vendor-packages * pyorbit.spec: move to vendor-packages * pyspi.spec: move to vendor-packages * python.spec: add vendor-packages dir; add a pth file to site-packages that tells python to search for modules in the vendor-packages directory too * patches/Python-01-solaris-lib-dirs.diff: new. update setup.py to search for some directories in /usr/sfw and to not search for anything in /usr/local. * vte.spec: move the python module to vendor-packages 2005-10-26 Laszlo Peter <[email protected]> * db_evo.spec: remove. unused. * docs/jds-branches.html: update to include gnome-2-12 branch

#
# spec file for package gnome-menus
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:			gnome-menus
License:		LGPL
Group:			System/GUI/GNOME
Version:		2.12.0
Release:		1
Distribution:		Java Desktop System
Vendor:			Sun Microsystems, Inc.
Summary:		Implementation of Desktop Menu Specification for GNOME
Source:			http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.12/%{name}-%{version}.tar.bz2
URL:			http://www.gnome.org
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
Docdir:			%{_defaultdocdir}/%{name}
Autoreqprov:		on
Prereq:                 /sbin/ldconfig
Prereq:                 GConf

%define gnome_vfs_version 2.8.2
%define pygtk2_version 2.7.0
%define python_version 2.4

Requires: pygtk2 >= %{pygtk2_version}
BuildRequires: pygtk2 >= %{pygtk2_version}
BuildRequires: gnome-vfs >= %{gnome_common_version}
BuildRequires: intltool

%description
This package implements the freedesktop.org desktop menu specification for the GNOME
desktop. Also contained in this package, are the menu layout configuration files, .directory
and assorted menu utility programs.

%package devel
Summary:      Implementation of Desktop Menu Specification for GNOME
Group:        System/Libraries/GNOME
Autoreqprov:  on
Requires:     %name = %version
Requires:     gnome-vfs-devel >= %{gnome_vfs_version}

%description devel
This package implements the freedesktop.org desktop menu specification for the GNOME
desktop. Also contained in this package, are the menu layout configuration files, .directory
and assorted menu utility programs.

%prep
%setup -q

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

aclocal $ACLOCAL_FLAGS
automake -a -c -f
autoconf
./configure --prefix=%{_prefix}			\
	    --sysconfdir=%{_sysconfdir}		\
            --mandir=%{_mandir}
make -j $CPUS \
    pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
    pythondir=%{_libdir}/python%{python_version}/vendor-packages

%install
make DESTDIR=$RPM_BUILD_ROOT install \
    pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
    pythondir=%{_libdir}/python%{python_version}/vendor-packages
find $RPM_BUILD_ROOT -type f -name "*.a" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.pyc" -exec rm -f {} ';'
# FIXME: Giga-hack part 1 of 2 follows...
# file /etc/xdg/menus/applications.menu conflicts with desktop-data-SLES
# Only on SuSE Linux !!
%ifos linux
mv $RPM_BUILD_ROOT%{_sysconfdir}/xdg/menus/applications.menu \
   $RPM_BUILD_ROOT%{_sysconfdir}/xdg/menus/applications.menu.new
%endif

%post
/sbin/ldconfig
# FIXME: Giga-hack part 2 of 2 follows...
# file /etc/xdg/menus/applications.menu conflicts with desktop-data-SLES
MENU=/etc/xdg/menus/applications.menu
cp $MENU $MENU.SuSE
cp $MENU.new $MENU

%postun
/sbin/ldconfig

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-,root,root)
%{_bindir}/*
%{_libdir}/libgnome-menu.so.*
%{_datadir}/desktop-directories/*
%config %{_sysconfdir}/xdg/menus/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/applications/*.desktop
%{_datadir}/gnome-menus
%{_libdir}/python2.4/

%files devel
%defattr(-, root, root)
%{_libdir}/pkgconfig/*
%{_libdir}/libgnome-menu.so
%{_includedir}/gnome-menus/*

%changelog
* Sat Sep 17 2005 - [email protected]
- Bump to 2.12.0

* Wed Aug 24 2005 - [email protected]
- remove upstream patch

* Mon Aug 15 2005 - [email protected]
- Bump to 2.11.91.

* Fri May 13 2005 - [email protected]
- Add unisntalled-pc files since they are needed on Solaris to build.

* Tue May 10 2005 - [email protected] 
- Initial spec file for gnome-menus