zenity.spec
author dc144907
Thu, 31 Mar 2005 16:32:27 +0000
changeset 5295 0285b58535ed
parent 5285 0adbc5030bb3
child 5333 817fa62bc95d
permissions -rw-r--r--
* bug-buddy.spec, gnome-utils.spec, zenity.spec: Updated docs tarballs from [email protected].

#
# spec file for package zenity
#
# Copyright (c) 2003 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#


Name:         zenity
License:      LGPL
Group:        System/GUI/GNOME
Version:      2.6.0
Release:      34
Distribution: Java Desktop System, Release 3
Vendor:       Sun Microsystems, Inc.
Summary:      Show graphical dialog boxes from scripts
Source:       http://ftp.gnome.org/pub/GNOME/sources/zenity/2.6/%{name}-%{version}.tar.bz2
Source1:      l10n-configure.sh
Source2:      zenity-l10n-po-1.14.tar.bz2
Source3:      zenity.1.gz
Source4:      gdialog.1.gz
Source5:      zenity-l10n-online-help-ci-linux-1.1.tar.bz2
Source6:      zenity-docs-0.2.tar.bz2
Source7:      zenity-docs-0.3linux.tar.bz2
Patch1:	      zenity-01-l10n-online-help.diff
Patch2:	      zenity-02-icon-size-crash.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on

%define gtk2_version 2.3.1
%define libgnomecanvas_version 2.4.0
%define GConf_version 2.4.0.1
%define libglade_version 2.3.1
%define popt_version 1.6.4
%define scrollkeeper_version 0.3.12

Requires:	gtk2 >= %{gtk2_version}
Requires:	libgnomecanvas >= %{libgnomecanvas_version}
Requires:	GConf >= %{GConf_version}
Requires:	libglade >= %{libglade_version}
BuildRequires:  gtk2-devel >= %{gtk2_version}
BuildRequires:  libgnomecanvas-devel >= %{libgnomecanvas_version}
BuildRequires:  GConf-devel >= %{GConf_version}
BuildRequires:  libglade-devel >= %{libglade_version}
BuildRequires:  popt-devel >= %{popt_version}
BuildRequires:  scrollkeeper >= %{scrollkeeper_version}
BuildRequires:  javahelp-convert

%description
Show graphical dialog boxes from the commandline or through scripts. Zenity is a 
predecessor to dialog.

%prep
%setup -q

%ifos solaris
bzcat %SOURCE6 | tar xf -
%else
bzcat %SOURCE7 | tar xf -
%endif
bzcat %SOURCE2 | tar xf -
bzcat %SOURCE5 | tar xf -
%patch1 -p1
%patch2 -p1

bash -x %SOURCE1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros
automake -a -c -f
autoconf
CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
	--prefix=%{_prefix} \
	--sysconfdir=%{_sysconfdir} \
	--mandir=%{_mandir}
make -j $CPUS

%install
make -i install DESTDIR=$RPM_BUILD_ROOT
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE4 $RPM_BUILD_ROOT%{_mandir}/man1
#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/

javahelp-convert-install $RPM_BUILD_ROOT %{name} %{name}.xml

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, root)
%{_bindir}/*
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/omf/zenity
%{_datadir}/zenity/*
%{_datadir}/gnome/help
%{_datadir}/gnome/javahelp
%{_mandir}/man1/*

%changelog
* Thu Mar 31 2005 - [email protected]
- Updated docs tarball (zenity-docs-0.3linux) from [email protected].

* Fri Jan 14 2005 - [email protected]
- Updated l10n help tarball for cinnabar-linux
                                                                                
* Thu Oct 28 2004 - [email protected]
- Updated l10n help tarball and added pt_BR

* Tue Aug 24 2004 - [email protected]
- fixed man page file list issue
* Fri Aug 20 2004 - [email protected]
- Integrated updated docs tarball from [email protected].

* Thu Aug 05 2004 - [email protected]
- Integrated docs tarball from [email protected]

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to zenity-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed Jun  2 2004 - [email protected]
- Added %SOURCE1 to install l10n messages
* Wed May 12 2004 - [email protected]
- Updated l10n content to zenity-l10n-po-1.1.tar.bz2

* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris

* Thu Apr 01 2004 - [email protected]
- Javahelp conversion

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to zenity-l10n-po-1.0.tar.bz2

* Tue Mar 23 2004 - [email protected]
- Bump to 2.6.0

* Wed Mar 17 2004 - [email protected]
- re-autotoolize to pick up fixed glib-gettext macros needed on Solaris

* Tue Mar 15 2004 - [email protected]
- Remove man page patch since we do this 
  with %files.

* Tue Feb 24 2004 - [email protected]
- Update tarball to 2.5.2

* Wed Dec 17 2003 - [email protected]
- Update tarball to 1.7

* Mon Oct 13 2003 - [email protected]
- Update tarball

* Mon Aug 11 2003 - [email protected]
- Update tarball

* Fri Jul 25 2003 - [email protected]
- Requires scrollkeeper for postinstall. Add a dependency

* Tue Jul 01 2003 - [email protected]
- Initial Sun release