eel.spec
author dermotm
Mon, 25 Apr 2005 09:26:30 +0000
changeset 5370 06fd4677e6e3
parent 5333 817fa62bc95d
child 5414 219255e89582
child 19279 83c4cb5d8638
permissions -rw-r--r--
Incremented release numbers for build 34

Name:         eel
License:      LGPL
Group:        System/Libraries/GNOME
Version:      2.6.1
Release:      37
Distribution: Java Desktop System, Release 3
Vendor:       Sun Microsystems, Inc.
Summary:      Eazel Extensions Library
Source:       http://ftp.gnome.org/pub/GNOME/sources/eel/2.6/eel-%{version}.tar.bz2
Source1:      eel-l10n-po-1.14.tar.bz2
Source2:      l10n-configure.sh
URL:          http://www.gnome.org
Patch1:       eel-01-multibyte-bookmark-menu.diff	
Patch2:       eel-02-assertion.diff
Patch3:       eel-03-popup-menu-i18n.diff
Patch4:       eel-04-gok-crash.diff
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/doc
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%define libgnomeui_version 2.6.0
%define librsvg_version 2.5.0
%define libxml2_version 2.6.7
%define gnome_vfs_version 2.6.0
%define gail_version 1.6.3
%define GConf_version 2.6.1

BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: librsvg-devel >= %{librsvg_version}
BuildRequires: gail-devel >= %{gail_version}
Requires: libgnomeui >= %{libgnomeui_version}
Requires: librsvg >= %{librsvg_version}
Requires: gail >= %{gail_version}

%description
This library extends the Gtk+ library with some useful routines for
applications like Nautilus.

%package devel
Summary:      Eazel Extensions Development Library
Group:        Development/Libraries/GNOME
Requires:     %{name} = %{version}
Requires:     libxml2-devel >= %{libxml2_version}
Requires:     gnome-vfs-devel >= %{gnome_vfs_version}
Requires:     GConf-devel >= %{GConf_version}

%description devel
This library extends the Gtk+ library with some useful routines for
applications like Nautilus.

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1

bzcat %SOURCE1 | tar xvf -

bash -x %SOURCE2

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}		\
	    --sysconfdir=%{_sysconfdir}
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
rm $RPM_BUILD_ROOT%{_libdir}/*.la
                                                                                                                                                             
%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%defattr (-, root, root)
%{_libdir}/*.so.*
%{_datadir}/locale/*/LC_MESSAGES/*.mo

%files devel
%defattr (-, root, root)
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
%{_includedir}/eel-2

%changelog
* Wed Mar 23 2005 - [email protected]
- Added patch eel-04-gok-crash.diff to fix nautilus crash when 
  folder is opened with gok. Fixes bug #6234837.

* Tue Feb 15 2005 - [email protected]
- Added patch eel-03-popup-menu-i18n.diff to translate "Select All"
  and "Input Methods" messages in nautilus. Fixes bug #5072488.

* Tue Jan 25 2005 - [email protected]
- Added patch eel-02-assertion.diff to fix assertion failure
  messages in nautilus. Fixes bug #4899270.

* Mon Dec 08 2004 - [email protected]
- Added patch #01 to fix the cutoff of long multibyte directory
  bookmarks. Fixes bug #6184582. Applied to linux trunk only.

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to eel-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- ported to rpm4
                                                                                
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed May 12 2004 - [email protected]
- Updated l10n content to eel-l10n-po-1.1.tar.bz2

* Fri May 07 2004 - <[email protected]>
- Bump to 2.6.1

* Thu Apr 15 2004 - <[email protected]>
- Bump to 2.6.0

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to eel-l10n-po-1.0.tar.bz2

* Tue Mar 16 2004 - <[email protected]>
- Bump to 2.5.91

* Wed Mar 10 2004 - <[email protected]>
- Bump to version 2.5.90 and update dependency pkg versions to something
  a bit more recent.
- Remove patches, they are merged into the lastest version.

* Wed Feb 18 2004 - <[email protected]>
- Updated l10n tarball to 0.8

* Tue Feb 17 2004 - <[email protected]>
- new tarball, removed patch #3

* Thu Feb 12 2004 - <[email protected]>
- added patches 01, 02 and 03: compilation fixes, add a -uninstalled-pc file,
  fix errors in Makefile.am
- autotoolize the build stage

* Wed Jan 07 2004 - <[email protected]>
- Updated to 2.5.4

* Tue Dec 16 2003 - <[email protected]>
- Updated to 2.5.3

* Mon Oct 13 2003 - <[email protected]>
- Updated to 2.4 

* Thu Aug 14 2003 - <[email protected]>
- remove *.a, *.la

* Wed Jul 09 2003 - <[email protected]>
- add in sun po files

* Thu Jul 03 2003 - [email protected]
- version 2.2.4
* Thu May 01 2003 - [email protected]
- initial Sun release.