bug-buddy.spec
author feyn
Tue, 29 Mar 2005 15:22:24 +0000
changeset 5285 0adbc5030bb3
parent 5281 67ebf8abba9e
child 5295 0285b58535ed
permissions -rw-r--r--
2005-03-29 Kazuhiko Maekawa <[email protected]> * Updated l10n help tarballs with version 1.1

Name:         bug-buddy
License:      GPL
Group:        System/GUI/GNOME
Version:      2.6.1
Release:      33
Distribution: Java Desktop System, Release 3
Vendor:       Sun Microsystems, Inc.
Summary:      GNOME 2.0 Bug Reporting Tool
Source:       http://ftp.gnome.org/pub/GNOME/sources/bug-buddy/2.6/bug-buddy-%{version}.tar.bz2
Source1:      bug-buddy-l10n-po-1.8.tar.bz2
Source2:      bug-buddy.1.gz
Source3:      l10n-configure.sh
Source4:      bug-buddy-l10n-online-help-ci-linux-1.1.tar.bz2
Source5:      bug-buddy-docs-0.4.tar.bz2
Source6:      bug-buddy-docs-0.5linux.tar.bz2
Patch1:       bug-buddy-01-g11n-potfiles.diff
Patch2:       bug-buddy-02-l10n-online-help.diff
Patch3:       bug-buddy-03-bug-reporting.diff

URL:          www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_docdir}/bug-buddy
Autoreqprov:  on

%define libgnomeui_version 2.6.0
%define scrollkeeper_version 0.3.14
%define gnome_desktop_version 2.6.1

BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: gnome-desktop >= %{gnome_desktop_version}
BuildRequires: scrollkeeper >= %{scrollkeeper_version}
BuildRequires: javahelp-convert
Requires: libgnomeui >= %{libgnomeui_version}

%description
Bug Buddy for the GNOME 2.6 Desktop has been ported from the GNOME 1.x releases. Its purpose is to make bug-reporting for end-users as easy as possible. It can generate backtraces of crashes and include the information with the bugreport.

%prep
%setup -q
bzcat %SOURCE1 | tar xf -
%ifos solaris
bzcat %SOURCE5 | tar xf -
%else
bzcat %SOURCE6 | tar xf -
%endif
bzcat %SOURCE4 | tar xf -
%patch1 -p1
%patch2 -p1
%patch3 -p1

bash -x %SOURCE3

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS" \
./configure --prefix=%{_prefix} \
            --sysconfdir=%{_sysconfdir} \
	    --mandir=%{_mandir}
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/man1
#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/

javahelp-convert-install $RPM_BUILD_ROOT %{name} %{name}.xml
rm $RPM_BUILD_ROOT%{_datadir}/applications/bug-buddy.desktop
rm $RPM_BUILD_ROOT%{_datadir}/bug-buddy/ximian.png

%clean
rm -rf $RPM_BUILD_ROOT

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="bug-buddy.schemas"
for S in $SCHEMAS; do
        gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%files
%doc AUTHORS COPYING ChangeLog NEWS README
%defattr (-, root, root)
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/bug-buddy/bug-buddy.*
%{_datadir}/bug-buddy/gdb-cmd
%{_datadir}/bug-buddy/gnome.png
%{_datadir}/bug-buddy/bugzilla/*
%{_datadir}/gnome/help/bug-buddy/*
%{_datadir}/gnome/javahelp/bug-buddy/*
%{_datadir}/mime-info/*
%{_bindir}/bug-buddy
%{_datadir}/omf/bug-buddy/*.omf
%{_datadir}/pixmaps/*.png
%{_datadir}/man/man1/bug-buddy.1.gz
%{_sysconfdir}/gconf/schemas/bug-buddy.schemas
%{_datadir}/application-registry/*.applications
 

%changelog
* Wed Feb 09 2005 - [email protected]
- Integrated updated Linux specific docs tarball from [email protected].
  Added %ifos to accomodate this.

* Thu Jan 27 2005 - [email protected]
- Put l10n help tarball for Cinnabar-linux

* Tue Jan 25 2005 - [email protected]
- Bring back bug-buddy into the Linux build, removing and merging
  some patches.

* Mon Nov 08 2004 - [email protected]
- Added bug-buddy-05-use-pstack.diff to use pstack to get the stack 
  trace on Solaris as gdb is not available. Fixes bug #5102045.

* Wed Aug 25 2004 - [email protected]
- Added l10n help contents with patch

* Fri Aug 20 2004 - [email protected]
- Integrated updated docs tarball from [email protected].

* Thu Aug 05 2004 - [email protected]
- Integrated docs tarball from [email protected]
- Added patch to compensate for Makefiles removed from new tarball.

* Wed Jul 21 2004 - [email protected]
- Add patch to remove --export-dynamic which breaks Solaris build.
- Add $ACLOCAL_FLAGS to build on Solaris.

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to bug-buddy-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- ported to rpm4
                                                                                
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed May 12 2004 - [email protected]
- Updated l10n content to bug-buddy-l10n-po-1.1.tar.bz2

* Fri May 07 2004 - [email protected]
- Bump to 2.6.1

* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris

* Thu Apr 01 2004 - [email protected]
- javahelp conversion

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to bug-buddy-l10n-po-1.0.tar.bz2

* Wed Mar 24 2004 - [email protected]
- Bump to 2.6.0

* Tue Mar 16 2004 - [email protected]
- Bump to 2.5.92. Remove localized online help since it's upstream
  in the tarball. Remove help button since we're working from head
  and we'll get it with the next iteration. Remove random branding
  in the user interface, just increases more time spent doing pointless
  localizations. Remove the ximian branding patch, since it needs to be
  redone, and we shouldn't do the sendmail edits in that patch.

* Tue Mar 16 2004 - [email protected]
- Removed man, menu patches since we're doing this in spec file now.
  Merged potfile patches and reorder the rest.

* Thu Mar 11 2004 - [email protected]
- added bug-buddy-09-g11n-potfiles.diff

* Wed Mar 03 2004 - [email protected]
- Added patch bug-buddy-08-enable-help.diff to provide help.

* Mon Feb 23 2004 - [email protected]
- Bump to 2.5.3, update l10n
- Re-merge all patches

* Wed Dec 17 2003 - [email protected]
- Bump to 2.5.1

* Thu Nov 13 2003 - [email protected]
- Remove menu entry

* Fri Oct 10 2003 - [email protected]
- Updated to version 2.4.0

* Thu Oct 9 2003 - [email protected]
- removed %post, fixed %files list and removed ximian.png.

* Wed Sep 17 2003 - [email protected]
- Man page change, package tarball version of man page

* Tue Aug 19 2003 - [email protected]
- add bug-buddy-04-remove-ximian-druid-pages.diff

* Tue Aug 05 2003 - [email protected]
- add bug-buddy-03-sensical-check-removed.diff

* Tue Aug 05 2003 - [email protected]
- Update tarball, bump version, reset release.

* Fri Aug 01 2003 - [email protected]
- Add menu category thing

* Tue May 13 2003 - [email protected]
- initial Sun Release