Solaris/SUNWgnome-cd-burner.spec
author laca
Sat, 02 Oct 2004 23:26:05 +0000
changeset 4122 0c938071234a
parent 3889 7d8feb81d21c
child 5518 235b0b4aa324
permissions -rw-r--r--
2004-10-03 Laszlo Peter <[email protected]> * SUNWPython.spec, SUNWTiff.spec, SUNWacroread.spec, SUNWapoc-adapter-gconf.spec, SUNWaspell.spec, ...... ..... SUNWogg-vorbis.spec, SUNWperl-xml-parser.spec, SUNWpng.spec: add %pkgbuild_postprocess so that binaries are stripped, ELF .comments set and sane permissions set. * SUNWopenjade.spec: add %pkgbuild_postprocess, move to /usr/sfw * SUNWopensp.spec: add %pkgbuild_postprocess, move to /usr/sfw * Solaris.inc: define jds_version macro (=JDS3) * cron-script.sh: mail log to gnome-re and only include warnings, errors and summary

#
# spec file for package SUNWgnome-cd-burner
#
# includes module(s): gnome-cd-burner
#
# Copyright (c) 2004 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include Solaris.inc

%define makeinstall make install DESTDIR=$RPM_BUILD_ROOT
%use cd_burner = nautilus-cd-burner.spec

Name:                    SUNWgnome-cd-burner
Summary:                 GNOME CD Burner
Version:                 2.6.0
Source:                  nautilus-cd-burner.1
SUNW_BaseDir:            %{_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWgnome-libs
Requires: SUNWgnome-base-libs
Requires: SUNWgnome-file-mgr

%package share
Summary:                 GNOME CD Burner - platform independent files, /usr/share
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: SUNWperl584usr

%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}

%package root
Summary:                 GNOME CD Burner - platform dependent files, / filesystem
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWgnome-libs

%prep
rm -rf %name-%version
mkdir %name-%version
%cd_burner.prep -d %name-%version

%build
export PKG_CONFIG_PATH=%{_pkg_config_path}
export MSGFMT="/usr/bin/msgfmt"
export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
export PERL5LIB=%{_prefix}/perl5/site_perl/5.6.1/sun4-solaris-64int
export CFLAGS="%optflags -I%{_includedir}"
export RPM_OPT_FLAGS="$CFLAGS"

%cd_burner.build -d %name-%version

%install
%cd_burner.install -d %name-%version
export GCONF_CONFIG_SOURCE=xml::$RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults
for S in $RPM_BUILD_ROOT/%{_sysconfdir}/gconf/schemas/*.schemas; do
  %{_bindir}/gconftool-2 --makefile-install-rule $S >/dev/null
done
chmod -R a+rX $RPM_BUILD_ROOT/%{_sysconfdir}
rm -rf $RPM_BUILD_ROOT%{_mandir}
install -d $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0755 %SOURCE0 $RPM_BUILD_ROOT%{_mandir}/sman1

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):supported" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, other)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/gnome-vfs-2.0/modules/lib*.so*
%{_libdir}/nautilus/extensions-1.0/lib*.so*
%{_libexecdir}/mapping-daemon

%files share
%defattr (-, root, other)
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/nautilus-cd-burner
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*
%{_mandir}/*/*

%files l10n
%defattr (-, root, other)
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/locale

%files root
%dir %attr(0755, root, sys) %{_sysconfdir}
%defattr (-, root, other)
%dir %{_sysconfdir}/gconf
%dir %{_sysconfdir}/gconf/schemas
%dir %{_sysconfdir}/gconf/gconf.xml.defaults
%dir %{_sysconfdir}/gconf/gconf.xml.defaults/apps
%dir %{_sysconfdir}/gconf/gconf.xml.defaults/schemas
%dir %{_sysconfdir}/gconf/gconf.xml.defaults/schemas/apps
%dir %{_sysconfdir}/gnome-vfs-2.0
%{_sysconfdir}/gconf/schemas/ncb.schemas
%{_sysconfdir}/gconf/gconf.xml.defaults/apps/nautilus-cd-burner
%{_sysconfdir}/gconf/gconf.xml.defaults/schemas/apps/nautilus-cd-burner
%{_sysconfdir}/gnome-vfs-2.0/modules
%defattr (-, root, sys)

%changelog
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Thu Sep 09 2004 - [email protected]
- Added nautilus-cd-burner.1 manpage
* Mon Aug 23 2004 - [email protected]
- s/SUNWpl5u/SUNWperl584usr/
* Sat Jun 26 2004  [email protected]
- Changed install location to /usr/...
* Wed Jun 23 2004 - [email protected]
- Remove 'devel' package because no files assigned to it.
* Wed Jun  2 2004 - [email protected]
- Added %{_datadir}/locale to install l10n messages
* Tue May 11 2004 - [email protected]
- add SUNWgnome-file-mgr dependency
* Mon May 03 2004 - [email protected]
- fix directory permissions
* Thu Apr 15 2004 - [email protected]
- Created