gdm.spec
author dc144907
Thu, 19 Aug 2004 12:54:19 +0000
changeset 3627 0d38058536e2
parent 3580 39da785696b5
child 3628 cf6118e136d2
permissions -rw-r--r--
* gnome-pilot.spec, gdm.spec: Integrated updated docs tarball from [email protected]. * gnome-user-docs.spec: Integrate updated docs tarball from [email protected]. Update patch for additional file. * patches/gnome-user-docs-07-access_guide.diff: Update to add new file.

#
# Copyright (c) 2003 Sun Microsystems Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

Name:         gdm
License:      GPL
Group:        System/GUI/GNOME
Version:      2.6.0.3
Release:      18
Distribution: Cinnabar
Vendor:       Sun Microsystems Inc.
Summary:      The GNOME 2.x Display Manager
Source:       http://ftp.gnome.org/pub/GNOME/sources/gdm/2.4/gdm-%{version}.tar.bz2
Source1:      gdm-l10n-po-1.3.tar.bz2
Source2:      gdm-docs-0.3.tar.bz2
Patch1:	      gdm-01-branding-defaults.diff
Patch2:	      gdm-02-pam-security-setup.diff
Patch3:       gdm-03-locale-alias.diff
Patch4:       gdm-04-zh-hk-greeter-languages.diff
Patch5:       gdm-05-normalise-locale-xiim-broken-filenames.diff
Patch6:       gdm-06-fix-garbled-language-dialog.diff
Patch7:       gdm-07-set-lc-messages-to-lang.diff
Patch10:      gdm-10-a11y-gestures.diff
Patch11:      gdm-11-g11n-truncated-username.diff
Patch12:      gdm-12-docs-figures.diff
Patch13:      gdm-13-config-options.diff
Patch14:      gdm-14-jds-registration.diff
Patch15:      gdm-15-default-path.diff
Patch16:      gdm-16-reboot-shutdown-option.diff
Patch17:      gdm-17-audit.diff

URL:          www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}
Autoreqprov:  on
Prereq:       /usr/sbin/groupadd
Prereq:       /usr/sbin/useradd
Prereq:       /sbin/nologin

%define pango_version 1.4.0
%define gtk2_version 2.4.0
%define libglade_version 2.3.6
%define libgnomeui_version 2.6.0
%define libgnomecanvas_version 2.6.0
%define librsvg_version 2.5.0
%define libxml2_version 2.6.6
%define scrollkeeper_version 0.3.14
%define pam_version 0.76
%define gail_version 1.6.0
%define XFree86_version 4.3.0
%define usermode_version 1.68
%define openssl_version 0.9.6g

Requires: gtk2 >= %{gtk2_version}
Requires: sun-gdm-themes
Requires: libglade >= %{libglade_version}
Requires: libgnomeui >= %{libgnomeui_version}
Requires: libgnomecanvas >= %{libgnomecanvas_version}
Requires: librsvg >= %{librsvg_version}
Requires: libxml2 >= %{libxml2_version}
Requires: pam >= %{pam_version}
Requires: usermode >= %{usermode_version}
Requires: openssl >= %{openssl_version}

BuildRequires: scrollkeeper >= %{scrollkeeper_version}
BuildRequires: javahelp-convert
BuildRequires: pango-devel >= %{pango_version}
BuildRequires: gtk2-devel >= %{gtk2_version}
BuildRequires: libglade-devel >= %{libglade_version}
BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: libgnomecanvas-devel >= %{libgnomecanvas_version}
BuildRequires: librsvg-devel >= %{librsvg_version}
BuildRequires: libxml2-devel >= %{libxml2_version}
BuildRequires: pam-devel >= %{pam_version}
BuildRequires: XFree86-devel >= %{XFree86_version}
BuildRequires: gail-devel >= %{gail_version}
BuildRequires: usermode >= %{usermode_version}
BuildRequires: openssl-devel >= %{openssl_version}

%description
This version of GDM, the GNOME Display manager is based on
GTK2 and suited for the GNOME 2.4 Desktop Environment. GDM
is a flexible X-Window Display Manager that allows to set
many options, usable for remote login, and provides a good
looking graphical interface.

%prep
%setup -q
bzcat %SOURCE1 | tar -xf -
bzcat %SOURCE2 | tar -xf -
bzcat %SOURCE3 | tar -xf -
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch10 -p0
%patch11 -p1
%patch12 -p1
%patch13 -p1
%patch14 -p1
%patch15 -p1
%patch16 -p1
%patch17 -p1

# Temporarily disabling ipv6 since the chooser doesn't yet
# work with IPv6 turned on.
%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

export CFLAGS="$RPM_OPT_FLAGS"
autoheader
autoconf

ENABLE_CONSOLE_HELPER=
%ifos linux
ENABLE_CONSOLE_HELPER="--enable-console-helper"
%endif

./configure \
	--prefix=%{_prefix} \
	--sysconfdir=%{_sysconfdir}/X11 \
	--localstatedir=%{_localstatedir}/lib \
	--mandir=%{_mandir} \
	--with-pam-prefix=%{_sysconfdir} \
	--libexecdir=%{_libexecdir} \
	--enable-ipv6=no $ENABLE_CONSOLE_HELPER
make -j $CPUS

%install
make install DESTDIR=$RPM_BUILD_ROOT
# no flexiserver thing, Xnest is too broken ??
# rm -f $RPM_BUILD_ROOT%{_datadir}/applications/gdmflexi*.desktop

javahelp-convert-install $RPM_BUILD_ROOT %{name} %{name}.xml

%clean
rm -rf $RPM_BUILD_ROOT

%pre
/usr/sbin/groupadd -r -g 50 gdm
/usr/sbin/useradd -r -o -g gdm -u 50 -s /sbin/nologin \
-c "Gnome Display Manager daemon" -d /var/lib/gdm gdm 2> /dev/null || :

%files
%config %attr(-,gdm,gdm) %{_sysconfdir}/X11/gdm
%config %attr(-,root,root) %{_sysconfdir}/X11/dm
%{_datadir}/locale/*/LC_MESSAGES/gdm*.mo
%{_sbindir}/*
%{_bindir}/*
%{_libdir}/gtk-2.0/modules/*.so
%{_libexecdir}/*
%{_datadir}/gdm
%{_datadir}/applications/*
%{_datadir}/pixmaps/*.png
%{_datadir}/gnome/help/*
%{_datadir}/gnome/javahelp/*
%{_datadir}/xsessions/*
%{_mandir}/man1/*
%{_datadir}/omf/*
%attr(-,gdm,gdm) /var/lib/gdm
%config /etc/pam.d/*
%config /etc/security/*

%changelog
* Thu Aug 19 2004 - [email protected]
- Integrate updated docs tarball from [email protected].

* Fri Aug 13 2004 - [email protected]
- Update patch gdm-10-a11y-gestures.diff.  Fixes bug #5067111.

* Thu Jul 29 2004 - [email protected]
- use version 2.6.0.3 (fix for bugzilla 144920 and related GOK problem)
- remove patches gdm-08-gdmtranslate.diff and gdm-09-fix-which.diff,
  since they are included in 2.6.0.3.

* Thu Jul 22 2004 - [email protected]
- add patch to remove reboot/shutdown option on Solaris box

* Thu Jul 22 2004 - [email protected]
- add patch gdm-15-default-path.diff to add /usr/dt/bin and /usr/sfw/bin
  to PATH for Solaris. 

* Wed Jul 14 2004 - [email protected]
- add patch from Johan to invoke jds registration on first login

* Thu Jul 08 2004 - [email protected]
- add patch to pass X server options instead of hardcoding 
  it in the gdm.conf.in

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed Jun 23 2004 - [email protected]
- Update a11y-gestures patch to add HAVE_XINPUT to acconfig.h.
  Remove xdmcp-enable patch (10) for app security reasons and move 13 to 10.

* Thu Jun 10 2004 - [email protected]
- Add patch 12 to add 'docs/C/figures' directory to the build.

* Mon May 31 2004 - [email protected]
- bump to 2.6.0.2

* Wed May 12 2004 - [email protected]
- Updated l10n content to gdm-l10n-po-1.1.tar.bz2

* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris

* Thu Apr 08 2004 - <[email protected]>
- bumped to 2.6.0.0 and updated dependencies

* Sat Apr 03 2004 - [email protected]
- added gdm-11-g11n-truncated-username.diff to fix 4955151

* Thu Apr 01 2004 - [email protected]
- javahelp conversion

* Wed Mar 31 2004 - <[email protected]>
- updated gdm-03-locale-alias.diff to fix 4884887

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to gdm-l10n-po-1.0.tar.bz2

* Tue Mar 23 2004 - <[email protected]>
- Remove photo setup from %files since we didn't want it part of the 
  menus by default [$datadir/gnome/capplets/..]

* Mon Mar 22 2004 - <[email protected]>
- simplify %build

* Fri Mar 19 2004 - <[email protected]>
- Move autoheader and autoconf out of the platform specific section because
  it is common to both platforms.

* Fri Mar 19 2004 - <[email protected]>
- Change '\' to ';' so autoheader and autoconf run separately.

* Thu Mar 18 2004 - <[email protected]>
- Add patch 8 that fixes gdmtranslate so it compiles with -g, add
  patch 9 to fix scripts so that they don't call which (since which
  doesn't work on Solaris without an associated TTY), and add patch
  10 to turn on XDMCP support by default.

* Tue Mar 09 2004 - <[email protected]>
- bump to 2.5.90.2

* Mon Mar 01 2004 - <[email protected]>
- s$/usr/share$%{_datadir}$

* Thu Feb 26 2004 - <[email protected]>
- Fix small typos in description and change tar commmand to bzcat/tar.
- Remove --enable-console-helper on Solaris.

* Fri Feb 06 2004 - <[email protected]>
- Bump to 2.5.90.0, add docs, and ported QS patches

* Wed Jan 07 2004 - <[email protected]>
- Update to 2.4.4.7 for gnome-2.5.x
- Regenerated gdm-07-enable-tcp-by-default.diff

* Fri Oct 31 2003 - <[email protected]>
- Remove the Sun Supported menu entry patch, and reorder.

* Tue Oct 14 2003 - <[email protected]> 2.4.4.3-2
- Add patch from Toshi to normalize the locale environment
  variables to be the same as LANG if they are unset.

* Fri Oct 10 2003 - <[email protected]> 2.4.4.3
- Update to 2.4.4.3 for gnome-2.4

* Wed Oct 01 2003 - <[email protected]> 2.4.2.101-14
- Add patch from Chookij to fix bug 4901817 (ja_JP.eucJP name)

* Thu Sep 18 2003 - <[email protected]> 2.4.2.101-12
- Add patch from Leena to set AlwaysRestartServer to true.

* Thu Aug 21 2003 - <[email protected]> 2.4.2.101-1
- Upgrade to 2.4.2.101

* Mon Aug 18 2003 - <[email protected]> 2.4.2.99-7
- Set DisallowTCP to false by default.

* Fri Aug 08 2003 - <[email protected]> 2.4.2.99-3
- Updated locale.alias patch with a fix for zh_HK and a tweak
  for ja_JP.sjis (now ja_JP.SJIS). Fixing bug 4899317.
- Added a dependancy on openssl-devel. My build failed because 
  it was missing. I've also added openssl for good measure.

* Thu Aug 07 2003 - <[email protected]> 2.4.2.99-2
- Patched /etc/X11/gdm/Xsession so ~/.xim or /etc/skel/.xim is sourced which
  ensures that XIM input methods are started.

* Fri Aug 01 2003 - <[email protected]> 2.4.2.99-1
- Upgrade to 2.4.2.99.

* Fri Aug 01 2003 - <[email protected]>
- Add supported menu category.

* Sun Jul 27 2003 - <[email protected]>
- Update to 2.4.2.98
- Remove POTFILES.in patch. Seems to be in new tarball.

* Tue Jul 22 2003 - <[email protected]>
- Added a patch to update the POTFILES.in.

* Mon Jul 21 2003 - <[email protected]>
- Changed category of gdmsetup.desktop, so it appears in 
  the system menu again.

* Mon Jul 21 2003 - <[email protected]>
- Added zh_HK (Hong Kong Chinese) to the available languages.

* Fri Jul 18 2003 - <[email protected]>
- Patched locale.alias to include more Asian locale codeset 
  variants as requested by the Asian teams.

* Thu Jul 17 2003 - <[email protected]>
- Fixed up the PAM configuration files.
- Removed the sysconfig/displaymanager hack

* Thu Jul 17 2003 - <[email protected]>
- update to version 2.4.2.97, release 0
- removed patches gdm-04-setlocale.diff and
  gdm-05-potfiles_in.diff, which are integrated upstream
- Changed sysconfdir to /etc/X11 so that new common sessions
  configuration directory (/etc/X11/dm/Sessions) can be shared
  with kdm etc.
- New common sessions dir /etc/X11/dm added to %files

* Fri Jul 11 2003 - <[email protected]>
- added setlocal patch - No more Welsh :) (or Czech!)

* Tue Jul 08 2003 - <[email protected]>
- Remove .desktop capplets from %files since photo setup
  is gone.

* Mon Jul 07 2003 - <[email protected]>
- Remove the photo setup .desktop menu item from the
  Settings menu.

* Tue Jul 01 2003 - <[email protected]>
- Move the pam and branding stuff to patches, and not 
  dirty copy hacks ;)

* Tue Jul 01 2003 - <[email protected]>
- Make gdm now depend on sun-gdm-themes which is a new
  package, replacing the old one.

* Fri Jun 30 2003 - <[email protected]>
- Make gdm now depend on Sundt-gdm-theme. This may be
  crack that we shouldn't do, but until I figure out
  how things work, let's go with it. 

* Fri Jun 30 2003 - <[email protected]>
- New tarball, bump version and reset release. Remove
  the old greeter theme, since we probably don't want
  it installed anyway

* Fri May 02 2003 - <[email protected]>
- Initial Sun release.