SUNWgnome-camera.spec
author dcarbery
Tue, 24 Jun 2008 09:38:23 +0000
changeset 12728 118427d41d8c
parent 12620 31cf55af5c8c
child 12996 017eacf54e5a
permissions -rw-r--r--
2008-06-24 Damien Carbery <[email protected]> * SUNWgnome-display-mgr.spec, SUNWgnome-dialog.spec, SUNWgnome-camera.spec, SUNWgnome-libs.spec, SUNWgnome-print.spec: Remove "-lgailutil" from LDFLAGS. Root cause found in gtk+: bugzilla 536430.

#
# spec file for package SUNWgnome-camera
#
# includes module(s): libgphoto2, gphoto2, gtkam
#
# Copyright 2007 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: mattman
#
%include Solaris.inc
%use libgphoto2 = libgphoto2.spec
%use gphoto2 = gphoto2.spec
%use gtkam = gtkam.spec

Name:                    SUNWgnome-camera
Summary:                 GNOME digital camera tool
Version:                 %{default_pkg_version}
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWgnome-libs
Requires: SUNWgnome-base-libs
Requires: SUNWlibusb
Requires: SUNWgnome-component
Requires: SUNWgnome-img-editor
Requires: SUNWjpg
Requires: SUNWlibexif
Requires: SUNWlibms
Requires: SUNWlibpopt
Requires: SUNWmlib
Requires: SUNWpostrun
Requires: SUNWdbus
Requires: SUNWdsdu
Requires: SUNWltdl
BuildRequires: SUNWgnome-component-devel
BuildRequires: SUNWlibexif-devel
BuildRequires: SUNWlibpopt-devel
# gtkam builds a gimp plug-in, so SUNWgnome-img-editor is a dependancy
BuildRequires: SUNWgnome-img-editor-devel
BuildRequires: SUNWlibusb
BuildRequires: SUNWdbus-devel
BuildRequires: SUNWdsdu
BuildRequires: SUNWlibtool
BuildRequires: SUNWltdl

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%package devel
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc

%prep
rm -rf %name-%version
mkdir %name-%version
%libgphoto2.prep -d %name-%version
%gphoto2.prep -d %name-%version
%gtkam.prep -d %name-%version

%build
# note: This ACLOCAL_FLAGS setting seems unnecessary, but it's
# needed so that gettext.m4 is used from /usr/share/aclocal and
# not from ./m4m
export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
export CFLAGS="%optflags"
export RPM_OPT_FLAGS="$CFLAGS"
export LDFLAGS="%_ldflags -R/usr/sfw/lib"

%libgphoto2.build -d %name-%version

export PKG_CONFIG_PATH=%{_builddir}/%name-%version/libgphoto2-%{libgphoto2.version}:%{_builddir}/%name-%version/libgphoto2-%{libgphoto2.version}/libgphoto2_port:%{_pkg_config_path}

%gphoto2.build -d %name-%version

%gtkam.build -d %name-%version

%install
rm -rf $RPM_BUILD_ROOT
%libgphoto2.install -d %name-%version
%gphoto2.install -d %name-%version
%gtkam.install -d %name-%version

rm -rf $RPM_BUILD_ROOT%{_prefix}/var
# Remove source code files (AUTHORS, README, CHANGELOG etc)
rm -rf $RPM_BUILD_ROOT%{_prefix}/doc
# Remove Linux specific hotplug stuff
rm -rf $RPM_BUILD_ROOT%{_sysconfdir}

%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/help/*/[a-z]*
rm -rf $RPM_BUILD_ROOT%{_datadir}/omf/*/*-[a-z][a-z].omf
%endif

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):unsupported" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%post
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS_wait
( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
  echo '/usr/bin/scrollkeeper-update'
) | $BASEDIR/lib/postrun -b -u -c JDS

%postun
test -x $BASEDIR/lib/postrun || exit 0
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS
( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
  echo '/usr/bin/scrollkeeper-update'
) | $BASEDIR/lib/postrun -b -u -c JDS

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/gphoto2
%{_bindir}/gtkam
%{_bindir}/gexif
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/lib*.so*
%{_libdir}/libgphoto2
%{_libdir}/libgphoto2_port
%{_libdir}/gimp
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/applications
%{_datadir}/applications/*
%dir %attr (0755, root, other) %{_datadir}/doc
%{_datadir}/doc/*
%dir %attr (0755, root, other) %{_datadir}/gnome
%{_datadir}/gnome/help/gtkam/C
%{_datadir}/gtkam
%{_datadir}/images
%{_datadir}/libgphoto2
%{_datadir}/omf/*/*-C.omf
%dir %attr (0755, root, other) %{_datadir}/pixmaps
%{_datadir}/pixmaps/*
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/man1
%{_mandir}/man1/*
%dir %attr(0755, root, bin) %{_mandir}/man3
%{_mandir}/man3/*

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/gnome
%attr (-, root, other) %{_datadir}/locale
%{_datadir}/gnome/help/*/[a-z]*
%{_datadir}/omf/*/*-[a-z]*.omf
%endif

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/gphoto2-port-config
%{_bindir}/gphoto2-config
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*

%changelog
* Tue Jun 24 2008 - [email protected]
- Remove "-lgailutil" from LDFLAGS. Root cause found in gtk+: bugzilla 536430.
* Fri Jun 06 2008 - [email protected]
- Add "-lgailutil" to LDFLAGS so that libgailutil is linked in when
  libgnomecanvas is linked.  libgnomecanvas.so includes some gail functions.
* Mon Mar 03 2007 - [email protected]
- Remove udev files as udev not supported on solaris
* Mon Dec 17 2007 - [email protected]
- Add Build/Requires SUNWltdl
- Remove Requires: SUNWlibtool
* Fri Dec  1 2007 - [email protected]
- Add Build/Requires SUNWlibtool.
* Wed Oct 10 2007 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Thu Oct  4 2007 - [email protected]
- define ACLOCAL_FLAGS
* Mon Aug 13 2007 - [email protected]
- Clean up.
* Tue Feb 13 2007 - [email protected]
- Add lib/udev to packaging - new directory in 2.3.1.
* Fri Feb 09 2007 - [email protected]
- Add SUNWdbus dependency since libgphoto2 requires D-Bus.
* Tue Dec 19 2006 - [email protected]
- Rework spec file after updating gtkam, libgphoto2, gphoto2 spec files.
* Sat Aug 12 2006 - [email protected]
- delete some unnecessary env variables
* Tue Jul 25 2006 - [email protected]
- Fix 'rm .omf' line to not delete the C locale file.
* Fri Jul 14 2006 - [email protected]
- update %post/%postun/etc scripts to support diskless client setup,
  part of 6448317
* Thu Jun 29 2006 - [email protected]
- update postrun scripts
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Mon May 15 2006 - [email protected]
- Correct l10n package perms.
* Tue May 09 2006 - [email protected]
- merge -share pkg(s) into the base pkg(s)
* Tue Apr 4 2006 - [email protected]
- Remove the hotplug stuff which is Linux specific. This
  cuts out the -root package currently.
* Tue Apr 4 2006 - [email protected]
- Move gphoto2-config into the -devel package.
* Wed Mar 15 2006 - [email protected]
- Add to Build/Requires after running check-deps.pl.
* Mon Jan 09 2006 - [email protected]
- Add SUNWlibusb dependency to get libusb-config.
* Sat Dec  3 2005 - [email protected]
- add %post script that runs update-desktop-database
* Tue Nov 29 2005 - [email protected]
- remove javahelp stuff
* Fri Sep 30 2005 - [email protected]
- Add root package for _sysconfdir files. Remove javahelp references.
  Delete .la files and others before packaging.
* Mon Dec 13 2004 - [email protected]
- Move to /usr/sfw to implement ARC decision.
* Sun Nov 14 2004 - [email protected]
- add /usr/demo/jds/lib to RPATH
* Fri Nov 12 2004 - [email protected]
- move to /usr/demo/jds
* Mon Oct 11 2004 - [email protected]
- Corrected packaging of gimp plugin.
* Wed Oct 06 2004 - [email protected]
- added l10n help files section
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Mon Sep 13 2004  [email protected]
- Added code to install javahelp documents. Fixes #5096653.
* Thu Sep 09 2004  [email protected]
- Moved %{_datadir}/pixmaps to '%files share' from '%files l10n'.
  Put %{_datadir}/omf/*/*-C.omf under '%files share'.
* Sun Sep 05 2004 - [email protected]
- removed root subpkg as it only contained 2 linux specific files (#5097102)
* Tue Aug 24 2004 - [email protected]
- Remove %{_datadir}/doc from install since these docs are not useful
  to install
* Mon Aug 23 2004 - [email protected]
- s/SUNWpl5u/SUNWperl584usr/
* Sun Jun 27 2004  [email protected]
- Changed install location to /usr/...
* Mon Jun 07 2004 - [email protected]
- Moved libexif to SUNWlibexif and libexif-gtk to SUNWgnome-libs since
  nautilus also uses these libraries if available.
* Wed Jun 02 2004 - [email protected]
- Added gtkam to package.
* Wed Jun 02 2004 - [email protected]
- Added %{_datadir}/locale to install l10n messages
* Mon May 03 2004 - [email protected]
- renamed to SUNWgnome-camera
* Fri Mar 31 2004 - [email protected]
- Created,