SUNWhamster.spec
author jyu_mit
Thu, 20 Nov 2008 10:01:06 +0000
branchgnome-2-24
changeset 13993 175b75ef9595
parent 13960 006fd1f4294e
child 14004 58e3f16f363f
permissions -rw-r--r--
* SUNWhamster.spec:Add %build_l10n section and correct attributes for some files.

#
# spec file for package SUNWhamster
#
# includes module(s): hamster
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: jyu_mit
#

%include Solaris.inc

Name:                    SUNWhamster
License:                 GPL v3 
Summary:		 Time tracking for masses	
Version:                 2.24.1
Source:                  http://ftp.gnome.org/pub/GNOME/sources/hamster-applet/2.24/hamster-applet-%{version}.tar.gz
URL:                     http://live.gnome.org/ProjectHamster
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
BuildRequires:     SUNWsqlite3
BuildRequires:     SUNWpysqlite
Requires:          SUNWsqlite3
Requires:          SUNWpysqlite

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif
 
%prep
%setup -q -n hamster-applet-%{version}

%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
    CPUS=1
fi
export CFLAGS="%optflags"

./configure --prefix=%{_prefix} \
	    --bindir=%{_bindir}	\
	    --libdir=%{_libdir}	\
	    --mandir=%{_mandir}
make -j$CPUS

%install
rm -rf $RPM_BUILD_ROOT
make DESTDIR=$RPM_BUILD_ROOT install

%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif
 
%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/*
%dir %attr (0755, root, root) %{_prefix}/etc
%{_prefix}/etc/*
%dir %attr (0755, root, sys) %{_datadir}
%doc AUTHORS
%doc(bzip2) COPYING NEWS
%doc(bzip2) ChangeLog README
%dir %attr (0755, root, other) %{_datadir}/doc
%dir %attr (-, root, other) %{_datadir}/icons
%dir %attr (-, root, other) %{_datadir}/icons/hicolor
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/scalable
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/16x16
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/22x22
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/32x32
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/48x48
%attr (-, root, other) %{_datadir}/icons/*/*/apps
%{_datadir}/gnome-control-center
%{_datadir}/hamster-applet 

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%endif
 
%changelog
* Thu Nov 20 2008 - [email protected]
- Add %build_l10n section and correct attributes for some files.
* Thu Nov 13 2008 - [email protected]
- Move from sfe to spec-files.
* Tue Nov 11 2008 - [email protected]
- Add BuildRequires.
* Wed Oct 22 2008 - [email protected]
- Bump to 2.24.1
* Tue Oct 07 2008 - [email protected]
- Initial spec