Solaris/SUNWgnome-cd-burner.spec
author lp117937
Thu, 11 May 2006 04:56:15 +0000
changeset 7242 19b994b053db
parent 6795 2243eef12c58
child 7244 b65ebefa231b
permissions -rw-r--r--
2006-05-10 Laszlo (Laca) Peter <[email protected]> * SUNWPython.spec, SUNWTiff.spec, SUNWgnome-a11y-base-libs.spec, SUNWgnome-a11y-gok.spec, SUNWgnome-a11y-libs.spec, SUNWgnome-a11y-poke.spec, SUNWgnome-a11y-reader.spec, SUNWgnome-a11y-speech.spec, SUNWgnome-applets.spec, SUNWgnome-archive-mgr.spec, SUNWgnome-audio.spec, SUNWgnome-base-libs.spec, SUNWgnome-calculator.spec, SUNWgnome-camera.spec, SUNWgnome-cd-burner.spec, SUNWgnome-cd.spec, SUNWgnome-character-map.spec, SUNWgnome-common-devel.spec, SUNWgnome-component.spec, SUNWgnome-config-editor.spec, SUNWgnome-config.spec, SUNWgnome-crash-report.spec, SUNWgnome-desktop-prefs.spec, SUNWgnome-dialog.spec, SUNWgnome-display-mgr.spec, SUNWgnome-file-mgr.spec, SUNWgnome-games.spec, SUNWgnome-help-viewer.spec, SUNWgnome-hex-editor.spec, SUNWgnome-im-client.spec, SUNWgnome-img-editor.spec, SUNWgnome-img-viewer.spec, SUNWgnome-media-apps.spec, SUNWgnome-media-player.spec, SUNWgnome-media.spec, SUNWgnome-panel.spec, SUNWgnome-pdf-viewer.spec, SUNWgnome-perf-meter.spec, SUNWgnome-pilot.spec, SUNWgnome-print.spec, SUNWgnome-remote-desktop.spec, SUNWgnome-removable-media.spec, SUNWgnome-session.spec, SUNWgnome-spell.spec, SUNWgnome-sys-suspend.spec, SUNWgnome-terminal.spec, SUNWgnome-text-editor.spec, SUNWgnome-themes.spec, SUNWgnome-ui-designer.spec, SUNWgnome-utils.spec, SUNWgnome-vfs.spec, SUNWgnome-wm.spec, SUNWjpg.spec, SUNWlibpopt.spec, SUNWogg-vorbis.spec, SUNWperl-authen-pam.spec, SUNWperl-xml-parser.spec, SUNWpng.spec: merge -share pkgs into the corresponding base pkgs * SUNWgnome-libs.spec: kill -share pkgs and fix the %postun script so that it removes the scrollkeeper data instead of trying to run scrollkeeper-update which will be removed by then anyway. * SUNWopenjade.spec: kill -share pkg; move to /usr * SUNWopensp.spec: kill -share pkg; move to /usr * Solaris.inc: allow defining jds_version and support_level on the command line 2006-05-10 Laszlo (Laca) Peter <[email protected]> * SUNWgnome-media.spec: re-add version numbered binaries in /usr/lib/gstreamer-0.10/tools and update toolsdir in gstreamer-0.10.pc accordingly so that SUNWgnome-media-apps can be built. Make the versionless binaries in %{_bindir} symlinks to the versioned ones in toolsdir.

#
# spec file for package SUNWgnome-cd-burner
#
# includes module(s): gnome-cd-burner
#
# Copyright (c) 2004 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include Solaris.inc

%define makeinstall make install DESTDIR=$RPM_BUILD_ROOT
%use cd_burner = nautilus-cd-burner.spec

Name:                    SUNWgnome-cd-burner
Summary:                 GNOME CD Burner
Version:                 %{default_pkg_version}
Source:                  nautilus-cd-burner.1
SUNW_BaseDir:            %{_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWgnome-libs
Requires: SUNWgnome-base-libs
Requires: SUNWgnome-file-mgr
Requires: %name-root
Requires: SUNWgnome-config
Requires: SUNWgnome-vfs
Requires: SUNWlibC
Requires: SUNWlibms
Requires: SUNWlibmsr
Requires: SUNWmlib
BuildRequires: SUNWgnome-libs-devel
BuildRequires: SUNWgnome-base-libs-devel
BuildRequires: SUNWgnome-file-mgr-devel
BuildRequires: SUNWgnome-config-devel
BuildRequires: SUNWgnome-vfs-devel


%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%package root
Summary:                 GNOME CD Burner
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWgnome-libs

%package devel
Summary:                 GNOME CD Burner - developer files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: %name

%prep
rm -rf %name-%version
mkdir %name-%version
%cd_burner.prep -d %name-%version

%build
export PKG_CONFIG_PATH=%{_pkg_config_path}
export MSGFMT="/usr/bin/msgfmt"
export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
export PERL5LIB=%{_prefix}/perl5/site_perl/5.6.1/sun4-solaris-64int
export CFLAGS="%optflags -I%{_includedir}"
export RPM_OPT_FLAGS="$CFLAGS"
export CXXFLAGS="%cxx_optflags -lCrun"
export LDFLAGS="-z ignore"

%cd_burner.build -d %name-%version

%install
%cd_burner.install -d %name-%version
export GCONF_CONFIG_SOURCE=xml::$RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults
for S in $RPM_BUILD_ROOT/%{_sysconfdir}/gconf/schemas/*.schemas; do
  %{_bindir}/gconftool-2 --makefile-install-rule $S >/dev/null
done
# Delete the empty %gconf.xml files.
for f in schemas/%gconf.xml \
         schemas/apps/%gconf.xml \
         apps/%gconf.xml \
    ; do
  test ! -s $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults/$f && \
    rm -f $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults/$f
done
chmod -R a+rX $RPM_BUILD_ROOT/%{_sysconfdir}
rm -rf $RPM_BUILD_ROOT%{_mandir}
install -d $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0755 %SOURCE0 $RPM_BUILD_ROOT%{_mandir}/sman1
# Remove .a and .la files.
rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la

%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, other)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/gnome-vfs-2.0/modules/lib*.so*
%{_libdir}/nautilus/extensions-1.0/lib*.so*
%{_libdir}/lib*.so*
%{_libexecdir}/mapping-daemon
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/nautilus-cd-burner
%{_datadir}/applications/nautilus-cd-burner.desktop
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*
%{_mandir}/*/*

%if %build_l10n
%files l10n
%defattr (-, root, other)
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/locale
%endif

%files root
%dir %attr(0755, root, sys) %{_sysconfdir}
%defattr (-, root, other)
%dir %{_sysconfdir}/gconf
%dir %{_sysconfdir}/gconf/schemas
%dir %{_sysconfdir}/gconf/gconf.xml.defaults
%dir %{_sysconfdir}/gconf/gconf.xml.defaults/apps
%dir %{_sysconfdir}/gconf/gconf.xml.defaults/schemas
%dir %{_sysconfdir}/gconf/gconf.xml.defaults/schemas/apps
%dir %{_sysconfdir}/gnome-vfs-2.0
%{_sysconfdir}/gconf/schemas/ncb.schemas
%{_sysconfdir}/gconf/gconf.xml.defaults/apps/nautilus-cd-burner
%{_sysconfdir}/gconf/gconf.xml.defaults/schemas/apps/nautilus-cd-burner
%{_sysconfdir}/gnome-vfs-2.0/modules
%defattr (-, root, sys)

%files devel
%defattr (-, root, other)
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/pkgconfig

%changelog
* Wed May 10 2006 - [email protected]
- merge -share pkg(s) into the base pkg(s)
* Mon Feb 20 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Sun Jan 22 2006 - [email protected]
- Add nautilus-cd-burner.desktop.
* Fri Sep 30 2005 - [email protected]
- Delete empty %gconf.xml files. Remove .la files.
* Mon Jul 11 2005 - [email protected]
- update CXXFLAGS
- added devel subpkg
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Thu Sep 09 2004 - [email protected]
- Added nautilus-cd-burner.1 manpage
* Mon Aug 23 2004 - [email protected]
- s/SUNWpl5u/SUNWperl584usr/
* Sat Jun 26 2004  [email protected]
- Changed install location to /usr/...
* Wed Jun 23 2004 - [email protected]
- Remove 'devel' package because no files assigned to it.
* Wed Jun  2 2004 - [email protected]
- Added %{_datadir}/locale to install l10n messages
* Tue May 11 2004 - [email protected]
- add SUNWgnome-file-mgr dependency
* Mon May 03 2004 - [email protected]
- fix directory permissions
* Thu Apr 15 2004 - [email protected]
- Created