vte.spec
author laca
Fri, 28 Oct 2005 01:33:57 +0000
changeset 6200 19ff8721b8f2
parent 6193 011617068c65
child 6564 480b9993069a
permissions -rw-r--r--
add %changelog entries (:

##
# spec file for package vte
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         vte
License:      LGPL
Group:        System/Libraries
Version:      0.11.15
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Terminal Emulation Widget Library
Source:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.11/%{name}-%{version}.tar.bz2
Source1:      vte.1.gz
Source2:      libvte.3.gz
Patch1:       vte-01-vtefc.diff
Patch2:       vte-02-glib.diff
Patch3:       vte-03-fcconfig.diff
Patch4:	      vte-04-inputmethod-spotlocation.diff
Patch5:       vte-05-cut-copy-paste-handle.diff
Patch6:       vte-06-update-logout-record.diff
Patch7:       vte-07-utf8-ambiguous.diff
Patch8:       vte-08-fix-crash.diff
Patch9:       vte-09-get-text.diff
Patch10:      vte-10-selection-perf-improve.diff
Patch11:      vte-11-pre-edit-crash-on-close.diff
Patch12:      vte-12-g11n-word-char.diff
Patch13:      vte-13-logname.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:	      %{_defaultdocdir}/doc
AutoReqProv:  on
Prereq:       /sbin/ldconfig

%define gtk2_version 2.4.0
%define python_version 2.4

Requires:      gtk2 >= %{gtk2_version}
BuildRequires: gtk2-devel >= %{gtk2_version}
BuildRequires: python >= %{python_version}

%description
VTE is a terminal emulation widget for GTK+, used in GNOME Terminal.

%package devel
Summary:	Terminal Emulation Widget Development Library
Group:		Development/Libraries
Requires:	%{name} = %{version}-%{release}
Requires:	gtk2-devel >= %{gtk2_version}

%description devel
VTE is a terminal emulation widget for GTK+, used in GNOME Terminal.

%prep
%setup -q
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
%patch6 -p1
%patch7 -p1
%patch8 -p1
%patch9 -p1
%patch10 -p1
%patch11 -p1
%patch12 -p1
%patch13 -p1


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS -I .
autoheader
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}		\
	    --sysconfdir=%{_sysconfdir} \
	    --disable-freetypetest      \
	    --libexecdir=%{_libexecdir} \
	    --enable-gtk-doc
make -j $CPUS \
    pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
    pythondir=%{_libdir}/python%{python_version}/vendor-packages

%install
make DESTDIR=$RPM_BUILD_ROOT install \
    pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
    pythondir=%{_libdir}/python%{python_version}/vendor-packages
#Copy zh_HK from zh_TW
#Fixes bug 4930405
install -d $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES
install --mode=0644 $RPM_BUILD_ROOT%{_datadir}/locale/zh_TW/LC_MESSAGES/*.mo $RPM_BUILD_ROOT%{_datadir}/locale/zh_HK/LC_MESSAGES/
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install -d $RPM_BUILD_ROOT%{_mandir}/man3
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/man3
# Clean up unpackaged files
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*.la
rm $RPM_BUILD_ROOT%{_libdir}/python2.4/vendor-packages/gtk-2.0/*.a
rm $RPM_BUILD_ROOT%{_libdir}/python2.4/vendor-packages/gtk-2.0/*.la


%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%defattr(-,root,root)
%{_bindir}/*
%{_libdir}/*.so*
%attr(2711,root,utmp) %{_libexecdir}/gnome-pty-helper
%{_datadir}/%{name}
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_mandir}/man1/*
%{_mandir}/man3/*

%files devel
%defattr(-,root,root)
%{_datadir}/gtk-doc/html/%{name}
%{_includedir}/*
%{_libdir}/*.so
%dir %{_libdir}/%{name}
%{_libdir}/%{name}/*
%{_libdir}/pkgconfig/*
%{_libdir}/python2.4/vendor-packages/gtk-2.0/vtemodule.so

%changelog
* Thu Oct 27 2005 - [email protected]
- move the python stuff from site-packages to vendor-packages

* Tue Sep 06 2005 - [email protected]
- Remove upstream patch, vte-04-a11y-selection.diff. Reorder remaining.

* Mon Sep 05 2005 - [email protected]
- Bump to 2.11.15.

* Thu Aug 25 2005 - [email protected]
- Add python build dependency and add python modules back into %files.

* Wed Aug 24 2005 - [email protected]
- Remove python references as the module doesn't generate any.

* Tue Aug 16 2005 - [email protected]
- Bump to 0.11.14.

* Fri May 13 2005 - [email protected]
- Bump to 0.11.13

* Wed Mar 16 2005 - [email protected]
- Added vte-14-g11n-word-char.diff fo select localized strings exactly.
  Fix 6241338.

* Wed Nov 24 2004 - [email protected]
- Updated the patch vte-11-scrolling-perf-improve.diff to chnage 
  vte input buffer size to 2K. Fixes bugtraq bug#6198452.
  Patch reviewed by [email protected]

* Fri Nov 12 2004 - [email protected]
- Added patch vte-13-preddit-crash-on-close.diff
  Bugster #6193929

* Fri Nov 05 2004 - [email protected]
- Added patch vte-12-selection-perf-improve.diff to improve selection
  performance 

* Fri Oct 29 2004 - [email protected]
- Added patch vte-11-scrolling-perf-improve.diff to improve scrolling 
  performance of gnome-terminal based on VTE. The patch improves the 
  performance of the issues mentioned in bugtraq bug#5014824. Most of 
  the patch is taken from the patch given to bugzilla bug#143914.

* Thu Oct 28 2004 - [email protected]
- Add vte.1, libvte.3 man pages
* Wed Oct 27 2004 - [email protected]
- Add patch vte-10-get-text.diff to fix bugzilla 156161.

* Mon Oct 18 2004 - [email protected]
- Add patch vte-09-fix-crash.diff to fix bug 5107420.

* Sat Oct 09 2004 - [email protected]
- Add patch vte-08-utf8-ambiguous.diff to fix bug 5028816
  [Cinnabar] gnome-terminal display full-width characters as half-width on UTF-8

* Fri Oct 08 2004 - [email protected]
- Added patch vte-07-update-logout-record.diff
  Fixes bug#5084840

* Mon Oct 04 2004 - [email protected]
- Added patch vte-06-cut-copy-paste-handle.diff to make Sun Cut,
  Copy, Paste keys work in gnome-terminal. Fixes bug#5098217

* Thu Aug 26 2004 - [email protected]
- Add patch vte-05-inputmethod-spotlocation.diff for bugzilla #150052,
bugtraq #5080038

* Wed Aug 18 2004 - [email protected]
- added --enable-gtk-doc

* Thu Jul 22 2004 - [email protected]
- Add patch vte-04-a11y-selection.diff for bugzilla #113590

* Sun Jul 11 2004 - [email protected]
- build fixup

* Thu Jul 08 2004 - [email protected]
- ported to rpm4
- removed auto*-jds stuff, not needed with SuSE 9.1

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to vte-l10n-po-1.2.tar.bz2

* Thu Jul 08 2004 - [email protected]
- updated vte.spec to remove the ifos from around gnome-pty-helper
  essentially yo revert back to what it was.

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Tue Jun 22 2004 <[email protected]>
- Based on the 0.11.11 version, recreate the vte-03-fcconfig.diff patch

* Mon Jun 14 2004 [email protected]
- Fixes stopper bug 5062671, not to use gnome-pty-helper on Solaris.
  Essentially just don't include the binary in Solaris.

* Fri Jun 11 2004 [email protected]
- Added patch to add '-lglib-2.0' to src/Makefile.am to build on Solaris sparc.

* Thu Jun 10 2004 [email protected]
- Changed to use correct autotools, hence no longer need autotools patch

* Wed Jun 09 2004 [email protected]
- Add '--disable-freetypetest' configure switch because S9x86 build fails when
  configure tries to run the test app, because /opt/jds/lib not in
  LD_LIBRARY_PATH or -R link parameter.

* Tue Jun 08 2004 [email protected]
- Update to 0.11.11 tarball

* Mon May 17 2004 - <[email protected]>
- Fixed bug 5042257 by adding patch vte-02-fcconfig.diff
  [Cinnabar Linux] The CJK font rendering in gnome-terminal is not acceptable

* Wed May 12 2004 - [email protected]
- Updated l10n content to vte-l10n-po-1.1.tar.bz2

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to vte-l10n-po-1.0.tar.bz2

* Tue Feb 24 2004 - <[email protected]>
- Update Distro, l10n tarball

* Thu Feb 12 2004 - <[email protected]>
- Added patch #01 to create an *-uninstalled-pc.file
- Autotoolize the build stage

* Fri Oct 17 2003 - <[email protected]> - 0.11.10-1
- Uprevved to GNOME 2.4.0 version.
- Changed source url.

* Thu Aug 14 2003 - <[email protected]>
- remove *.a

* Tue May 13 2003 - [email protected]
- initial Sun release