libIDL.spec
author dermotm
Mon, 12 Jul 2004 09:46:45 +0000
changeset 3320 1b6af4da604e
parent 3263 3c14210c0b99
child 3425 1df6e1328537
permissions -rw-r--r--
Incremented release numbers for build 14

Name:         libIDL
License:      LGPL
Group:        System/Libraries
Version:      0.8.3
Release:      14
Distribution: Cinnabar
Vendor:       Sun Microsystems, Inc.
Summary:      IDL parsing library
Source:       http://ftp.gnome.org/pub/GNOME/sources/libIDL/0.8/libIDL-%{version}.tar.bz2
Source1:      libIDL-2.3.gz
URL:          http://www.gnome.org
Docdir:       %{_defaultdocdir}/doc
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
AutoReqProv:  on
Prereq:       /sbin/ldconfig

%define glib2_version 2.2.1
%define pkgconfig_version 0.15.0

Requires:      glib2 >= %{glib2_version}
BuildRequires: glib2-devel >= %{glib2_version}
BuildRequires: pkgconfig >= %{pkgconfig_version}

%description
libIDL is a small library for creating parse trees of CORBA v2.2
compliant Interface Definition Language (IDL) files, which is a
specification for defining interfaces which can be used between
different CORBA implementations.

%package devel
Summary:      IDL parsing library development libraries and header files.
Group:        Development/Languages/Other
Requires:     %{name} = %{version}
Requires:     glib2-devel >= %{glib2_version}

%description devel
libIDL is a small library for creating parse trees of CORBA v2.2
compliant Interface Definition Language (IDL) files, which is a
specification for defining interfaces which can be used between
different CORBA implementations.

%prep
%setup -q

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CFLAGS="$RPM_OPT_FLAGS"				\
./configure --prefix=%{_prefix}			\
            --sysconfdir=%{_sysconfdir}
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
install -d $RPM_BUILD_ROOT/usr/share/man/man3
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT/usr/share/man/man3

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%defattr(-,root,root)
%{_libdir}/*.so.*

%files devel
%defattr(-,root,root)
%{_bindir}/*
%{_libdir}/pkgconfig/*.pc
%{_libdir}/*.so
%{_includedir}/*
%{_mandir}/man3/*

%changelog
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed Jan 28 2004 - <[email protected]> 0.8.3-1
- Upgrade to 0.8.3

* Mon Dec 15 2003 - <[email protected]>
- Add back the man pages.

* Thu Aug 14 2003 - <[email protected]>
- move lib*.so to -devel, remove *.a, *.la

* Fri Aug 01 2003 - <[email protected]> 0.8.2-1
- Upgrade to 0.8.2

* Tue May 20 2003 - <[email protected]>
- initial Sun release