base-specs/dbus-python.spec
author chrisk
Thu, 15 Apr 2010 16:36:41 +0000
changeset 17842 1cc615f41f16
parent 17559 c22aa5b46d2e
child 17864 337913e88a9d
permissions -rw-r--r--
2010-04-15 Christian Kelly <[email protected]> * SUNWperl-xml-parser.spec, SUNWlibpopt.spec, SUNWTiff.spec, SUNWPython25.spec, SUNWgnonlin.spec, SUNWgnome-config-java.spec, SUNWtgnome-tsoljdslabel.spec, SUNWgnome-hex-editor.spec, SUNWgnome-ps-viewer.spec, SUNWopensp.spec, base-specs/gir-repository.spec, base-specs/pygtksourceview.spec, base-specs/tack.spec, base-specs/dbus-glib.spec, base-specs/acroread.spec, base-specs/libgnome.spec, base-specs/raptor.spec, base-specs/ekiga.spec, base-specs/libpng10.spec, base-specs/libffi.spec, base-specs/thunderbird.spec, base-specs/dbus-python.spec, base-specs/firefox.spec, SUNWPython26.spec, SUNWpostrun.spec, SUNWtgnome-tsoljdsdevmgr.spec, SUNWtgnome-tsol-libs.spec, SUNWgnome-dtlogin-integration.spec, closed/SUNWgnome-solaris-branding.spec, closed/SUNWflash-player-plugin.spec, closed/SUNWfsexam.spec, closed/SUNWjds-registration.spec, SUNWjpg.spec, SUNWPython.spec, SUNWxdg-utils.spec, SUNWgnome-terminal-java.spec, SUNWtgnome-tstripe.spec, SUNWtgnome-tsoljdsselmgr.spec, SUNWcheese.spec, SUNWopenjade.spec, SUNWmyspell-dictionary-l10n.spec: Add/Fix License/Vendor/OSR information.

#
# spec file for package dbus-python
#
# Copyright 2007 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define owner yippi
# bugdb: bugzilla.freedesktop.org
#
%{?!pythonver:%define pythonver 2.4}

%define OSR 4092:0.60

Name:         dbus-python
License:      MIT
Vendor:       Freedesktop
Group:        System/Libraries
Version:      0.83.1
Release:      1
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      Python bindings for D-Bus
Source:       http://dbus.freedesktop.org/releases/dbus-python/%{name}-%{version}.tar.gz
URL:          http://www.freedesktop.org/wiki/Software_2fdbus
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:	      %{_defaultdocdir}/doc
Autoreqprov:  on
Prereq:       /sbin/ldconfig

BuildRequires: glib2-devel >= %glib2_version
BuildRequires: libxml2-devel >= %libxml2_version
BuildRequires: python-devel >= %{pythonver}
Requires: glib2 >= %glib2_version
Requires: libxml2 >= %libxml2_version
Requires: python >= %{pythonver}

%description
Python bindings for D-Bus.

%package devel
Summary:      Simple IPC library based on messages
Group:        Development/Libraries
Requires:     %{name} = %{version}

%description devel
Python bindings for D-Bus.

%prep
%setup -q

%build
export PYTHON=/usr/bin/python%{pythonver}
export PYTHON_VERSION=%{pythonver}
aclocal $ACLOCAL_FLAGS -I ./m4
autoconf
automake -a -c -f
export CFLAGS="%optflags -D_REENTRANT"
export LDFLAGS="%_ldflags"
./configure --prefix=%{_prefix}			\
            --includedir=%{_includedir}		\
            --sysconfdir=%{_sysconfdir}		\
            --libdir=%{_libdir}			\
            --bindir=%{_bindir}			\
            --localstatedir=%{_localstatedir}	\
            --with-dbus-user=root		\
            --with-dbus-daemondir=%{_basedir}/lib \
            --mandir=%{_mandir}			\
            --datadir=%{_datadir}		\
            --disable-static
make

%install
make install DESTDIR=$RPM_BUILD_ROOT

find $RPM_BUILD_ROOT%{_libdir} -type f -name "*.pyo" -exec rm -f {} ';'

# move to vendor-packages
PYLIBDIR=$RPM_BUILD_ROOT%{_libdir}/python%{pythonver}
[ ! -d ${PYLIBDIR}/vendor-packages ] && mkdir -p ${PYLIBDIR}/vendor-packages
(
    cd ${PYLIBDIR}/site-packages
    find . -print | cpio -pdm ${PYLIBDIR}/vendor-packages
)
rm -rf ${PYLIBDIR}/site-packages


find $RPM_BUILD_ROOT%{_prefix} -type f -name "*.la" -exec rm {} ';'
find $RPM_BUILD_ROOT%{_prefix} -type f -name "*.a" -exec rm {} ';'

%clean 
rm -rf $RPM_BUILD_ROOT

%files 
%defattr(-, root, root)
%config %{_sysconfdir}/dbus-1/session.conf
%config %{_sysconfdir}/dbus-1/system.conf
%{_bindir}/*
%{_libdir}/libdbus*.so*
%{_datadir}/man/*
%{_datadir}/dbus-1/*

%files devel
%defattr(-, root, root)
%{_libdir}/*.so
%{_includedir}/dbus-1.0/*
%{_libdir}/dbus-1.0/*
%{_libdir}/pkgconfig/*
%{_libdir}/python?.?/vendor-packages/*

%changelog
* Fri Feb 19 2010 - Brian Cameron  <[email protected]>
- Bump to 0.83.1.
* Tue Oct 13 2009 - Brian Cameron  <[email protected]>
- Do not install .pyo files.
* Thu Mar 19 2009 - [email protected]
- Remove patch dbus-python-01-fix-wrong-python25-includes.diff and instead
  set PYTHON_VERSION, which also ensures that the right python includes are
  used.
* Thu Mar 05 2009 - [email protected]
- Made it possible to build both Python 2.4 and 2.6 bindings.
* Mon Aug 15 2008 - [email protected]
- Remove method to find python headers by means of python-config from
  configure (Patch1) and add -I/usr/python2.4 to CFLAGS.
* Thu Jul 24 2008 - [email protected]
- bump to 0.83.0.
* Mon Dec 10 2007 - [email protected]
- Bump to 0.82.4.
* Wed Nov 07 2007 - [email protected]
- Add -D_REENTRANT to CFLAGS. It was removed from SUNW spec file on Sep 28.
  See bugster 6615221
* Wed Oct 10 2007 - [email protected]
- Don't delete *.pyc files - they are needed.
* Fri Sep 28 2007 - [email protected]
- convert to new style multi-ISA build
* Mon Aug 06 2007 - [email protected]
- Bump to 0.82.2 add "-I ./m4" to aclocal calls.
* Sun Apr  1 2007 - [email protected]
- add missing aclocal calls
* Wed Mar 15 2007 - [email protected]
- Removed CC64 and CC32. They are not needed anymore
* Sat Feb 25 2007 - [email protected]
- updated to include 64-bit build RFE: #6480511
* Wed Feb 14 2007 - [email protected]
- Bump to 0.80.2.
* Thu Jan 25 2007 - [email protected]
- Bump to 0.80.1. Use configure/make to build, not setup.py.
* Thu Nov 27 2006 - [email protected]
- Created.