gnome-python.spec
author dc144907
Fri, 21 Jul 2006 18:15:23 +0000
changeset 7706 2582c8fc8329
parent 6923 45fbffcf5f44
child 7760 f423c5a9415b
permissions -rw-r--r--
2006-07-21 Damien Carbery <[email protected]> * pygtk2.spec: Bump to 2.9.3. * bug-buddy.spec: Bump to 2.15.0. Disable patch as needs an engineer. * nimbus.spec: Add patch to disable a redefine of an enum. * patches/nimbus-01-redef-enum.diff: Disable enum redef. * gnome-backgrounds.spec: Bump to 2.14.2.1. * gnome-themes.spec: Bump to 2.15.4. Add patch, 01-icon-name-mapping, to remove path to icon-name-mapping. * gnome-vfs.spec: Bump to 2.15.3. * patches/gnome-vfs-16-acl.diff: Remove upstream hunks. * gnome-icon-theme.spec: Bump to 2.15.3. Remove obsolete patch, 03. * patches/gnome-icon-theme-01-sun-java-icon.diff: Rework. * patches/gnome-icon-theme-02-pkgconfig-dir.diff: Rework. * patches/gnome-icon-theme-03-relative-symlinks.diff: Remove. Obsolete. * pygobject.spec: Bump to 2.11.0. * pyorbit.spec: Bump to 2.14.1. * gtk2-engines.spec: Bump to 2.7.5. Add patch, 01-hidden. * patches/gtk-engines-01-hidden.diff: For G_GNUC_INTERNAL. * gnome-python.spec: Bump to 2.15.4. * icon-naming-utils.spec: Bump to 0.7.3.

#
# spec file for package gnome-python
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:			gnome-python
License:		LGPL	
Group:			System/Library
Version:		2.15.4
Release:		1
Distribution:		Java Desktop System
Vendor:			Sun Microsystems, Inc.
Summary:		Python bindings for various GNOME libraries
Source:			http://ftp.gnome.org/pub/GNOME/sources/gnome-python/2.15/gnome-python-%{version}.tar.bz2
URL:			http://www.gnome.org
BuildRoot:		%{_tmppath}/%{name}-%{version}-build
Docdir:			%{_defaultdocdir}/doc
Autoreqprov:		off

%define libglade_version           2.4.0
%define python_version             2.4
%define pygtk2_version             2.4.0
%define pyorbit_version            2.0.1
%define libgnomeui_version         2.0.0
%define gconf_version              1.2.0
%define nautilus_version           2.0.0
%define gnome_panel_version        2.0.0
%define gtkhtml_version            2.3.1
%define libgnomeprintui_version    2.2.0

Requires: python >= %{python_version}
Requires: pygtk2 >= %{pygtk2_version}
Requires: pyorbit >= %{pyorbit_version}
Requires: libgnomeui >= %{libgnomeui_version}
Requires: libglade >= %{libglade_version}
Requires: GConf >= %{gconf_version}
Requires: nautilus >= %{nautilus_version}
Requires: gnome-panel >= %{gnome_panel_version}
Requires: gtkhtml >= %{gtkhtml_version}
Requires: libgnomeprintui >= %{libgnomeprintui_version}

BuildRequires: python >= %{python_version}
BuildRequires: pygtk2-devel >= %{pygtk2_version}
BuildRequires: pyorbit-devel >= %{pyorbit_version}
BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: GConf-devel >= %{gconf_version}
BuildRequires: nautilus-devel >= %{nautilus_version}
BuildRequires: gnome-panel-devel >= %{gnome_panel_version}
BuildRequires: gtkhtml-devel >= %{gtkhtml_version}
BuildRequires: libgnomeprintui-devel >= %{libgnomeprintui_version}

%description
GNOME-Python provides the Python language bindings for the GNOME libraries.

%package devel
Summary: Files needed to build applications using the Python bindings for GNOME libraries
Group: Development/Languages
Requires: %{name} = %{version}

%description devel
This package contains files required to build Python applications that need 
to interope rate with the various GNOME libraries

%prep
%setup -q -n gnome-python-%{version}

%build
CFLAGS="$RPM_OPT_FLAGS"				\
./configure 	--prefix=%{_prefix}		\
	    	--sysconfdir=%{_sysconfdir}
make \
    pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
    pythondir=%{_libdir}/python%{python_version}/vendor-packages

%install
make install DESTDIR=$RPM_BUILD_ROOT \
    pyexecdir=%{_libdir}/python%{python_version}/vendor-packages \
    pythondir=%{_libdir}/python%{python_version}/vendor-packages
find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
find $RPM_BUILD_ROOT -type f -name "*.pyo" -exec rm -f {} ';'

%clean
rm -rf $RPM_BUILD_ROOT

%post

%postun

%files
%defattr(-, root, root)
%{_libdir}/python?.?/vendor-packages/gtk-2.0
%{_libdir}/gnome-vfs-*/modules/lib*.so

%doc AUTHORS NEWS README ChangeLog
%doc examples

%files devel
%defattr(644, root, root)
%{_libdir}/pkgconfig/*
%{_datadir}/pygtk
%{_includedir}/*

%changelog -n gnome-python
* Fri Jul 21 2006 - [email protected]
- Bump to 2.15.4.

* Mon Mar 13 2006 - [email protected]
- Bump to 2.12.4.

* Tue Jan 03 2006 - [email protected]
- Bump to 2.12.3.

* Tue Dec 20 2005 - [email protected]
- Bump to 2.12.2

* Thu Oct 27 2005 - [email protected]
- move from site-packages to vendor-packages
- include the .pyc files

* Fri Aug 26 2005 - [email protected]
- fix dependencies, fix %files

* Fri Aug 12 2005 - [email protected]
- Initial Sun release