Solaris/SUNWgnome-remote-desktop.spec
author dduvall
Thu, 15 Jul 2004 21:48:13 +0000
changeset 3348 26eb685038fa
parent 3221 a9dc1a9a5f37
child 3669 83ac9ef5f846
permissions -rw-r--r--
remove -L%{_libdir} -R%{_libdir} from LDFLAGS, as %{_libdir} is /usr/lib, and placing it unnecessarily in the RUNPATH makes it override later entries in the RUNPATH which need to come first. Evolution, with %{_libdir} != /usr/lib, doesn't require this treatment.

#
# spec file for package SUNWgnome-remote-desktop
#
# includes module(s): vino
#
# Copyright (c) 2004 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include Solaris.inc

%define makeinstall make install DESTDIR=$RPM_BUILD_ROOT
%use vino = vino.spec

Name:                    SUNWgnome-remote-desktop
Summary:                 GNOME Remote Desktop
Version:                 2.6.0
SUNW_BaseDir:            %{_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWgnome-libs
Requires: SUNWgnome-base-libs

%package share
Summary:                 GNOME Remote Desktop - platform independent files, /usr/share
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: SUNWpl5u

%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}

%package root
Summary:                 GNOME Remote Desktop - platform dependent files, / filesystem
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWgnome-libs

%prep
rm -rf %name-%version
mkdir %name-%version
%vino.prep -d %name-%version

%build
export PKG_CONFIG_PATH=%{_pkg_config_path}
export MSGFMT="/usr/bin/msgfmt"
export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
export PERL5LIB=%{_prefix}/perl5/site_perl/5.6.1/sun4-solaris-64int
export CFLAGS="%optflags -I%{_includedir} -I/usr/sfw/include"
export RPM_OPT_FLAGS="$CFLAGS"
export LDFLAGS="-L/usr/sfw/lib -R/usr/sfw/lib"

%vino.build -d %name-%version

%install
%vino.install -d %name-%version
export GCONF_CONFIG_SOURCE=xml::$RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults
for S in $RPM_BUILD_ROOT/%{_sysconfdir}/gconf/schemas/*.schemas; do
  %{_bindir}/gconftool-2 --makefile-install-rule $S >/dev/null
done
chmod -R a+rX $RPM_BUILD_ROOT/%{_sysconfdir}
for f in desktop/?gconf.xml \
         desktop/gnome/?gconf.xml \
         schemas/?gconf.xml \
         schemas/desktop/?gconf.xml \
         schemas/desktop/gnome/?gconf.xml \
    ; do
  test ! -s $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults/$f && \
    rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults/$f
done

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, other)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/vino-server
%{_libdir}/bonobo/servers/GNOME_RemoteDesktop.server

%files share
%defattr (-, root, other)
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/control-center-2.0/capplets
%{_datadir}/gnome/vino
%{_datadir}/pixmaps

%files l10n
%defattr (-, root, other)
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/locale

%files root
%attr (0755, root, sys) %dir %{_sysconfdir}
%defattr (-, root, other)
%{_sysconfdir}/gconf
%defattr (0755, root, sys)

%changelog
* Thu Jun 23 2004 - [email protected]
- more changes for change install location to /usr/lib and /usr/bin
* Tue Jun 22 2004 - [email protected]
- changed install location to /usr/lib and /usr/bin
* Wed Jun  2 2004 - [email protected]
- Added %{_datadir}/locale to install l10n messages
* Fri May 07 2004 - [email protected]
- Removed locale/C from "%files share" since it doesn't
  exist.
* Thu Apr 15 2004 - [email protected]
- Created,