Solaris/SUNWgnome-component.spec
author mattk
Fri, 01 Sep 2006 14:15:59 +0000
changeset 8038 298c3c334a25
parent 7547 52ffe601b5b0
child 8111 39f056a2f425
permissions -rw-r--r--
Update for man page tarballs

#
# spec file for package SUNWgnome-component
#
# includes module(s): libIDL, ORBit2, libbonobo
#
# Copyright (c) 2004 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%include Solaris.inc
%use idl = libIDL.spec
%use orbit = ORBit2.spec
%use bonobo = libbonobo.spec
Name:                    SUNWgnome-component
Summary:                 GNOME CORBA ORB and component framework
Version:                 %{default_pkg_version}
Source:                  %{name}-manpages-0.1.tar.gz
SUNW_BaseDir:            %{_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
BuildRequires: SUNWgnome-base-libs-devel
BuildRequires: SUNWlibpopt-devel
BuildRequires: SUNWgnome-component-devel
Requires: SUNWlibpopt
Requires: SUNWgnome-component-root
Requires: SUNWgnome-base-libs
Requires: SUNWperl584usr
Requires: SUNWperl584core
Requires: SUNWlxml

%package root
Summary:                 %{summary} - / filesystem
SUNW_BaseDir:            /
%include default-depend.inc

%package devel		
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: SUNWgnome-common-devel
Requires: SUNWgnome-base-libs-devel
Requires: SUNWlxml
Requires: SUNWgnome-component
Requires: SUNWgnome-base-libs
Requires: SUNWlibpopt
Requires: SUNWlibms

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: %{name}
%endif

%prep
rm -rf %name-%version
mkdir %name-%version
%idl.prep -d %name-%version
%orbit.prep -d %name-%version
%bonobo.prep -d %name-%version
cd %{_builddir}/%name-%version
gzcat %SOURCE0 | tar xf -

cd %{_builddir}/%name-%version
ln -s `pwd`/ORBit2-%{orbit.version}/src/services/name `pwd`/ORBit2-%{orbit.version}/include/ORBitservices

%ifarch amd64 sparcv9
ln -s `pwd`/ORBit2-%{orbit.version}-64/src/services/name `pwd`/ORBit2-%{orbit.version}-64/include/ORBitservices
%endif

%build
PKG_CONFIG_DISABLE_UNINSTALLED=
unset PKG_CONFIG_DISABLE_UNINSTALLED

export PKG_CONFIG_PATH=../ORBit2-%{orbit.version}:../libIDL-%{idl.version}:../libbonobo-%{bonobo.version}:%{_pkg_config_path}

export PKG_CONFIG_PATH32="$PKG_CONFIG_PATH"

export PKG_CONFIG_PATH64=../ORBit2-%{orbit.version}-64:../libIDL-%{idl.version}-64:../libbonobo-%{bonobo.version}-64:%{_pkg_config_path64}

export PERL_PATH=/usr/perl5/5.8.4/bin/perl
export PERL=/usr/perl5/5.8.4/bin/perl
export PERL5LIB=%{_prefix}/perl5/site_perl/5.6.1/sun4-solaris-64int
export CPP=/usr/lib/cpp
export CFLAGS="%optflags -I%{_includedir}"
export CFLAGS32="$CFLAGS"
export CFLAGS64="%optflags64 -I%{_includedir}"

export RPM_OPT_FLAGS="$CFLAGS"

export MSGFMT="/usr/bin/msgfmt"
%idl.build -d %name-%version
%orbit.build -d %name-%version

export LDFLAGS="%_ldflags -L%{_builddir}/%name-%version/ORBit2-%{orbit.version}/src/services/name"

export LDFLAGS32="$LDFLAGS"

export LDFLAGS64="%_ldflags -L%{_builddir}/%name-%version/ORBit2-%{orbit.version}-64/src/services/name -R/usr/lib/%{_arch64}"

%bonobo.build -d %name-%version

%install
%idl.install -d %name-%version
%orbit.install -d %name-%version
%bonobo.install -d %name-%version
rm -rf $RPM_BUILD_ROOT%{_mandir}
cd %{_builddir}/%name-%version/sun-manpages
make install DESTDIR=$RPM_BUILD_ROOT

rm -rf $RPM_BUILD_ROOT%{_datadir}/info

%ifarch amd64 sparcv9
rm -f $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/lib*a
rm -f $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/bonobo/monikers/lib*a
rm -f $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/orbit-2.0/*.a
rm -f $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/orbit-2.0/*.la
rm -f $RPM_BUILD_ROOT%{_libexecdir}/%{_arch64}/bonobo-activation-server
%endif

%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/activation-client
%{_bindir}/bonobo-activation-run-query
%{_bindir}/bonobo-slay
%{_bindir}/ior-decode-2
%{_bindir}/linc-cleanup-sockets
%{_bindir}/typelib-dump
%{_bindir}/echo-client-2
%dir %attr (0755, root, bin) %{_sbindir}
%{_sbindir}/bonobo-activation-sysconf
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/lib*.so*
%{_libdir}/bonobo/monikers/*.so
%{_libdir}/bonobo/servers
%{_libdir}/bonobo-2.0
%{_libdir}/orbit*/*.so
%{_libexecdir}/bonobo-activation-server
%ifarch amd64 sparcv9
%dir %attr (0755, root, bin) %{_bindir}/%{_arch64}
%{_bindir}/%{_arch64}/activation-client
%{_bindir}/%{_arch64}/bonobo-activation-run-query
%{_bindir}/%{_arch64}/ior-decode-2
%{_bindir}/%{_arch64}/linc-cleanup-sockets
%{_bindir}/%{_arch64}/typelib-dump
%{_bindir}/%{_arch64}/echo-client-2
%dir %attr (0755, root, bin) %{_sbindir}/%{_arch64}
%{_sbindir}/%{_arch64}/bonobo-activation-sysconf
%dir %attr (0755, root, bin) %{_libdir}/%{_arch64}
%{_libdir}/%{_arch64}/lib*.so*
%{_libdir}/%{_arch64}/bonobo/monikers/*.so
%{_libdir}/%{_arch64}/bonobo/servers
%{_libdir}/%{_arch64}/bonobo-2.0
%{_libdir}/%{_arch64}/orbit*/*.so
%endif

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/libIDL*
%{_bindir}/orbit*
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*
%ifarch amd64 sparcv9
%dir %attr (0755, root, bin) %{_libdir}/%{_arch64}
%dir %attr (0755, root, other) %{_libdir}/%{_arch64}/pkgconfig
%{_libdir}/%{_arch64}/pkgconfig/*
%dir %attr (0755, root, bin) %{_bindir}/%{_arch64}
%{_bindir}/%{_arch64}/orbit-idl-2
%endif
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/gtk-doc
%dir %attr (0755, root, other) %{_datadir}/aclocal
%{_datadir}/aclocal/*
%{_datadir}/idl
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*
%{_mandir}/*/*

%files root
%defattr (-, root, sys)
%attr (0755, root, sys) %dir %{_sysconfdir}
%{_sysconfdir}/[bo]*
%ifarch sparcv9 amd64
%{_sysconfdir}/%{_arch64}/*
%endif

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%endif

%changelog
* Fri Sep 01 2006 - [email protected]
- New Manpage tarball
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Wed May 10 2006 - [email protected]
- merge -share pkg(s) into the base pkg(s)
* Sun Feb 19 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Thu Feb  2 2006 - [email protected]
- Add hack to use /usr/xpg4/bin/sed for libbonobo so last line of file not 
  dropped.
* Sun Sep 18 2005 - [email protected]
- remove unpackaged 64-bit files
* Fri Sep 02 2005 - [email protected]
- remove unpackaged files
* Wed May 11 2005 - [email protected]
- Create symlink when building ORBit2 to allow uninstalled.pc
  files to find header files properly.
* Thu Oct 21 2004 - [email protected]
- set PERL and PERL_PATH, fixes 5100958
* Wed Oct 13 2004 - [email protected]
- use _pkg_config_path64 in $PKG_CONFIG_PATH64
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Sat Oct  2 2004 - [email protected]
- Create 64bit libraries for Solaris
* Thu Sep 09 2004 - [email protected]
- Added bonobo-slay.1 manpage
* Tue Aug 31 2004 - [email protected]
- Bug 5091588 : Added BuildRequires SUNWgnome-base-libs-devel since 
  SUNWgnome-base-libs was split
* Mon Aug 23 2004 - [email protected]
- s/SUNWpl5u/SUNWperl584usr/
* Wed Aug 18 2004 - [email protected]
- Changed manpage mode to 0755 for Solaris integration.
* Tue Aug 17 2004 - [email protected]
- Changed manpage mode to 0755 for Solaris integration.
* Mon Aug 16 2004 - [email protected]
- Changed multiple manpage modes to 0755 for Solaris integration.
* Sat Jun 26 2004  [email protected]
- Changed install location to /usr/...
* Thu May 27 2004 - [email protected]
- added l10n subpkg, remove share, since it only contained the l10n files
* Wed May 19 2004 - [email protected]
- Added missing man pages
* Thu May 06 2004 - [email protected]
- Removed libraries from devel package since they are already
  in the SUNWgnome-component package.
* Wed Mar 24 2004 - [email protected]
- Added SGML man page integration
* Fri Mar 12 2004 - [email protected]
- more missing files: sbindir, bonobo monikiers and servers
* Mon Mar 01 2003 - [email protected]
- added missing bonobo/activation binaries to
  files map. 
* Fri Feb 13 2004 - [email protected]
- added %dir flags
* Mon Jan 19 2004 - [email protected]
- initial Sun release.