blueprint-cursor.spec
author dermotm
Mon, 18 Oct 2004 09:30:38 +0000
changeset 4276 2a2c7f354601
parent 4273 f0a0d5b30f51
child 4409 4fec71e58697
permissions -rw-r--r--
Incremented release numbers for build 21

#
# spec file for package blueprint-cursor-theme
#
# Copyright (c) 2003 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

Name:         blueprint-cursor-theme
Summary:      X11 Cursors for Blue Print Theme
Version:      0.0.2
Release:      33
License:      GPL
Distribution: Cinnabar
Vendor:	      Sun Microsystems, Inc.
Group:        System/GUI/GNOME
Source:       %{name}-%{version}.tar.bz2
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
URL:          http://www.gnome.org

Requires: coreutils
PreReq: coreutils

%define gtk2_version 2.2.1

%description
This package can be used to demonstrate the new look-n-feel of the 
Mad Hatter Desktop. It contains themes meant to enhance 
the default look-and-feel of an off-the-shelf, base linux distribution.

The results of this RPM installation should strictly be seen as
an example of the upcoming Sun Blueprint theme and does in no
way reflect the function and look of the final product.

Property of Sun Microsystems Inc., 2003

%prep
%setup -q

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CFLAGS="$RPM_OPT_FLAGS"
./configure --prefix=%{_prefix}  \
	    --libdir=%{_prefix}/%_lib \
	    --sysconfdir=%{_sysconfdir} 
make -j $CPUS
cd -

%install
rm -rf $RPM_BUILD_ROOT
make DESTDIR=$RPM_BUILD_ROOT install

%post
if [ -a %{_prefix}/X11R6/lib/X11/icons/default/index.theme ]; then
  \mv %{_prefix}/X11R6/lib/X11/icons/default/index.theme %{_prefix}/X11R6/lib/X11/icons/default/index.theme.orig
fi
mv %{_prefix}/X11R6/lib/X11/icons/default/index.theme.blueprint %{_prefix}/X11R6/lib/X11/icons/default/index.theme

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-, root, root)
%doc AUTHORS COPYING ChangeLog NEWS README
%{_prefix}/X11R6/lib/X11/icons/%{name}/*
%{_prefix}/X11R6/lib/X11/icons/default/*

%changelog
* Mon Oct 18 2004 - [email protected]
- moved coreutils dep. to headers

* Mon Oct 04 2004 - [email protected]
- added dependency on coreutils for 'mv' command
  in postinstall script

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed Jul 02 2003 Erwann Chenede - <[email protected]>
- cleanup + icons theme addition
* Mon May 12 2003 Erwann Chenede - <[email protected]>
- initial implementation of the spec file