gail.spec
author dermotm
Mon, 18 Oct 2004 09:30:38 +0000
changeset 4276 2a2c7f354601
parent 4265 9c26d9ef4f72
child 4322 4a7db25fdba7
permissions -rw-r--r--
Incremented release numbers for build 21

Name:         gail
License:      LGPL
Group:        System/Libraries/GNOME
Version:      1.8.0
Release:      21
Distribution: Cinnabar
Vendor:       Sun Microsystems, Inc.
Summary:      GNOME Accessibility Implementation Library
URL:          http://www.gnome.org
Source:       http://ftp.gnome.org/pub/GNOME/sources/gail/1.6/gail-%{version}.tar.bz2
Source1:      libgailutil.3.gz
Source2: gail-l10n-po-1.6.tar.bz2
Patch1:       gail-01-combo-fix.diff
Patch2:       gail-04-g11n-alllinguas.diff
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/doc
AutoReqProv:  on
Prereq:       /sbin/ldconfig

%define libgnomecanvas_version 2.6.0
%define gtk2_version 2.4.0
%define atk_version 1.7

Requires: atk >= %{atk_version}
Requires: gtk2 >= %{gtk2_version}
Requires: libgnomecanvas >= %{libgnomecanvas_version}

BuildRequires: gtk2-devel >= %{gtk2_version}
BuildRequires: atk-devel >= %{atk_version}
BuildRequires: libgnomecanvas-devel >= %{libgnomecanvas_version}

%description
GNOME Accessibility Implementation Library is a set of accessibility interfaces for the GTK+ widgets.

%package devel
Summary:      GNOME Accessibility Implementation Development Library
Group:        Development/Library/GNOME
Requires:     %{name} = %{version}
Requires:     gtk2-devel >= %{gtk2_version}
Requires:     libgnomecanvas-devel >= %{libgnomecanvas_version}

%description devel
GNOME Accessibility Implementation Library is a set of accessibility interfaces for the GTK+ widgets.

%prep
%setup -q
%patch1 -p1
%patch2 -p1

/usr/bin/bzcat -dc %SOURCE2|tar xf -

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros
gtkdocize
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}		\
	    --sysconfdir=%{_sysconfdir}
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
install -d $RPM_BUILD_ROOT%{_mandir}/man3
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man3
rm $RPM_BUILD_ROOT%{_libdir}/gtk-2.0/modules/*.la
rm $RPM_BUILD_ROOT%{_libdir}/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%defattr(-, root, root)
%{_libdir}/*.so.*
%{_libdir}/gtk-2.0/modules/*.so

%files devel
%defattr(-, root, root)
%doc %{_datadir}/gtk-doc/html/gail-libgail-util
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
%{_includedir}/*
%{_datadir}/locale/*/*/*.mo
%{_mandir}/man3/*

%changelog
* Mon Sep 27 2004 - [email protected]
- Bump to 1.8.0; rework gail-01-combo-fix.diff patch;
  remove gail-02-metacity-fix.diff and gail-03-canvas-item-fix.diff patches. 

* Mon Sep 20 2004 - [email protected]
- Added gail-04-g11n-alllinguas.diff to add hu for all linguas

* Tue Sep 07 2004 - [email protected]
- Added patch gail-03-canvas-item-fix.diff for bug 5064514

* Thu Aug 05 2004 - [email protected]
- Added patch gail-02-metacity-fix.diff for bug 5082567

* Thu Jul 22 2004 - [email protected]
- Added patch gail-01-combo-fix.diff for bugzilla #136657.

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gail-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- ported to rpm4
                                                                                
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Tue Jun 08 2004 - <[email protected]>
- Bump to 1.6.6

* Tue May 25 2004 - <[email protected]>
- Bump to 1.6.5

* Fri May 14 2004 - <[email protected]>
- Bump to 1.6.4

* Wed May 12 2004 - [email protected]
- Updated l10n content to gail-l10n-po-1.1.tar.bz2

* Mon Apr 26 2004 - <[email protected]>
- Bump to 1.6.3

* Mon Apr 19 2004 - <[email protected]>
- Bump to 1.6.2

* Wed Apr 07 2004 - <[email protected]>
- Bump to 1.6.1

* Wed Mar 31 2004 - [email protected]
- replace tar jxf with the more solaris friendly
  bzcat piped through tar

* Mon Mar 29 2004 - [email protected]
- Adding gail-l10n-po-1.0.tar.bz2 l10n content

* Tue Mar 23 2004 - <[email protected]>
- Bump to 1.6.0, update gtk+ dependency.

* Thu Mar 11 2004 - <[email protected]>
- Reset release to 1.

* Wed Mar 10 2004 - [email protected]
- Bump to 1.5.7

* Mon Feb 23 2004 - [email protected]
- bump to 1.5.5, remerge patch

* Fri Feb 06 2004 - [email protected]
- bump to 1.5.4 to fix automake mess

* Fri Feb 06 2004 - [email protected]
- added a uninatalled-pc.in file for Wells build.
- autotoolize

* Tue Dec 16 2003 - [email protected]
- bump to 1.5.2

* Thu Oct 9 2003 - [email protected]
- tarball upgrade

* Thu Aug 14 2003 - <[email protected]>
- move lib*.so to -devel, remove *.a, *.la

* Tue Aug 08 2003 - [email protected]
- added libtoolize and friends + patch to fix the build

* Tue May 13 2003 - [email protected]
- initial Sun release