gnome-spell.spec
author dermotm
Mon, 18 Oct 2004 09:30:38 +0000
changeset 4276 2a2c7f354601
parent 4274 db01cec80c59
child 4324 bd92ccc2a72f
permissions -rw-r--r--
Incremented release numbers for build 21

#
# License (c) 2003 Sun Microsystems Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%define t_suffix -build21-cb
%{?nightly:%define t_suffix -%(TZ=GMT date +%Y%m%d)}

Name:     	gnome-spell
Version: 	1.0.4
Release:	353
Vendor:		Sun Microsystems, Inc.
Distribution:	Java Desktop System, Release 3
Copyright:	GPL
BuildRoot:	%{_tmppath}/%{name}-%{version}-build
Docdir:         %{_datadir}/doc
Autoreqprov:    on
URL:		http://www.sun.com/software/javadesktopsystem/
Source:		%{name}-%{version}%{t_suffix}.tar.bz2
Source1: 	gnome-spell-l10n-po-1.6.tar.bz2
Source2:	mkinstalldirs
Summary:	GNOME spell checking component
Group:		Applications/Text

%define aspell_version 0.50.3
Requires:       aspell >= %{aspell_version}
BuildRequires:  aspell-devel >= %{aspell_version}

%description
Gnome Spell is GNOME/Bonobo component for spell checking. It
contains the GNOME::Spell::Dictionary object, which provides a spell
checking dictionary (see Spell.idl for exact API definition). It is
based on pspell.

%files
%defattr(-, root, root)
%doc AUTHORS ChangeLog COPYING NEWS README
%dir %{_libdir}/gnome-spell
%{_libdir}/gnome-spell/*.so
%{_datadir}/control-center-2.0/icons/*
%{_datadir}/gnome-spell-1.0.4
%{_datadir}/idl/*
%{_libdir}/bonobo/servers/*
%{_prefix}/*/locale/*/LC_MESSAGES/*


# $RPM_COMMAND is an environment variable used by the SUN build
# system to control the build process with finer granularity than RPM
# normally allows.  This specfile will function as expected by RPM if
# $RPM_COMMAND is unset.  If you are not the SUN build system,
# feel free to ignore it.

%prep
case "${RPM_COMMAND:-all}" in
dist)
%setup  -q -D -n %{name}-%{version}
/usr/bin/bzcat -dc %SOURCE1|tar xf -
    ;;
all)
%setup  -q -n %{name}-%{version}
/usr/bin/bzcat -dc %SOURCE1|tar xf -
    ;;
esac
cp %SOURCE2 .

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

MAKE=${MAKE:-make}
RPM_COMMAND=${RPM_COMMAND:-all}
DESTDIR=${DESTDIR:-"$RPM_BUILD_ROOT"}
ARCH=%{_target_platform}
export MAKE RPM_COMMAND DESTDIR ARCH
case "$RPM_COMMAND" in
prepare|all)
%ifos linux
    export LDFLAGS="-lstdc++"
%endif
    aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros
    libtoolize --force
    glib-gettextize --force --copy
    intltoolize --force --automake
    autoheader
    automake -a -f -c --gnu
    autoconf
    ./configure --prefix=%{_prefix} --sysconfdir=%{_sysconfdir} --mandir=%{_mandir} --infodir=%{_datadir}/info --localstatedir=/var
    ;;
esac
case "$RPM_COMMAND" in
clean|all)
    if [ "/" != "$DESTDIR" ]; then
	rm -rf "$DESTDIR"
    fi
    ;;
esac
case "$RPM_COMMAND" in
build|all)
    ${MAKE} -j $CPUS
    ;;
esac

%install
MAKE=${MAKE:-make}
DESTDIR=${DESTDIR:-"$RPM_BUILD_ROOT"}
# export DESTDIR
case "${RPM_COMMAND:-all}" in
install|all)
    ${MAKE} install DESTDIR=${DESTDIR}
    ;;
esac
#clean up unpackaged files
rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.a
rm -f $RPM_BUILD_ROOT%{_libdir}/%{name}/*.la

%clean
DESTDIR=${DESTDIR:-"$RPM_BUILD_ROOT"}
export DESTDIR
case "${RPM_COMMAND:-all}" in
clean|all)
    if [ "/" != "$DESTDIR" ]; then
	rm -rf "$DESTDIR"
    fi
    ;;
esac


%changelog
* Mon Oct 18 2004 - [email protected]
- bump src tarball to build21

* Mon Oct 11 2004 - [email protected]
- bump src tarball to build20b

* Mon Oct 04 2004 - [email protected]
- change aspell dep. version to 0.50.3

* Mon Sep 20 2004 - [email protected]
- bump src tarball to build19

* Mon Sep 06 2004 - [email protected]
- bump src tarball to build18

* Mon Aug 23 2004 - [email protected]
- bump src tarball to build17

* Mon Aug 09 2004 - [email protected]
- bump src tarball to build16

* Mon Jul 26 2004 - [email protected]
- bump src tarball to build15

* Tue Jul 13 2004 - [email protected]
- ported to sles 9, add build requirement on
  aspell-devel. Remove unpackaged files.

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gnome-spell-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Fri Jun 25 2004 - [email protected]
- bump src tarball to build13
* Thu Jun 10 2004 - [email protected]
- bump src tarball to build12
* Sun May 30 2004 - [email protected]
- bump src tarball to build11
* Fri May 28 2004 - [email protected]
- add -lstdc++ to LDFLAGS on Linux
* Thu May 27 2004 - [email protected]
- add mkinstalldirs to the source tree
* Fri May 14 2004 - [email protected]
- bump src tarball to build10
* Wed May 12 2004 - [email protected]
- replace tar jxf with the more solaris friendly
  bzcat piped through tar
* Wed May 12 2004 - [email protected]
- Adding gnome-spell-l10n-po-1.1.tar.bz2 l10n content
* Fri Apr 30 2004 - [email protected]
- bump src tarball to build09