gok.spec
author dermotm
Mon, 18 Oct 2004 09:30:38 +0000
changeset 4276 2a2c7f354601
parent 4246 23d79c43b54a
child 4329 ede1c2c36a77
permissions -rw-r--r--
Incremented release numbers for build 21

Name:         gok
License:      LGPL
Group:        System/Libraries
Version:      0.11.10
Release:      22
Distribution: Cinnabar 
Vendor:       Sun Microsystems, Inc.
Summary:      GNOME On-screen Keyboard
Source:       http://ftp.gnome.org/pub/GNOME/sources/gok/0.11/%{name}-%{version}.tar.bz2
Source1:      gok-l10n-po-1.2.tar.bz2
Source2:      gok-docs-0.2.tar.bz2
Patch1:       gok-01-jds-apps.diff
Patch2:       gok-02-g11n-potfiles.diff 
Patch3:       gok-03-buildfix.diff
Patch4:       gok-04-actionfix.diff
Patch5:       gok-05-string-fix.diff
URL:          http://developer.gnome.org/projects/gap/
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on
Prereq:	      /sbin/ldconfig

%define gtk2_version 2.2.4
%define libgnomeui_version 2.4.0
%define atk_version 1.6.0
%define gail_version 1.5.7
%define at_spi_version 1.5.4
%define gnome_speech_version 0.3.5

BuildRequires: gtk2-devel >= %{gtk2_version}
BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: gail-devel >= %{gail_version}
BuildRequires: javahelp-convert
BuildRequires: at-spi-devel >= %at_spi_version
BuildRequires: gnome-speech-devel >= %gnome_speech_version
BuildRequires: esound-devel
Requires:      gtk2 >= %{gtk2_version}
Requires:      libgnomeui >= %{libgnomeui_version}
Requires:      gail >= %{gail_version}
Requires:      at-spi >= %at_spi_version
Requires:      gnome-speech >= %gnome_speech_version
Requires:      esound

%description
The GNOME On-screen Keyboard (GOK) is a dynamic on-screen keyboard for UNIX and UNIX-like operating systems.  It features Direct Selection, Dwell Selection, Automatic Scanning and Inverse Scanning access methods and includes word completion.

%prep
%setup -q
m4 gok-with-references.schemas.m4 > gok-with-references.schemas.in
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1
/usr/bin/bzcat -dc %SOURCE1|tar xf -
/usr/bin/bzcat -dc %SOURCE2|tar xf -

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CFLAGS="$RPM_OPT_FLAGS"			\
./configure --prefix=%{_prefix}			\
            --sysconfdir=%{_sysconfdir}		\
	    --mandir=%{_mandir}			\
            --disable-gtk-doc
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make DESTDIR=$RPM_BUILD_ROOT install
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL

javahelp-convert-install $RPM_BUILD_ROOT %{name} %{name}.xml

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="gok.schemas"
for S in $SCHEMAS; do
        gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done

%postun
/sbin/ldconfig

%files
%defattr(-,root,root)
%{_bindir}/gok
%{_bindir}/create-branching-keyboard
%{_libdir}/bonobo/servers/*.server
%{_libdir}/pkgconfig/*.pc
%{_datadir}/applications/*
%{_datadir}/gok
%{_datadir}/pixmaps/*
%{_datadir}/gnome/help/gok/*
%{_datadir}/gnome/javahelp/gok/*
%{_datadir}/locale/*/*/*
%{_datadir}/omf/gok/*.omf
%{_sysconfdir}/gconf/schemas/*.schemas

%changelog
* Wed Oct 13 2004 - [email protected]
- Added patch gok-05-fix-strings.diff for bugzilla 155229.

* Wed Oct 13 2004 - [email protected]
- Added m4 in %prep to pre-generate .schemas.in

* Tue Oct 12 2004 - [email protected]
- Added patch gok-04-actionfix.diff for P1 6176892.
  Should be removed when we rev to gok-0.11.11 or higher.

* Wed Oct 08 2004 - [email protected]
- Added buildfix patch gok-03-buildfix.diff (forte build failed).

* Wed Oct 06 2004 - [email protected]
- Revved to 0.11.10, to fix P1 6174262.

* Fri Oct 01 2004 - [email protected]
- Revved to 0.11.9

* Fri Sep 24 2004 - [email protected]
- Added gok-02-g11n-potfiles.diff

* Wed Sep 16 2004 - [email protected]
- added missing dependencies

* Wed Sep 15 2004 - [email protected]
- Integrate updated docs tarball from [email protected].

* Thu Sep 02 2004 - [email protected]
- Add docs tarball from [email protected].

* Wed Sep 01 2004 - [email protected]
- Revved to 0.11.7.

* Wed Aug 25 2004 - [email protected]
- Add create-branching-keyboard to %files.

* Tue Aug 24 2004 - [email protected]
- Removed "launcher.kbd" part of gok-01-jds-apps.diff, we only need to patch
- the .kbd.in file and re-make.

* Thu Aug 17 2004 - [email protected]
- Added patch gok-01-jds-apps.diff, for bug #5085248.  This is a JDS-specific 
- branding patch, which needed to be applied now due to string freeze impact.

* Mon Aug 16 2004 - [email protected]
- Bumped to 0.11.6.

* Thu Aug 12 2004 - [email protected]
- Removed the gok g11n patches, they should have been applied to cvs instead.
- They were also incorrect; root cause of problem appears to be an intltool bug.
- Bumped version to 0.11.5.

* Wed Jul 15 2004 - [email protected]
- Added gok-01-g11n-potfiles.diff and gok-02-g11n-i18n-ui.diff. Fixes bug #5074183

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to gok-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed Jun 23 2004 - [email protected]
- Install gconf schema files. Fixes bug #5045140

* Fri Jun 11 2004 - [email protected]
- fix 0.11.4.1 tarball and Source tag

* Thu Jun 10 2004 - <[email protected]>
- Bump to 0.11.4.1

* Thu Jun 10 2004 - <[email protected]>
- Bump to 0.11.4

* Fri May 14 2004 - <[email protected]>
- Bump to 0.11.2

* Wed May 12 2004 - [email protected]
- Updated l10n content to gok-l10n-po-1.1.tar.bz2

* Thu Apr 22 2004 - <[email protected]>
- Bump to 0.10.2

* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris

* Thu Apr 01 2004 - [email protected]
- Javahelp converison

* Wed Mar 31 2004 - [email protected]
- replace tar jxf with the more solaris friendly
  bzcat piped through tar

* Mon Mar 29 2004 - [email protected]
- Adding gok-l10n-po-1.0.tar.bz2 l10n content

* Tue Mar 23 2004 - <[email protected]>
- Bump to 0.10.0

* Mon Mar 15 2004 - <[email protected]>
- Remove gtk-doc line from %files section as no files there any more.

* Thu Mar 11 2004 - <[email protected]>
- Reset release to 1.

* Wed Mar 10 2004 - [email protected]
- Bump to 0.9.10

* Mon Feb 23 2004 - [email protected]
- Created new spec file for gok