hydrogen.spec
author dermotm
Mon, 18 Oct 2004 09:30:38 +0000
changeset 4276 2a2c7f354601
parent 4274 db01cec80c59
child 4387 1b0580c5041e
permissions -rw-r--r--
Incremented release numbers for build 21

#
# License (c) 2003 Sun Microsystems Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%define t_suffix -build21-cb
%{?nightly:%define t_suffix -%(TZ=GMT date +%Y%m%d)}

%define evolution_imagesdir %(echo `PKG_CONFIG_PATH=%{_libdir}/pkgconfig:/usr/lib/pkgconfig pkg-config --variable imagesdir evolution-shell 2>/dev/null`)

%define evolution_libdir %(echo `PKG_CONFIG_PATH=%{_libdir}/pkgconfig:/usr/lib/pkgconfig pkg-config --variable privlibdir evolution-shell 2>/dev/null`)

Name:     	hydrogen
Version: 	1.0.0
Release:	353
Vendor:		Sun Microsystems, Inc.
Distribution:	Java Desktop System, Release 3
Copyright:	LGPL/GPL
BuildRoot:	%{_tmppath}/%{name}-%{version}-root
Docdir:         %{_datadir}/doc
Autoreqprov:    on
URL:		http://www.sun.com/software/javadesktopsystem/
Source:		%{name}-%{version}%{t_suffix}.tar.bz2
Source1:	mkinstalldirs
Source2: hydrogen-l10n-po-1.6.tar.bz2
Patch1:         hydrogen-01-g11n-alllinguas.diff

BuildRequires:	glibc-devel
BuildRequires:	libtool
BuildRequires:	glib2-devel
BuildRequires:	libsoup-devel
BuildRequires:	evolution-devel	
BuildRequires:  libgal-devel 
BuildRequires:  libbonoboui-devel
BuildRequires:  bonobo-activation-devel
Summary:	The SUN one connector.
Group:		System Environment/Libraries
Requires:	libsoup
Requires:	evolution
Requires:	glib2
Requires:	libgal
Requires:       bonobo-activation

%description
    The SUN one connector, protocol wcap.
%files
%defattr(-, root, root)
%doc COPYING ChangeLog AUTHORS INSTALL NEWS README
%{_bindir}/hydrogen
%{_libdir}/bonobo/servers/GNOME_Evolution_SunOne_Storage.server
%{_datadir}/locale/*/LC_MESSAGES/hydrogen-1.0.mo
%{_datadir}/hydrogen/glade/*.glade
%{_datadir}/hydrogen/etspec/*.etspec
/%{evolution_imagesdir}/*.png
/%{evolution_libdir}/
%post
ldconfig

# $RPM_COMMAND is an environment variable used by the SUN build
# system to control the build process with finer granularity than RPM
# normally allows.  This specfile will function as expected by RPM if
# $RPM_COMMAND is unset.  If you are not the SUN build system,
# feel free to ignore it.

%prep
case "${RPM_COMMAND:-all}" in
dist)

%setup  -q -D -n %{name}-%{version}
/usr/bin/bzcat -dc %SOURCE2|tar xf -
    ;;
all)
%setup  -q -n %{name}-%{version}
%patch1 -p1
/usr/bin/bzcat -dc %SOURCE2|tar xf -
    ;;
esac
cp %SOURCE1 .

%build
MAKE=${MAKE:-make}
RPM_COMMAND=${RPM_COMMAND:-all}
DESTDIR=${DESTDIR:-"$RPM_BUILD_ROOT"}
ARCH=%{_target_platform}
export MAKE RPM_COMMAND DESTDIR ARCH
case "$RPM_COMMAND" in
prepare|all)
    aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros
    libtoolize --force
    glib-gettextize --force --copy
    intltoolize --force --automake
    autoheader
    automake -a -f -c --gnu
    autoconf
    ./configure --prefix=%{_prefix}  \
                 --enable-idn=no
    ;;
esac
case "$RPM_COMMAND" in
clean|all)
    if [ "/" != "$DESTDIR" ]; then
	rm -rf "$DESTDIR"
    fi
    ;;
esac
case "$RPM_COMMAND" in
build|all)
    ${MAKE}
    ;;
esac

%install
mkdir -p $RPM_BUILD_ROOT%{evolution_imagesdir}
cp ./storage/*.png $RPM_BUILD_ROOT%{evolution_imagesdir}
mkdir -p $RPM_BUILD_ROOT%{evolution_libdir}
cp ./calendar/.libs/libwcapcalendar.so.0 $RPM_BUILD_ROOT%{evolution_libdir}
cp ./lib/.libs/libhydrogen.so.0 $RPM_BUILD_ROOT%{evolution_libdir}
MAKE=${MAKE:-make}
DESTDIR=${DESTDIR:-"$RPM_BUILD_ROOT"}
# export DESTDIR
case "${RPM_COMMAND:-all}" in
install|all)
    ${MAKE} install DESTDIR=${DESTDIR}
    ;;
esac

%clean
DESTDIR=${DESTDIR:-"$RPM_BUILD_ROOT"}
export DESTDIR
case "${RPM_COMMAND:-all}" in
clean|all)
    if [ "/" != "$DESTDIR" ]; then
	rm -rf "$DESTDIR"
    fi
    ;;
esac


%changelog
* Mon Oct 18 2004 - [email protected]
- bump src tarball to build21

* Mon Oct 11 2004 - [email protected]
- bump src tarball to build20b

* Mon Oct 04 2004 - [email protected]
- removed idn support

* Mon Sep 20 2004 - [email protected]
- bump src tarball to build19

* Thu Sep 16 2004 - [email protected]
- Added hydrogen-01-g11n-alllinguas.diff to include cd,hu linguas

* Mon Sep 06 2004 - [email protected]
- bump src tarball to build18

* Mon Aug 23 2004 - [email protected]
- bump src tarball to build17

* Mon Aug 09 2004 - [email protected]
- bump src tarball to build16

* Mon Jul 26 2004 - [email protected]
- bump src tarball to build15

* Fri Jul 09 2004 - [email protected]
- undid -j $CPUS for this module

* Thu Jul 08 2004 - [email protected]
- Updated l10n content to hydrogen-l10n-po-1.2.tar.bz2

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Sun Jun 27 2004 - [email protected]
- Removed hydrogen-01-calander-makefile.diff, not needed
* Sat Jun 26 2004 - [email protected]
- Added hydrogen-01-calander-makefile.diff for build13 tarball problem
* Fri Jun 25 2004 - [email protected]
- bump src tarball to build13
* Thu Jun 10 2004 - [email protected]
- bump src tarball to build12
* Sun May 30 2004 - [email protected]
- bump src tarball to build11
* Fri May 14 2004 - [email protected]
- bump src tarball to build10
* Wed May 12 2004 - [email protected]
- replace tar jxf with the more solaris friendly
  bzcat piped through tar
* Wed May 12 2004 - [email protected]
- Adding hydrogen-l10n-po-1.1.tar.bz2 l10n content
* Sat May 01 2004 - [email protected]
- remove icon conflict hack as it is fixed in the tarball
* Fri Apr 30 2004 - [email protected]
- bump src tarball to build09
* Wed Apr 07 2004 - [email protected]
-