libxklavier.spec
author dermotm
Mon, 18 Oct 2004 09:30:38 +0000
changeset 4276 2a2c7f354601
parent 4145 dfe6173546d2
child 4287 6ce3787d3e16
permissions -rw-r--r--
Incremented release numbers for build 21

Name:         libxklavier
License:      LGPL
Group:        System/Libraries/GNOME
Version:      1.02
Release:      21
Distribution: Cinnabar
Vendor:       Sun Microsystems, Inc.
Summary:      Utility library for XKB
Source:       libxklavier-%{version}.tar.bz2
Patch1:       libxklavier-01-null-dpy-pointer.diff
URL:          http://www.freedesktop.org/Software/LibXklavier
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/doc
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%define libxml2_version 2.6.7
# Fixme - doxyten seems to be unnecessary
#%define doxygen_version 1.2.0

BuildRequires: libxml2-devel >= %{libxml2_version}
#BuildRequires: doxygen >= %{doxygen_version}
Requires: libxml2 >= %{libxml2_version}

%description
libxklavier is a private utility library used in the GNOME control center
used for XKB.

%package devel
Summary:      Eazel Extensions Development Library
Group:        Development/Libraries/GNOME
Requires:     %{name} = %{version}
Requires:     libxml2-devel >= %{libxml2_version}

%description devel
libxklavier is a private utility library used in the GNOME control center
used for XKB.

%prep
%setup -q
%patch1 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CFLAGS="$RPM_OPT_FLAGS"			\
%ifos solaris
./configure --prefix=%{_prefix}		\
	    --disable-doxygen           \
            --with-xkb-base=/usr/X11/lib/X11/xkb \
	    --sysconfdir=%{_sysconfdir}
%else
./configure --prefix=%{_prefix}		\
	    --sysconfdir=%{_sysconfdir}
%endif

make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install 
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%defattr (-, root, root)
%{_libdir}/*.so.*

%files devel
%defattr (-, root, root)
%{_libdir}/*.so
%{_libdir}/pkgconfig/*.pc
%{_includedir}/libxklavier
%{_datadir}/libxklavier

%changelog
* Wed Jul 07 2004 - [email protected]
- ported to rpm4

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Mon Apr 26 2004 - <[email protected]>
- Bump to 1.02

* Tue Apr 6 2004 - <[email protected]>
- Bump to 1.0

* Thu Mar 04 2004 - <[email protected]>
- add patch to fix null pointer segv on Solaris
  patch has also been put into upstream cvs.

* Tue Feb 24 2004 - <[email protected]>
- Update Distro

* Tue Feb 17 2004 - <[email protected]>
- fix build error with Forte caused by out-of-range initialiser

* Tue Feb 17 2004 - <[email protected]>
- disable doxygen when building on Solaris

* Wed Jan 04 2004 - <[email protected]>
- Bumped version to 0.97

* Tue Dec 16 2003 - <[email protected]>
- initial Sun release.