quick-lounge-applet.spec
author dermotm
Mon, 18 Oct 2004 09:30:38 +0000
changeset 4276 2a2c7f354601
parent 4268 420d45f51da6
child 4352 dc2689982835
permissions -rw-r--r--
Incremented release numbers for build 21

#
# Copyright (c) 2003 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

Name:         quick-lounge-applet
License:      GPL
Group:        Productivity/Graphics/Viewers
Version:      2.1.1
Release:      26
Distribution: Cinnabar
Vendor:       Sun Microsystems, Inc.
Summary:      Quick Lounge Panel Applet
Source:       http://ftp.gnome.org/pub/GNOME/sources/quick-lounge-applet/1.1/%{name}-%{version}.tar.bz2
Source1:      quick-lounge-applet-l10n-po-1.5.tar.bz2
Source2:      quick-lounge-applet-docs-0.4.tar.bz2
Source3:      quick-lounge-applet-l10n-online-help-ci.tar.bz2
Patch1:       quick-lounge-applet-01-potfiles-in.diff
Patch2:       quick-lounge-applet-02-xlibs.diff
Patch3:       quick-lounge-applet-03-dialog-properties-crash.diff
Patch4:       quick-lounge-applet-04-unusable-as-root.diff
Patch5:       quick-lounge-applet-05-g11n-alllinguas.diff
URL:          http://www.gnome.org
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/quick-lounge-applet
Autoreqprov:  on

%define gnome_vfs_version 2.4.0
%define libgnome_version 2.4.0
%define libgnomeui_version 2.4.0.1
%define gnome_panel_version 2.4.0
%define gnome_desktop_version 2.4.0
Requires:     gnome-vfs >= %{gnome_vfs_version}
Requires:     libgnome >= %{libgnome_version}
Requires:     libgnomeui >= %{libgnomeui_version}
Requires:     gnome-panel >= %{gnome_panel_version}
Requires:     gnome-desktop >= %{gnome_desktop_version}
BuildRequires: gnome-vfs-devel >= %{gnome_vfs_version}
BuildRequires: libgnome-devel >= %{libgnome_version}
BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: gnome-panel-devel >= %{gnome_panel_version}
BuildRequires: gnome-desktop-devel >= %{gnome_desktop_version}
BuildRequires: javahelp-convert

%description
Quick Lounge Applet allows you to group launchers on your panel.

%prep
%setup -q
bzcat %SOURCE1 | tar xf -
bzcat %SOURCE2 | tar xf -
bzcat %SOURCE3 | tar xf -
%patch1 -p1
%patch2 -p1
%patch3 -p1
%patch4 -p1
%patch5 -p1


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

libtoolize --force
aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros
automake -a -c -f
autoconf

CFLAGS="$RPM_OPT_FLAGS" \
  ./configure \
    --prefix=%{_prefix} \
    --sysconfdir=%{_sysconfdir} \
    --libexecdir=%{_libexecdir} \
    --localstatedir=/var/lib
make -j $CPUS

%install
export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
make -i install DESTDIR=$RPM_BUILD_ROOT
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL  

javahelp-convert-install $RPM_BUILD_ROOT quick-lounge quick-lounge.xml

%clean
rm -rf $RPM_BUILD_ROOT

%post
export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
SCHEMAS="quick-lounge.schemas"
for S in $SCHEMAS; do
        gconftool-2 --makefile-install-rule %{_sysconfdir}/gconf/schemas/$S >/dev/null
done


%files
%doc AUTHORS COPYING ChangeLog NEWS README
%defattr (-, root, root)
%{_datadir}/pixmaps/*.png
%{_datadir}/locale/*/LC_MESSAGES/*.mo
%{_datadir}/gnome-2.0/ui/*
%{_datadir}/quick-lounge/*
%{_sysconfdir}/gconf/schemas/*.schemas
%{_libdir}/bonobo/servers/*
%{_datadir}/gnome/help/quick-lounge/*
%{_datadir}/gnome/javahelp/quick-lounge/*
%{_datadir}/omf/%{name}/*.omf
%{_libexecdir}/*

%changelog -n quick-lounge-applet
* Mon Sep 20 2004 [email protected]
- Added quick-lounge-applet-05-g11n-alllinguas.diff to support hu

* Wed Aug 25 2004 [email protected]
- Updated l10n help tarball name for Cinnabar

* Thu Aug 05 2004 [email protected]
- Incorporate new docs tarball from [email protected].

* Mon Jul 19 2004 - [email protected]
- synced with HEAD, fixed up packaging

* Thu Jul 08 2004 - [email protected]
- fixed typo in patch 04 (p->P)

* Thu Jul 08 2004 - [email protected]
- fixed typo in patch 04 (p->P)

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed Jun 25 2004 - [email protected]
- Add patch from Vinay M R  to fix quicklounge to be usable as root 

* Wed Jun 23 2004 - [email protected]
- Add patch from Vinay M R  to fix the properites dialog crash

* Wed Jun 09 2004 - [email protected]
- Remove l10n online help patch(#2). Changes are now included in base source.

* Wed Jun 02 2004 [email protected]
- Incorporate new docs tarball from [email protected].

* Wed May 12 2004 - [email protected]
- Updated l10n content to quick-lounge-applet-l10n-po-1.1.tar.bz2

* Fri Apr 30 2004 - [email protected]
- add libexecdir to %files.  

* Sun Apr 18 2004 - [email protected]
- enable javahelp conversion on Solaris

* Wed Apr 07 2004 - [email protected]
- add patch 03 to add the Xlibs to LDFLAGS.
- add --libexecdir=%{_libexecdir} to configure args
* Tue Apr 06 2004 - [email protected]
- Remove *.so* from files, as none delivered anymore

* Tue Apr 06 2004 - [email protected]
- Forgot to rename patches in spec file

* Mon Apr 05 2004 - [email protected]
- Bump to 2.1.1
- Remove 3 patches and re-align the remaining two

* Thu Apr 01 2004 - [email protected]
- Javahelp conversion

* Mon Mar 29 2004 - [email protected]
- Updated l10n content to quick-lounge-applet-l10n-po-1.0.tar.bz2

* Thu Mar 04 2004 - <[email protected]>
- Added quick-lounge-applet-05-display-help.diff to display help with 
  correct section id.

* Thu Feb 05 2004 - <[email protected]>
- Upgrade tarball to 2.0.3 for Cinnabar, add l10n docs/help

* Fri Jan 09 2004 - <[email protected]>
- Patch for deprecated widgets compiling

* Tue Oct 14 2003 - <[email protected]>
- Upgrade tarball to 2.0.1 for QS

* Wed Oct 01 2003 - <[email protected]>
- #4930772 and #4930772

* Thu Aug 14 2003 - <[email protected]>
- remove *.a, *.la

* Fri Jun 30 2003 - Glynn Foster <[email protected]>
- Add in the bonobo ui xml menus to the %files directive

* Wed May 15 2003 - Glynn Foster <[email protected]>
- initial Sun release