blueprint.spec
author gman
Wed, 02 Jun 2004 00:19:14 +0000
changeset 2987 2f54e83f7d28
parent 2958 3655558ced77
child 3057 23f08096e7a4
permissions -rw-r--r--
2004-06-02 Glynn Foster <[email protected]> * blueprint.spec: Bump to 0.9.5 so that we get a bug fix for #5051164, a missing Sun branded throbber.

#
# spec file for package blueprint
#
# Copyright (c) 2003 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

Name:         blueprint
Summary:      Engine for GTK2 Blue Print Theme
Version:      0.9.5
Release:      1
License:      LGPL
Distribution: Cinnabar
Vendor:	      Sun Microsystems, Inc.
Group:        System/GUI/GNOME
Source:       %{name}-%{version}.tar.bz2
Source1: blueprint-l10n-po-1.1.tar.bz2
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
URL:          http://www.gnome.org

%define gtk2_version 2.2.1
%define intltool_version 0.25
BuildRequires: gtk2 >= %{gtk2_version}
BuildRequires: intltool >= %{intltool_version}

%description
Engine for GTK2 Blue Print Theme
Property of Sun Microsystems Inc., 2003

%prep
%setup -q
/usr/bin/bzcat -dc %SOURCE1|tar xf -

%build
CFLAGS="$RPM_OPT_FLAGS"
./configure --prefix=%{_prefix}  \
	    --libdir=%{_prefix}/%_lib \
	    --sysconfdir=%{_sysconfdir} 
make
cd -

%install
make DESTDIR=$RPM_BUILD_ROOT install
mkdir -p $RPM_BUILD_ROOT%{_defaultdocdir}/blueprint-engine
cp -a AUTHORS COPYING ChangeLog NEWS README $RPM_BUILD_ROOT%{_defaultdocdir}/blueprint-engine

# Hack to install images into %{_datadir}/pixmaps with blueprint prefix
mkdir -p $RPM_BUILD_ROOT%{_datadir}/pixmaps
mkdir -p /tmp/blueprint-pixmaps
installfiles=`find icons/48x48 -name "*.png"`				
for i in $installfiles; do						
  echo '-- moving '$i ;						
  cp $i /tmp/blueprint-pixmaps ;             				
done;                                           			
installfiles=`find /tmp/blueprint-pixmaps -name "*.png" |sed 's/^\/tmp\/blueprint-pixmaps\///'`

for i in $installfiles; do                     			
  echo '-- Installing '$i ;                  				
  mv /tmp/blueprint-pixmaps/$i $RPM_BUILD_ROOT%{_datadir}/pixmaps/blueprint-$i ; 	
  done ;                                          			
rm -rf /tmp/blueprint-pixmaps/

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr(-, root, root)
%doc AUTHORS COPYING ChangeLog NEWS README
%{_defaultdocdir}/blueprint-engine/ChangeLog
%{_defaultdocdir}/blueprint-engine/AUTHORS
%{_defaultdocdir}/blueprint-engine/COPYING
%{_defaultdocdir}/blueprint-engine/README
%{_defaultdocdir}/blueprint-engine/NEWS
%{_libdir}/gtk-2.0/*/engines/*.so
%{_datadir}/themes/*
%{_datadir}/icons/*
%{_datadir}/locale/*
%{_datadir}/pixmaps/*

%changelog
* Wed Jun 2 2004 - [email protected]
- Bump to 0.9.5

* Wed May 12 2004 - [email protected]
- Updated l10n content to blueprint-l10n-po-1.1.tar.bz2

* Wed Mar 31 2004 - [email protected]
- replace tar jxf with the more solaris friendly
  bzcat piped through tar

* Mon Mar 29 2004 - [email protected]
- Adding blueprint-l10n-po-1.0.tar.bz2 l10n content

* Fri Mar 12 2004 Niall Power <[email protected]>
- remove "rm -rf" evil from the install stage

* Mon Feb 16 2004 Niall Power <[email protected]>
- add ACLOCAL_FLAGS to aclocal invocation
- do not use the -printf argument with find - it
  doesn't work on Solaris (pipe through sed instead)

* Fri Jan 19 2004 Takao Fujiwara <[email protected]>
- Modified blueprint.spec for i18n

* Thu Aug 14 2003 - <[email protected]>
- remove *.a, *.la

* Wed Jul 02 2003 Erwann Chenede - <[email protected]>
- cleanup + icons theme addition

* Mon May 12 2003 Erwann Chenede - <[email protected]>
- initial implementation of the spec file