libIDL.spec
author jan
Sat, 02 Oct 2004 22:06:15 +0000
changeset 4121 397b519ee64a
parent 4007 3cf8b6afa295
child 4127 69ec35a2e770
permissions -rw-r--r--
Create 64bit libraries for Solaris

Name:         libIDL
License:      LGPL
Group:        System/Libraries
Version:      0.8.3
Release:      19
Distribution: Cinnabar
Vendor:       Sun Microsystems, Inc.
Summary:      IDL parsing library
Source:       http://ftp.gnome.org/pub/GNOME/sources/libIDL/0.8/libIDL-%{version}.tar.bz2
Source1:      libIDL-2.3.gz
URL:          http://www.gnome.org
Docdir:       %{_defaultdocdir}/doc
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
AutoReqProv:  on
Prereq:       /sbin/ldconfig

%define glib2_version 2.4.0
%define pkgconfig_version 0.15.0

Requires:      glib2 >= %{glib2_version}
BuildRequires: glib2-devel >= %{glib2_version}
BuildRequires: pkgconfig >= %{pkgconfig_version}

%description
libIDL is a small library for creating parse trees of CORBA v2.2
compliant Interface Definition Language (IDL) files, which is a
specification for defining interfaces which can be used between
different CORBA implementations.

%package devel
Summary:      IDL parsing library development libraries and header files.
Group:        Development/Languages/Other
Requires:     %{name} = %{version}
Requires:     glib2-devel >= %{glib2_version}

%description devel
libIDL is a small library for creating parse trees of CORBA v2.2
compliant Interface Definition Language (IDL) files, which is a
specification for defining interfaces which can be used between
different CORBA implementations.

%prep
%setup -q

%ifos solaris
cd ..
cp -rp libIDL-%{version} libIDL-%{version}-64
%endif


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

CONFLAGS="--prefix=%{_prefix} --infodir=%{_infodir}"

%ifos solaris

CPUS=$(($CPUS*4))

cd ../libIDL-%version-64

export CFLAGS="$CFLAGS64"
export PKG_CONFIG_PATH="$PKG_CONFIG_PATH64"

./configure $CONFLAGS					\
            --bindir=%{_bindir}/%{_arch64}		\
            --libdir=%{_libdir}/%{_arch64}		\
            --libexecdir=%{_libexecdir}/%{_arch64}	\
            --sysconfdir=%{_sysconfdir}/%{_arch64}

make -j $CPUS

cd ../libIDL-%version

export CFLAGS="$RPM_OPT_FLAGS"
export PKG_CONFIG_PATH="$PKG_CONFIG_PATH32"

%endif

CFLAGS="$RPM_OPT_FLAGS"				\
./configure $CONFLAGS				\
            --sysconfdir=%{_sysconfdir}
make -j $CPUS

%install

%ifos solaris
cd ../libIDL-%version-64
make install DESTDIR=$RPM_BUILD_ROOT
cd ../libIDL-%version
%endif

make DESTDIR=$RPM_BUILD_ROOT install
install -d $RPM_BUILD_ROOT/usr/share/man/man3
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT/usr/share/man/man3
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*.la

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%defattr(-,root,root)
%{_libdir}/*.so.*

%files devel
%defattr(-,root,root)
%{_bindir}/*
%{_libdir}/pkgconfig/*.pc
%{_libdir}/*.so
%{_includedir}/*
%{_mandir}/man3/*
%{_infodir}/*.info.gz

%changelog
* Sat Oct  2 2004 - [email protected]
- Create 64bit libraries for Solaris

* Thu Jul 08 2004 - [email protected]
- ported to rpm4

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed Jan 28 2004 - <[email protected]> 0.8.3-1
- Upgrade to 0.8.3

* Mon Dec 15 2003 - <[email protected]>
- Add back the man pages.

* Thu Aug 14 2003 - <[email protected]>
- move lib*.so to -devel, remove *.a, *.la

* Fri Aug 01 2003 - <[email protected]> 0.8.2-1
- Upgrade to 0.8.2

* Tue May 20 2003 - <[email protected]>
- initial Sun release