flac.spec
author dcarbery
Thu, 15 Feb 2007 08:34:55 +0000
changeset 9298 3dbf2b411ba8
parent 8706 f5e00fe9610a
permissions -rw-r--r--
2007-02-15 Damien Carbery <[email protected]> * flac.spec: Bump to 1.1.4.

#
# spec file for package flac
#
# Copyright (c) 2003 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: yippi
#
Name:         flac
License:      Xiph
Group:        Application/Devel
Version:      1.1.4
Release:      2
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      An Open Source Lossless Audio Codec
Source:       http://easynews.dl.sourceforge.net/sourceforge/%{name}/%{name}-%{version}.tar.gz
#owner:yippi date:2005-08-12 type:bug
Patch1:       flac-01-forte.diff
URL:          http://flac.sourceforge.net/
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_docdir}/%{name}
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%description
FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, 
FLAC is similar to MP3, but lossless, meaning that audio is compressed 
in FLAC without any loss in quality. This is similar to how Zip works, 
except with FLAC you will get much better compression because it is 
designed specifically for audio, and you can play back compressed FLAC 
files in your favorite player (or your car or home stereo, see supported 
devices) just like you would an MP3 file.

%package devel
Summary:	flac development files
Group:		Development/Libraries
Requires:	%{name} = %{version}

%description devel
flac development files.

%prep
%setup -q
perl -pi -e 's/^M$//' src/share/replaygain_analysis/replaygain_analysis.c
%ifos solaris
%patch1 -p1
%endif

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

autoconf
CFLAGS="$RPM_OPT_FLAGS" \
./configure --prefix=%{_prefix} \
            --sysconfdir=%{_sysconfdir} \
            --mandir=%{_mandir}

make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install

#Clean up unpackaged files
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*la

%clean
rm -rf $RPM_BUILD_ROOT

%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig

%files
%defattr(-,root,root)
%{_datadir}/doc/*
%{_datadir}/man/man1/flac*
%{_datadir}/man/man1/metaflac*
%attr(755,root,root) %{_bindir}/*
%attr(755,root,root) %{_libdir}/libFLAC.so*
%attr(755,root,root) %{_libdir}/libFLAC++.so*
%attr(755,root,root) %{_libdir}/libOggFLAC.so*
%attr(755,root,root) %{_libdir}/libOggFLAC++.so*

%files devel
%defattr(-,root,root)
%{_includedir}/*
%{_datadir}/aclocal/*.m4

%changelog
* Thu Feb 15 2006 - [email protected]
- Bump to 1.1.4.
* Thu Nov 30 2006 - [email protected]
- Bump to 1.1.3.
* Fri Aug 12 2005 - [email protected]
- Add patch flac-01-forte.diff
* Tue Aug 02 2005 - [email protected]
- Initial spec file checkin