SUNWgnome-spell.spec
author dcarbery
Mon, 10 Sep 2007 06:44:29 +0000
branchgnome-2-18
changeset 18961 3fd33e55b06c
parent 9794 b8f6ab13caf3
child 10572 8cdee8cd9c9c
permissions -rw-r--r--
2007-09-10 Damien Carbery <[email protected]> ==== JDS Nevada build 74 ====

#
# spec file for package SUNWgnome-spell
#
# includes module(s): gnome-spell, enchant
#
# Copyright (c) 2004 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: jefftsai
#
%include Solaris.inc
%use gspell = gnome-spell.spec
%use enchant = enchant.spec

Name:          SUNWgnome-spell
Summary:       GNOME spell checker component
Version:       %{default_pkg_version}
SUNW_BaseDir:  %{_basedir}
BuildRoot:     %{_tmppath}/%{name}-%{version}-build
%include default-depend.inc
Requires:      SUNWgnome-component
Requires:      SUNWgnome-base-libs
Requires:      SUNWgnome-config
Requires:      SUNWgnome-libs
Requires:      SUNWlibC
BuildRequires: SUNWgnome-base-libs-devel
BuildRequires: SUNWgnome-config-devel
BuildRequires: SUNWgnome-libs-devel
BuildRequires: SUNWgnome-component-devel

%package devel
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_basedir}
Requires:                %{name} = %{version}
%include default-depend.inc

%if %build_l10n
%package l10n
Summary: %{summary} - l10n content
SUNW_BaseDir: %{_basedir}
%include default-depend.inc
Requires: %name
%endif

%prep
rm -rf %name-%version
mkdir -p %name-%version
%enchant.prep -d %name-%version
%gspell.prep -d %name-%version

%build
%if %cc_is_gcc
%else
export CXX="${CXX} -norunpath"
%endif

# See http://bugzilla.abisource.com/show_bug.cgi?id=10668 for why LD is set 
# to $CXX.
export LD=$CXX
%enchant.build -d %name-%version
export CFLAGS="%optflags"
export CXXFLAGS="%cxx_optflags"
export PKG_CONFIG_PATH=../enchant-%{enchant.version}:%{_pkg_config_path}
export LDFLAGS="%_ldflags"
%gspell.build -d %name-%version

%install
%enchant.install -d %name-%version
%gspell.install -d %name-%version

%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
%endif

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/libenchant*
%{_libdir}/bonobo
%dir %{_libdir}/gnome-spell
%{_libdir}/gnome-spell/*.so
%dir %{_libdir}/enchant
%{_libdir}/enchant/*.so
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/control-center-2.0
%{_datadir}/control-center-2.0/*
%{_datadir}/enchant
%{_datadir}/gnome-spell-%{gspell.version}
%{_datadir}/idl
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/man1
%{_mandir}/man1/*

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%endif

%changelog
* Thu Apr 26 2007 - [email protected]
- set CXX to $CXX -norunpath because libtool swallows this option sometimes
  and leaves compiler paths in the binaries
* Wed Apr 4 2007 - [email protected]
- remove enchant++.h from the package.
* Fri Mar 23 2007 - [email protected]
- Change %{_datadir}/control-center-2.0 perms to root:other on snv to match
  SUNWj5rt and SUNWj6rt who set the perms in their postinstall scripts.
* Thu Mar 15 2007 - [email protected]
- Add Requires SUNWlibC after check-deps.pl run.
* Thu Mar 08 2007 - [email protected]
- Remove dependency on aspell.
* Wed Feb 14 2007 - [email protected]
- Make gnome-spell use enchant.
* Sun Jan 28 2007 - [email protected]
- update %files so that dir attributes work on both s10 and nevada
* Mon Dec 11 2006 - [email protected]
- Set LD to $CXX so that linking to C++ libs works in enchant.
* Fri Dec 08 2006 - [email protected]
- Add enchant.spec module and update %files.
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Thu May 11 2006 - [email protected]
- Merge -share pkg(s) into the base pkg(s).
* Fri Apr 21 2006 - [email protected].
- Add %{_libdir}/aspell to PATH,
  this is becuase aspell change, refer to LSARC/2006/231
* Mon Feb 20 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Sat Oct 30 2004 - [email protected]
- change version to 2.6.0 to match other GNOME pkgs
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Thu Sep 23 2004 - [email protected]
- Add BuildRequires SUNWgnome-libs-devel so libgnomeui is available for 
  gnome-spell.
* Tue Jun 22 2004 - [email protected]
- changed install location to /usr/lib and /usr/bin
* Thu Mar 11 2004 - <[email protected]>
- initial version created