flac.spec
author bviswa
Fri, 12 Aug 2005 06:08:31 +0000
changeset 5521 41f732d553dc
parent 5518 235b0b4aa324
child 5528 8eaf8a1cb170
permissions -rw-r--r--
2005-08-12 Balamurali Viswanathan <[email protected]> * flac.spec: Update * patch-status.txt: Update * patches/flac-01-forte.diff: Patch to make flac compile in Solaris * patches/gnome-media-X-cdda.diff: Remove * patches/gnome-media-X-lossless-wav.diff Remove: * patches/gnome-media-X-play-not-working.diff: Remove 2005-08-12 Balamurali Viswanathan <[email protected]> * SUNWflac.spec: New spec file for flac * SUNWgnome-media.spec: Add dependency of flac

#
# spec file for package flac
#
# Copyright (c) 2003 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         flac
License:      Xiph
Group:        Application/Devel
Version:      1.1.2
Release:      2
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      An Open Source Lossless Audio Codec
Source:       http://prdownloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
Patch1:       flac-01-forte.diff
URL:          http://flac.sourceforge.net/
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_docdir}/%{name}
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%description
FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, 
FLAC is similar to MP3, but lossless, meaning that audio is compressed 
in FLAC without any loss in quality. This is similar to how Zip works, 
except with FLAC you will get much better compression because it is 
designed specifically for audio, and you can play back compressed FLAC 
files in your favorite player (or your car or home stereo, see supported 
devices) just like you would an MP3 file.

%package devel
Summary:	flac development files
Group:		Development/Libraries
Requires:	%{name} = %{version}

%description devel
flac development files.

%prep
%setup -q
perl -pi -e 's/^M$//' src/share/replaygain_analysis/replaygain_analysis.c
%patch1 -p1

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

autoconf
CFLAGS="$RPM_OPT_FLAGS" \
./configure --prefix=%{_prefix} \
            --sysconfdir=%{_sysconfdir} \
            --mandir=%{_mandir}

make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install

#Clean up unpackaged files
rm $RPM_BUILD_ROOT%{_libdir}/*.a
rm $RPM_BUILD_ROOT%{_libdir}/*la

%clean
rm -rf $RPM_BUILD_ROOT

%post -p /sbin/ldconfig
%postun -p /sbin/ldconfig

%files
%defattr(-,root,root)
%{_datadir}/doc/*
%{_datadir}/man/man1/flac*
%{_datadir}/man/man1/metaflac*
%attr(755,root,root) %{_bindir}/*
%attr(755,root,root) %{_libdir}/libFLAC.so*
%attr(755,root,root) %{_libdir}/libFLAC++.so*
%attr(755,root,root) %{_libdir}/libOggFLAC.so*
%attr(755,root,root) %{_libdir}/libOggFLAC++.so*

%files devel
%defattr(-,root,root)
%{_includedir}/*
%{_datadir}/aclocal/*.m4

%changelog
* Fri Aug 12 2005 - [email protected]
- Add patch flac-01-forte.diff
* Tue Aug 02 2005 - [email protected]
- Initial spec file checkin