SUNWgtk-doc.spec
author davelam
Wed, 24 Feb 2010 04:10:23 +0000
branchgnome-2-28
changeset 18642 478b5460cc36
parent 16736 6c815aa0eecf
child 17206 c9355ec42045
permissions -rw-r--r--
add new proto file for b133

%include default-depend.inc
%include Solaris.inc

%use gtkdoc = gtk-doc.spec

Name:                    SUNWgtk-doc
Summary:                 GTK+ DocBook Documentation Generator
Version:                 %{default_pkg_version}
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

Requires: SUNWPython26
Requires: SUNWgnome-xml-root
Requires: SUNWgnome-common-devel
BuildRequires: SUNWPython26-devel
BuildRequires: SUNWgnome-doc-utils

%prep
rm -rf %name-%version
mkdir %name-%version

%gtkdoc.prep -d %name-%version
cd %{_builddir}/%name-%version

%build
cd %{_builddir}
export PYTHON="/usr/bin/python2.6"
export CXXFLAGS="%{cxx_optflags}"
export ACLOCAL_FLAGS="-I /usr/share/gnome-doc-utils -I./m4"
%gtkdoc.build -d %name-%version

%install
rm -rf $RPM_BUILD_ROOT
%gtkdoc.install -d %name-%version

# Normally we build this package before we build scrollkeeper, but
# remove any scrollkeeper files if user happens to rebuild this
# package after scrollkeeper is already on the system.
#
rm -rf $RPM_BUILD_ROOT%{_prefix}/var

# Remove /usr/share/info/dir, it's a generated file and shared by multiple
# packages
rm -f $RPM_BUILD_ROOT%{_datadir}/info/dir

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%doc -d gtk-doc-%{gtkdoc.version} README MAINTAINERS
%doc(bzip2) -d gtk-doc-%{gtkdoc.version} COPYING COPYING-DOCS NEWS ChangeLog
%dir %attr (0755, root, other) %{_datadir}/doc
%dir %attr (0755, root, other) %{_datadir}/aclocal
%{_datadir}/aclocal/gtk-doc.m4
%dir %attr (0755, root, bin) %{_datadir}/omf
%{_datadir}/omf/gtk-doc-manual/gtk-doc-manual-C.omf
%{_datadir}/sgml/gtk-doc/gtk-doc.cat
%{_datadir}/gtk-doc/data/*
%{_datadir}/pkgconfig/gtk-doc.pc
%dir %attr (0755, root, other) %{_datadir}/gnome
%{_datadir}/gnome/help/gtk-doc-manual/C/gtk-doc-manual.xml
%{_datadir}/gnome/help/gtk-doc-manual/C/fdl-appendix.xml
%{_bindir}/gtkdoc*

%changelog
* Tue Oct 13 2009 - [email protected]
- Correct Summary line(doo9505).
* Mon Mar 23 2009 - [email protected]
* Add 'BuildRequires: SUNWgnome-doc-utils'.
* Mon Mar 23 2009 - [email protected]
- Change BuildRequires to SUNWPython26-devel.
* Thu Mar 19 2009 - [email protected]
- Add BuildRequires: SUNWPython-devel