oxygen2.spec
author dermotm
Mon, 23 May 2005 09:28:28 +0000
changeset 5458 4c7bf791deca
parent 5452 19218a29c2bc
child 5460 54346da409d4
permissions -rw-r--r--
bump src tarballs for moz/evo/apoc

#
# License (c) 2003 Sun Microsystems Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
%define t_suffix -build36-linux-cb
%define _unpackaged_files_terminate_build 0
%{?nightly:%define t_suffix -%(TZ=GMT date +%Y%m%d)}

Name:		oxygen2
Version:	1.4
Release:	59
Vendor:		Sun Microsystems, Inc.
Distribution:	Java Desktop System, Release 3
Copyright:	LGPL/GPL
BuildRoot:	%{_tmppath}/%{name}-%{version}-root
Docdir:		%{_datadir}/doc
Autoreqprov:	on
URL:		http://www.sun.com/software/javadesktopsystem/
Source:		%{name}-%{version}%{t_suffix}.tar.bz2
Source1:        mkinstalldirs
Source2: oxygen2-l10n-po-1.15.tar.bz2
Source3: l10n-configure.sh
Patch1:         oxygen2-01-g11n-alllinguas.diff
BuildRequires:	glibc-devel
BuildRequires:	libtool
BuildRequires:	glib2-devel
BuildRequires:	libsoup-devel
BuildRequires:	evolution-devel	
BuildRequires:  libgal-devel 
BuildRequires:  libbonoboui-devel
BuildRequires:  bonobo-activation-devel
BuildRequires:	libxml2-devel
Summary:	The Evolution Exchange connector
Group:		System Environment/Libraries
Requires:	libsoup
Requires:	evolution
Requires:	glib2
Requires:	libgal
Requires:       bonobo-activation
Requires:	libxml2

%description
The MS Exchange connector, protocol webdev.

%files
%defattr(755, root, root)
%doc COPYING ChangeLog AUTHORS INSTALL NEWS README
%{_bindir}/*
%{_libdir}/evolution/*/camel-providers/lib*.so
%{_libdir}/evolution/*/camel-providers/*.urls
%{_libdir}/bonobo
%{_libexecdir}/evolution/1.4/evolution-exchange-storage
%{_sysconfdir}/gconf/schemas/apps_evolution_exchange.schemas
%{_datadir}/ximian-connector
%{_datadir}/evolution
%{_datadir}/locale

%post
ldconfig

%prep
case "${RPM_COMMAND:-all}" in
dist)
%setup  -q -D -n %{name}-%{version}
bzcat %SOURCE2 | tar xf -
    ;;
all)
%setup  -q -n %{name}-%{version}
%patch1 -p1

bzcat %SOURCE2 | tar xf -
    ;;
esac
cp %SOURCE1 .

bash -x %SOURCE3

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

export LDFLAGS=$LDFLAGS" -R`pkg-config --variable=privlibdir evolution-shell`" 
MAKE=${MAKE:-make}
RPM_COMMAND=${RPM_COMMAND:-all}
ARCH=%{_target_platform}
export MAKE RPM_COMMAND ARCH
case "$RPM_COMMAND" in
prepare|all)
    aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros
    libtoolize --force
    glib-gettextize --force --copy
    intltoolize --force --automake
    autoheader
    automake -a -f -c --gnu
    autoconf
    ./configure --prefix=%{_prefix} \
	--libexecdir=%{_libexecdir} \
	--sysconfdir=%{_sysconfdir} \
        --enable-ldap=/usr
    ;;
esac
export DESTDIR=${DESTDIR:-"$RPM_BUILD_ROOT"}
case "$RPM_COMMAND" in
clean|all)
    if [ "/" != "$DESTDIR" ]; then
        rm -rf "$DESTDIR"
    fi
    ;;
esac
case "$RPM_COMMAND" in
build|all)
    ${MAKE} -j $CPUS
    ;;
esac

%install
MAKE=${MAKE:-make}
DESTDIR=${DESTDIR:-"$RPM_BUILD_ROOT"}
export DESTDIR
case "${RPM_COMMAND:-all}" in
install|all)
     ${MAKE} install DESTDIR=${DESTDIR}
    ;;
esac

%clean
DESTDIR=${DESTDIR:-"$RPM_BUILD_ROOT"}
export DESTDIR
case "${RPM_COMMAND:-all}" in
clean|all)
    if [ "/" != "$DESTDIR" ]; then
        rm -rf "$DESTDIR"
    fi
    ;;
esac
%changelog
* Mon May 23 2005 - [email protected]
- Bump source tarball to build 36 (linux)

* Mon May 09 2005 - [email protected]
- Bump source tarball to build 35 (linux)

* Mon Apr 25 2005 - [email protected]
- Bump source tarball to build 34 (linux)

* Mon Apr 11 2005 - [email protected]
- Bump source tarball to build 33 (linux)

* Mon Mar 28 2005 - [email protected]
- Bump source tarball to build 32 (linux)

* Mon Mar 14 2005 - [email protected]
- Bump source tarball to build 31 (linux)

* Mon Feb 28 2005 - [email protected]
- Bump source tarball to build 30 (linux)

* Mon Feb 14 2005 - [email protected]
- Bump source tarball to build 29 (linux)

* Mon Jan 31 2005 - [email protected]
- Bump source tarball to build 28 (linux)

* Mon Jan 17 2005 - [email protected]
- Bump source tarball to build 27 (linux)

* Tue Jan 04 2005 - [email protected]
- Bump source tarball to build 26 (linux)

* Mon Dec 13 2004 - [email protected]
- Bump source tarball to build 25 (linux)

* Mon Nov 29 2004 - [email protected]
- Bump source tarball to build 24

* Mon Nov 15 2004 - [email protected]
- Bump source tarball to build 23.

* Mon Nov 01 2004 - [email protected]
- bump src tarball to build22

* Mon Oct 18 2004 - [email protected]
- bump src tarball to build21

* Mon Oct 11 2004 - [email protected]
- bump src tarball to build20b

* Thu Oct 07 2004 - [email protected]
- Recreated oxygen2-01-g11n-alllinguas.diff

* Mon Sep 20 2004 - [email protected]
- removed patch 01

* Mon Sep 20 2004 - [email protected]
- bump src tarball to build19

* Thu Sep 17 2004 - [email protected]
- Added oxygen2-01-g11n-alllinguas.diff to support cs,hu linguas

* Tue Sep 15 2004 - [email protected]
- Add _unpackaged_files_terminate_build to 
- disable rpm v4.1.1 "Checking for unpackaged file" feature

* Mon Sep 06 2004 - [email protected]
- bump src tarball to build18

* Tue Aug 24 2004 - [email protected]
- changed %{_sysconfdir}/* to %{_sysconfdir}/gconf/schemas/apps_evolution_exchange.schemas 

* Mon Aug 23 2004 - [email protected]
- bump src tarball to build17

* Mon Aug 09 2004 - [email protected]
- bump src tarball to build16

* Tue Jul 27 2004 - [email protected]
- remove patch 01

* Mon Jul 26 2004 - [email protected]
- bump src tarball to build15

* Fri Jul 16 2004 - [email protected]
- change the version number to 1.4 approved by Henry Jia
* Mon Jul 12 2004 - [email protected]
- bump src tarball to build14

* Fri Jul 09 2004 - [email protected]
- Added patch1 for language content inclusion

* Thu Jul 08 2004 - [email protected]
- Adding oxygen2-l10n-po-1.2.tar.bz2 l10n content

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Fri Jun 25 2004 - [email protected]
- bump src tarball to build13
* Wed Jun 16 2004 - [email protected]
- Remove upstream applied patch.
* Fri Jun 11 2004 - [email protected]
- Add patch for configure.in.
* Thu Jun 10 2004 - [email protected]
- bump src tarball to build12