Solaris/SUNWjpg.spec
author lp117937
Fri, 30 Jun 2006 04:08:48 +0000
changeset 7547 52ffe601b5b0
parent 7425 5f918d0fa619
child 8055 20da8ce7efe7
permissions -rw-r--r--
2006-06-29 Laszlo (Laca) Peter <[email protected]> * SUNWevolution-webcal.spec, SUNWevolution.spec, SUNWfirefox.spec, SUNWfsexam.spec, SUNWgnome-a11y-dasher.spec, SUNWgnome-a11y-gok.spec, SUNWgnome-a11y-reader.spec, SUNWgnome-applets.spec, SUNWgnome-archive-mgr.spec, SUNWgnome-calculator.spec, SUNWgnome-camera.spec, SUNWgnome-cd-burner.spec, SUNWgnome-cd.spec, SUNWgnome-character-map.spec, SUNWgnome-config-editor.spec, SUNWgnome-crash-report.spec, SUNWgnome-desktop-prefs.spec, SUNWgnome-dialog.spec, SUNWgnome-display-mgr.spec, SUNWgnome-doc-utils.spec, SUNWgnome-file-mgr.spec, SUNWgnome-games.spec, SUNWgnome-gui-test.spec, SUNWgnome-help-viewer.spec, SUNWgnome-hex-editor.spec, SUNWgnome-im-client.spec, SUNWgnome-img-editor.spec, SUNWgnome-img-viewer.spec, SUNWgnome-libs.spec, SUNWgnome-media-apps.spec, SUNWgnome-media-player.spec, SUNWgnome-media.spec, SUNWgnome-meeting.spec, SUNWgnome-panel.spec, SUNWgnome-pdf-viewer.spec, SUNWgnome-perf-meter.spec, SUNWgnome-pilot.spec, SUNWgnome-print.spec, SUNWgnome-remote-desktop.spec, SUNWgnome-screensaver.spec, SUNWgnome-session.spec, SUNWgnome-system-tools.spec, SUNWgnome-terminal.spec, SUNWgnome-text-editor.spec, SUNWgnome-themes.spec, SUNWgnome-ui-designer.spec, SUNWgnome-user-docs.spec, SUNWgnome-utils.spec, SUNWgnome-vfs.spec, SUNWgnome-wm.spec, SUNWrealplayer.spec, SUNWthunderbird.spec: update gconf postrun scripts and/or classify postrun scripts as JDS or JDS_wait. JDS_wait jobs are the ones that need to finish before the desktop is usable.

#
# spec file for package SUNWjpg
#
# includes module(s): jpeg
#
# Copyright (c) 2004 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include Solaris.inc

%define tarball_version 6b

Name:                    SUNWjpg
Summary:                 jpeg - The Independent JPEG Groups JPEG software
Version:                 20.%{default_pkg_version}
Source:                  http://www.ijg.org/files/jpegsrc.v%{tarball_version}.tar.gz
Source1:                 cjpeg.1
Source2:                 djpeg.1
Source3:                 jpegtran.1
Source4:                 rdjpgcom.1
Source5:                 wrjpgcom.1
Source6:                 libjpeg.3
Source7:                 l10n-configure.sh
SUNW_BaseDir:            %{_prefix}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc

%package devel
Summary:                 %{summary} - development files
SUNW_BaseDir:            %{_prefix}
%include default-depend.inc

%prep
%setup -c -n %name-%version
cd jpeg-%{tarball_version}

%ifarch amd64 sparcv9
cd ..
mv jpeg-%{tarball_version} jpeg-%{tarball_version}-64
gzcat %SOURCE0 | tar xf -
cd jpeg-%{tarball_version}
%endif

bash -x %SOURCE7

%build
CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
if test "x$CPUS" = "x" -o $CPUS = 0; then
    CPUS=1
fi
export CFLAGS="$RPM_OPT_FLAGS"
cd jpeg-%{tarball_version}
./configure --enable-shared --prefix=%{_prefix} --exec-prefix=%{_prefix}
sed -e "s%%^CC=\"/.*\"%%CC=\"$CC\"%%" `which libtool` > libtool
chmod a+x libtool
make -j$CPUS

%ifarch amd64 sparcv9
cd ../jpeg-%{tarball_version}-64
export CFLAGS="%optflags64"
export LDFLAGS="%_ldflags %optflags64"
export LD_RUN_PATH=%{_prefix}/lib/%{_arch64}
export CC=${CC64:-$CC}
ccdir=`dirname $CC`
export PATH=$ccdir:$PATH
./configure --enable-shared --prefix=%{_prefix} --exec-prefix=%{_prefix}
sed -e "s%%^CC=\"/.*\"%%CC=\"$CC\"%%" `which libtool` > libtool
chmod a+x libtool
make -j$CPUS
%endif

%install
cd jpeg-%{tarball_version}
mkdir -p $RPM_BUILD_ROOT/dummy
mkdir -p $RPM_BUILD_ROOT%{_libdir} $RPM_BUILD_ROOT%{_bindir}
mkdir -p $RPM_BUILD_ROOT%{_includedir}
mkdir -p $RPM_BUILD_ROOT%{_mandir}/man1
make install mandir=$RPM_BUILD_ROOT%{_mandir}/man1 bindir=$RPM_BUILD_ROOT%{_bindir} includedir=$RPM_BUILD_ROOT%{_includedir} libdir=$RPM_BUILD_ROOT%{_libdir}

%ifarch amd64 sparcv9
cd ../jpeg-%{tarball_version}-64
mkdir -p $RPM_BUILD_ROOT%{_libdir}/%{_arch64}
make install bindir=$RPM_BUILD_ROOT/dummy includedir=$RPM_BUILD_ROOT/dummy mandir=$RPM_BUILD_ROOT/dummy libdir=$RPM_BUILD_ROOT%{_libdir}/%{_arch64}
rm -f $RPM_BUILD_ROOT%{_libdir}/%{_arch64}/lib*a
%endif

rm -rf $RPM_BUILD_ROOT%{_mandir}
install -d $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0644 %SOURCE2 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0644 %SOURCE3 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0644 %SOURCE4 $RPM_BUILD_ROOT%{_mandir}/sman1
install --mode=0644 %SOURCE5 $RPM_BUILD_ROOT%{_mandir}/sman1
install -d $RPM_BUILD_ROOT%{_mandir}/sman3
install --mode=0644 %SOURCE6 $RPM_BUILD_ROOT%{_mandir}/sman3

rm -f $RPM_BUILD_ROOT%{_libdir}/lib*a
rm -rf $RPM_BUILD_ROOT/dummy

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/lib*.so*
%ifarch amd64 sparcv9
%dir %attr (0755, root, bin) %{_libdir}/%{_arch64}
%{_libdir}/%{_arch64}/lib*.so*
%endif
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr(0755, root, sys) %{_datadir}
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/sman1
%{_mandir}/sman1/*

%files devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_includedir}
%{_includedir}/*
%dir %attr(0755, root, sys) %{_datadir}
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/sman3
%{_mandir}/sman3/*

%changelog
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Wed May 10 2006 - [email protected]
- merge -share pkg(s) into the base pkg(s)
* Thu Apr 06 2006 - [email protected]
- Now use tarball-version
* Fri Feb 17 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Fri Sep 02 2005 - [email protected]
- remove unpackaged files
* Fri Oct 29 2004 - [email protected]
- use $CC64 as the 64-bit C compiler, if defined
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Sat Oct  2 2004 - [email protected]
- Create 64bit libraries for Solaris
* Mon Aug 30 2004 - [email protected]
- Bug 5091588 : Include files and man3 files should be in separate devel package
* Thu Aug 12 2004 - [email protected]
- Updated Version to be 2.6.0 since delivering w/ G2.6
* Sun Feb 23 2004 - [email protected]
- initial version added to CVS