at-poke.spec
author dermotm
Mon, 23 May 2005 09:34:35 +0000
changeset 5460 54346da409d4
parent 5414 219255e89582
child 5484 b4c330e76240
permissions -rw-r--r--
Incremented release numbers for build 36

Name:         at-poke
License:      LGPL
Group:        System/Libraries/GNOME
Version:      0.2.2
Release:      36
Distribution: Java Desktop System, Release 3
Vendor:       Sun Microsystems, Inc.
Summary:      Tool to poke around accessibility infrastructure
Source:       http://ftp.gnome.org/pub/GNOME/sources/at-poke/0.2/%{name}-%{version}.tar.bz2
Source1:      at-poke.1.gz
Source2:      l10n-configure.sh
URL:          http://developer.gnome.org/projects/gap
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/doc
Autoreqprov:  on
Prereq:       /sbin/ldconfig

%define libgnomeui_version 2.4.0.1
%define gtk2_version 2.2.4
%define atk_version 1.4.0
%define at_spi_version 1.1.8
%define libgail_gnome_version 1.0.2

# Requirements: libgail-gnome libglade-2.0
BuildRequires: gtk2-devel >= %{gtk2_version}
BuildRequires: libgnomeui-devel >= %{libgnomeui_version}
BuildRequires: at-spi-devel >= %{at_spi_version}
BuildRequires: libgail-gnome >= %{libgail_gnome_version}
Requires:      atk >= %{atk_version}
Requires:      gtk2 >= %{gtk2_version}
Requires:      libgnomeui >= %{libgnomeui_version}
Requires:      at-spi >= %{at_spi_version}
Requires:      libgail-gnome >= %{libgail_gnome_version}

%description
at-poke is a tool that allows one to examine the widigts from an accessibility perspective.

%prep
%setup -q 

bash -x %SOURCE2

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

./configure --prefix=%{_prefix}

make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
install -d $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %SOURCE1 $RPM_BUILD_ROOT%{_mandir}/man1

%clean
rm -rf $RPM_BUILD_ROOT

%post 
/sbin/ldconfig

%postun 
/sbin/ldconfig

%files
%defattr(-,root,root)
%{_bindir}/at-poke
%{_datadir}/at-poke/at-poke.glade2
%{_mandir}/man1/*


%changelog
* Thu Oct 28 2004 - [email protected]
- Add at-poke.1 manpage

* Wed Aug 18 2004 - [email protected]
- removed --disable-gtk-doc since this isn't an option this module's
  configure takes.

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Wed Feb 25 2004 - [email protected]
- Initial release version for at-poke