Solaris/SUNWgnome-games.spec
author dc144907
Thu, 16 Feb 2006 17:51:05 +0000
changeset 6781 6150399823ea
parent 6521 5b5d26c2c436
child 6795 2243eef12c58
permissions -rw-r--r--
2006-02-16 Damien Carbery <[email protected]> * SUNWevolution.spec, SUNWapleg.spec, SUNWevolution-data-server.spec, SUNWevolution-exchange.spec, SUNWevolution-webcal.spec, SUNWgnome-a11y-gok.spec, SUNWgnome-a11y-libs.spec, SUNWgnome-cd.spec, SUNWgnome-a11y-reader.spec, SUNWgnome-config-editor.spec, SUNWgnome-desktop-prefs.spec, SUNWgnome-utils.spec, SUNWgnome-libs.spec, SUNWgnome-display-mgr.spec, SUNWgnome-games.spec, SUNWgnome-im-client.spec, SUNWgnome-img-editor.spec, SUNWgnome-img-viewer.spec: Update Build/Requires after running check-deps.pl script.


# spec file for package SUNWgnome-games
#
# includes module(s): gnome-games
#
# Copyright (c) 2004 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%include Solaris.inc
%define _bindir /usr/sfw/bin
%define _libdir /usr/sfw/lib
%define _libexecdir /usr/sfw/lib
%define _includedir /usr/sfw/include

%define makeinstall make install DESTDIR=$RPM_BUILD_ROOT
%use gnome_games = gnome-games.spec

Name:                    SUNWgnome-games
Summary:                 GNOME Games
Version:                 %{default_pkg_version}
SUNW_BaseDir:            %{_basedir}
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
BuildRequires: SUNWlibrsvg-devel
BuildRequires: SUNWPython-devel
BuildRequires: SUNWgnome-libs-devel
BuildRequires: SUNWgnome-base-libs-devel
Requires: SUNWgnome-libs
Requires: SUNWgnome-base-libs
Requires: SUNWlibrsvg
Requires: SUNWPython

%package share
Summary:                 GNOME Games - platform independent files, /usr/share
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: SUNWperl584usr
Requires: SUNWpostrun

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%package root
Summary:                 GNOME Games - platform dependent files, / filesystem
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWgnome-libs

%package devel
Summary:                 GNOME Games - developer files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc

%prep
rm -rf %name-%version
mkdir %name-%version
%gnome_games.prep -d %name-%version

%build
export PKG_CONFIG_PATH=%{_pkg_config_path}
export MSGFMT="/usr/bin/msgfmt"
export ACLOCAL_FLAGS="-I %{_datadir}/aclocal"
export PERL5LIB=%{_prefix}/perl5/site_perl/5.6.1/sun4-solaris-64int
export CFLAGS="%optflags -I%{_includedir}"
export RPM_OPT_FLAGS="$CFLAGS"
export LDFLAGS="%_ldflags"

%gnome_games.build -d %name-%version

%install
%gnome_games.install -d %name-%version
export GCONF_CONFIG_SOURCE=xml::$RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults
for S in $RPM_BUILD_ROOT/%{_sysconfdir}/gconf/schemas/*.schemas; do
  /usr/bin/gconftool-2 --makefile-install-rule $S >/dev/null
done
chmod -R a+rX $RPM_BUILD_ROOT/%{_sysconfdir}

for f in apps/?gconf.xml \
         schemas/?gconf.xml \
         schemas/apps/?gconf.xml \
    ; do
  test ! -s $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults/$f && \
    rm -rf $RPM_BUILD_ROOT%{_sysconfdir}/gconf/gconf.xml.defaults/$f
done

rm -rf $RPM_BUILD_ROOT%{_localstatedir}/lib/games
rmdir $RPM_BUILD_ROOT%{_localstatedir}/lib
rmdir $RPM_BUILD_ROOT%{_localstatedir}

%if %build_l10n
%else
# REMOVE l10n FILES*files-list*
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/help/[a-z]*/[a-z]*
rm -rf $RPM_BUILD_ROOT%{_datadir}/omf/*/*-[a-z]*.omf
%endif

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):unsupported" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%post share
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $PKG_INSTALL_ROOT/usr/lib/postrun -b -u

%files
%defattr (-, root, other)
%dir %attr (0755, root, bin) /usr/sfw
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*

%files share
%defattr (-, root, other)
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/applications
%{_datadir}/gnect
%{_datadir}/gnibbles
%{_datadir}/gnobots2
%{_datadir}/gnome/help/*/C
%{_datadir}/gnome-games/ataxx
%{_datadir}/gnome-games/mahjongg
%{_datadir}/gnome-games/same-gnome
%{_datadir}/omf/*/*-C.omf
%{_datadir}/pixmaps
%{_datadir}/sounds

%if %build_l10n
%files l10n
%defattr (-, root, other)
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/locale
%{_datadir}/gnome/help/[a-z]*/[a-z]*
%{_datadir}/omf/*/*-[a-z]*.omf
%endif

%files root
%attr(0755, root, sys) %dir %{_sysconfdir}
%defattr (-, root, other)
%{_sysconfdir}/sound
%{_sysconfdir}/gconf
%defattr(0755, root, sys)

%files devel
%defattr (-, root, other)
%dir %attr (0755, root, bin) /usr/sfw
#%dir %attr (0755, root, bin) %{_includedir}
#%{_includedir}/gdkcardimage

%changelog
* Thu Feb 16 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.

* Fri Jan 06 2006 - [email protected]
- Fix %files for updated file list.

* Sat Dec  3 2005 - [email protected]
- add %post script that runs update-desktop-database
* Tue Nov 29 2005 - laca.com
- remove javahelp stuff
* Tue Sep 13 2005 - [email protected]
- Remove unpackaged files or add to %files
* Thu Jul 28 2005 - [email protected]
- Add SUNWlibrsvg-devel build dependency. Add SUNWlibrsvg runtime dependency.
* Tue May 24 2005 - [email protected]
- Bump to 2.10 and fix packaging.
* Mon Dec 13 2004 - [email protected]
- Move to /usr/sfw to implement ARC decision.
* Fri Nov 12 2004 - [email protected]
- move to /usr/demo/jds
* Tue Oct 05 2004 - [email protected]
- Added localized help to l10n package
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Mon Aug 23 2004 - [email protected]
- s/SUNWpl5u/SUNWperl584usr/
* Sat Jun 26 2004  [email protected]
- Changed install location to /usr/...
* Wed Jun  2 2004 - [email protected]
- Added %{_datadir}/locale to install l10n messages
* Thu May 27 2004 - [email protected]
- Comment out SUNWcspu lines. Will uncomment when Metropolis branch created.
* Wed May 26 2004 - [email protected]
- Add SUNWcspu (with libucb.so and scandir) to Requires and BuildRequires.
  configure was breaking because of its absense.
* Mon May 10 2004 - [email protected]
- Putting back %{_sysconfig}/gconf into packaging which got 
  accidently simplified away in Laca's last change.  Now the
  games work again.
* Tue Apr 20 2004 - [email protected]
- simlify %files
- add javahelp
* Thu Apr 08 2004 - [email protected]
- added missing %defattr
* Fri Mar 26 2004 - [email protected]
- Created,