SUNWgnome-archive-mgr.spec
author dkenny
Mon, 14 Jul 2008 14:46:05 +0000
branchgnome-2-22
changeset 12467 6830bb7a5bbd
parent 11958 9a5520e3cc7a
child 13505 fb02d1329af5
permissions -rw-r--r--
2008-07-14 Darren Kenny <[email protected]> * base-specs/evince.spec, patches/evince-03-static-enum.diff: Add patch to fix crash when using presentation mode (bug#6724495), and logged upstream bugzilla bug#542924.

#
# spec file for package SUNWgnome-archive-mgr
#
# includes module(s): file-roller
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: mattman
#
%include Solaris.inc

%use froller = file-roller.spec

Name:                    SUNWgnome-archive-mgr
Summary:                 GNOME archive manager
Version:                 %{default_pkg_version}
Source:                  %{name}-manpages-0.1.tar.gz
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWgnome-archive-mgr-root
Requires: SUNWgnome-file-mgr
Requires: SUNWgnome-libs
Requires: SUNWgnome-vfs
Requires: SUNWgnome-config
Requires: SUNWbzip
Requires: SUNWzlib
Requires: SUNWgnome-base-libs
Requires: SUNWlibms
Requires: SUNWlibpopt
Requires: SUNWpostrun
BuildRequires: SUNWgnome-base-libs-devel
BuildRequires: SUNWlibpopt-devel

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%package root
Summary:                 %{summary} - / filesystem
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWpostrun-root
Requires: SUNWgnome-config

%prep
rm -rf %name-%version
mkdir %name-%version
%froller.prep -d %name-%version
cd %{_builddir}/%name-%version
gzcat %SOURCE0 | tar xf -

%build
export CFLAGS="%optflags -I%{_includedir}/gnome-vfs-2.0 -I%{_libdir}/gnome-vfs-2.0/include"
export RPM_OPT_FLAGS="$CFLAGS"
export PKG_CONFIG_PATH=%{_pkg_config_path}
export LDFLAGS="%_ldflags -L%{_libdir} -lgnomevfs-2"

%froller.build -d %name-%version

%install
rm -rf $RPM_BUILD_ROOT
%froller.install -d %name-%version

rm -rf $RPM_BUILD_ROOT%{_mandir}
cd %{_builddir}/%name-%version/sun-manpages
make install DESTDIR=$RPM_BUILD_ROOT

%if %build_l10n
%else
# REMOVE l10n FILES
rm -r $RPM_BUILD_ROOT%{_datadir}/locale
rm -r $RPM_BUILD_ROOT%{_datadir}/gnome/help/*/[a-z]*
rm $RPM_BUILD_ROOT%{_datadir}/omf/*/*-[a-z][a-z].omf
%endif

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%post
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS_wait
( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
  echo '/usr/bin/scrollkeeper-update'
) | $BASEDIR/lib/postrun -b -u -c JDS

%postun
test -x $BASEDIR/lib/postrun || exit 0
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS
( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
  echo '/usr/bin/scrollkeeper-update'
) | $BASEDIR/lib/postrun -b -u -c JDS

%post root
%include gconf-install.script

%preun root
test -x $BASEDIR/var/lib/postrun/postrun || exit 0
( echo 'test -x $PKG_INSTALL_ROOT/usr/bin/gconftool-2 || {';
  echo '  echo "WARNING: gconftool-2 not found; not uninstalling gconf schemas"';
  echo '  exit 0';
  echo '}';
  echo 'umask 0022';
  echo 'GCONF_CONFIG_SOURCE=xml:merged:$BASEDIR/etc/gconf/gconf.xml.defaults';
  echo 'GCONF_BACKEND_DIR=$PKG_INSTALL_ROOT/usr/lib/GConf/2';
  echo 'LD_LIBRARY_PATH=$PKG_INSTALL_ROOT/usr/lib';
  echo 'export GCONF_CONFIG_SOURCE GCONF_BACKEND_DIR LD_LIBRARY_PATH';
  echo 'SDIR=$BASEDIR%{_sysconfdir}/gconf/schemas';
  echo 'schemas="$SDIR/file-roller.schemas"';
  echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $schemas'
) | $BASEDIR/var/lib/postrun/postrun -i -c JDS -a

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/file-roller
%{_libdir}/nautilus
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/applications
%{_datadir}/applications/*
%{_datadir}/file-roller
%dir %attr (0755, root, other) %{_datadir}/gnome
%{_datadir}/gnome/help/file-roller/C
%{_datadir}/omf/file-roller/*-C.omf
%attr (-, root, other) %{_datadir}/icons
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*
%{_mandir}/*/*

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%dir %attr (0755, root, other) %{_datadir}/gnome
%{_datadir}/gnome/help/*/[a-z]*
%{_datadir}/omf/*/*-[a-z][a-z].omf
%endif

%files root
%defattr (-, root, sys)
%attr (0755, root, sys) %dir %{_sysconfdir}
%{_sysconfdir}/gconf/schemas/file-roller.schemas

%changelog
* Thu Jan 10 2008 - [email protected]
- Add gnome-vfs info to CFLAGS and LDFLAGS as configure no longer retrieves
  them with pkg-config (libnautilus-extension depends on gio instead of
  gnome-vfs).
* Thu Jan  3 2008 - [email protected]
- use gconf-install.script instead of an inline script
* Tue Apr 24 2007 - [email protected]
- s/0755/-/ in defattr so that files are not made all executable
* Mon Mar 20 2007 - [email protected]
- Remove omf deletion line from %install, as suggested by reborg on
  desktop-discuss.
* Wed Jan 10 2007 - [email protected]
- Update l10n code for omf files as some locales have been removed.
* Fri Nov 24 2006 - [email protected]
- Update %files for 2.17.2 tarball.
* Fri Sep 01 2006 - [email protected]
- New Manpage tarball
* Mon Aug 21 2006 - [email protected]
- Fix l10n package - C locale omf file was in base and l10n package.
* Sat Aug 12 2006 - [email protected]
- delete some unnecessary env variables
* Sat Aug 12 2006 - [email protected]
- change datadir/icons permissions back to root:other since it's a stable
  interface and wasn't supposed to be changed
* Fri Jul 14 2006 - [email protected]
- update %post/%postun/etc scripts to support diskless client setup,
  part of 6448317
* Thu Jun 29 2006 - [email protected]
- update postrun scripts
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Thu Jun  1 2006 - [email protected]
- use post/preun scripts to install schemas into the merged gconf files
* Tue May 09 2006 - [email protected]
- merge -share pkg(s) into the base pkg(s)
* Tue Apr 18 2006 - [email protected]
- Icons have moved to %{_datadir}/icons, from pixmaps.
* Mon Feb 20 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Tue Jan 31 2006 - [email protected]
- Remove mime-info from %files. No files installed now.
* Sun Jan 22 2006 - [email protected]
- Remove application-registry from share package as no longer installed.
* Mon Jan 09 2006 - [email protected]
- Remove bonobo files from base package as they are no longer installed.
* Sat Dec  3 2005 - [email protected]
- add %post script that runs update-desktop-database
* Tue Nov 29 2005 - [email protected]
- remove javahelp stuff
* Fri Nov 12 2004 - [email protected]
- Revised files section
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Sat Jun 26 2004  [email protected]
- Changed install location to /usr/...
* Wed Jun  2 2004 - [email protected]
- Added %{_datadir}/locale to install l10n messages
* Wed Mar 24 2004 - [email protected]
- Added SGML man page integration
* Mon Mar 01 2004 - <[email protected]>
- define PERL5LIB
- fix share subpkg contents/permissions
* Wed Feb 25 2004 - <[email protected]>
- inital Solaris spec file created