SUNWgnome-crash-report.spec
author dkenny
Mon, 14 Jul 2008 14:46:05 +0000
branchgnome-2-22
changeset 12467 6830bb7a5bbd
parent 11958 9a5520e3cc7a
child 13542 f4cb52eb2c4d
permissions -rw-r--r--
2008-07-14 Darren Kenny <[email protected]> * base-specs/evince.spec, patches/evince-03-static-enum.diff: Add patch to fix crash when using presentation mode (bug#6724495), and logged upstream bugzilla bug#542924.

#
# spec file for package SUNWgnome-crash-report
#
# includes module(s): bug-buddy
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: mattman
#
%include Solaris.inc

%use bug_buddy= bug-buddy.spec

Name:                    SUNWgnome-crash-report
Summary:                 GNOME crash report generator
Version:                 %{default_pkg_version}
Source:                  %{name}-manpages-0.1.tar.gz
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build

%include default-depend.inc
Requires: SUNWgnome-vfs
Requires: SUNWgnome-component
Requires: SUNWgnome-libs
Requires: SUNWgnome-base-libs
Requires: SUNWgnome-panel
Requires: SUNWgnome-config
Requires: SUNWlxml
Requires: SUNWpostrun
Requires: SUNWlibgtop
BuildRequires: SUNWgnome-vfs-devel
BuildRequires: SUNWgnome-component-devel
BuildRequires: SUNWgnome-libs-devel
BuildRequires: SUNWgnome-base-libs-devel
BuildRequires: SUNWgnome-panel-devel
BuildRequires: SUNWgnome-config-devel
BuildRequires: SUNWlxml
BuildRequires: SUNWlibgtop-devel
#BuildRequires: SUNWgcc

%package root
Summary:                 %{summary} - / filesystem
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWpostrun-root
Requires: SUNWgnome-config

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%prep
rm -rf %name-%version
mkdir %name-%version
%bug_buddy.prep -d %name-%version
cd %{_builddir}/%name-%version
gzcat %SOURCE0 | tar xf -

%build
# Uncomment these 4 lines when building 2.19.0.
#export CC=/usr/sfw/bin/gcc
#export CXX=/usr/sfw/bin/g++
#export CFLAGS="%gcc_optflags -I%{_includedir} -I/usr/sfw/include/c++/3.4.3"
#export CXXFLAGS="%gcc_cxx_optflags -I%{_includedir} -I/usr/sfw/include/c++/3.4.3"

%if %cc_is_gcc
%else
export CXX="${CXX} -norunpath"
%endif
export CXXFLAGS="%cxx_optflags"

export CFLAGS="%optflags"
export RPM_OPT_FLAGS="$CFLAGS"
export LDFLAGS="%_ldflags"
%bug_buddy.build -d %name-%version

%install
rm -rf $RPM_BUILD_ROOT
%bug_buddy.install -d %name-%version
rm -rf $RPM_BUILD_ROOT%{_mandir}
cd %{_builddir}/%name-%version/sun-manpages
make install DESTDIR=$RPM_BUILD_ROOT

rm -r $RPM_BUILD_ROOT%{_datadir}/applications

%if %build_l10n
%else
# REMOVE l10n FILES
rm -r $RPM_BUILD_ROOT%{_datadir}/locale
%endif

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%post
( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
  echo '/usr/bin/scrollkeeper-update'
) | $BASEDIR/lib/postrun -b -u -c JDS

%postun
test -x $BASEDIR/lib/postrun || exit 0
( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
  echo '/usr/bin/scrollkeeper-update'
) | $BASEDIR/lib/postrun -b -u -c JDS

%post root
%include gconf-install.script

%preun root
test -x $BASEDIR/var/lib/postrun/postrun || exit 0
( echo 'test -x $PKG_INSTALL_ROOT/usr/bin/gconftool-2 || {';
  echo '  echo "WARNING: gconftool-2 not found; not uninstalling gconf schemas"';
  echo '  exit 0';
  echo '}';
  echo 'umask 0022';
  echo 'GCONF_CONFIG_SOURCE=xml:merged:$BASEDIR/etc/gconf/gconf.xml.defaults';
  echo 'GCONF_BACKEND_DIR=$PKG_INSTALL_ROOT/usr/lib/GConf/2';
  echo 'LD_LIBRARY_PATH=$PKG_INSTALL_ROOT/usr/lib';
  echo 'export GCONF_CONFIG_SOURCE GCONF_BACKEND_DIR LD_LIBRARY_PATH';
  echo 'SDIR=$BASEDIR%{_sysconfdir}/gconf/schemas';
  echo 'schemas="$SDIR/bug-buddy.schemas"';
  echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $schemas'
) | $BASEDIR/var/lib/postrun/postrun -i -c JDS -a

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/*
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/icons
%{_datadir}/bug-buddy
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*
%{_mandir}/*/*
%dir %attr(0755, root, bin) %{_libdir}
%dir %attr(0755, root, bin) %{_libdir}/*
%{_libdir}/*/*/*

%files root
%defattr (-, root, sys)
%attr (0755, root, sys) %dir %{_sysconfdir}
%{_sysconfdir}/gconf/schemas/bug-buddy.schemas

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%endif

%changelog
* Thu Jan  3 2008 - [email protected]
- use gconf-install.script instead of an inline script
* Thu Oct  4 2007 - [email protected]
- delete unneeded env vars
* Fri Sep 28 2007 - [email protected]
- Add -norunpath to CXX path so that Sun internal runpaths are not embedded in
  libgnomebreakpad.so.
* Tue Aug 28 2007 - [email protected]
- update files for 2.19.91 tarball
* Fri Aug 10 2007 - [email protected]
- Unbump to 2.18.1 so that it builds.
* Thu Aug 09 2007 - [email protected]
- Change to use gcc.
* Tue Apr 24 2007 - [email protected]
- s/0755/-/ in defattr so that files are not made all executable
* Fri Sep 08 2006 - [email protected]
- New Manpage tarball
* Tue Sep 05 2006 - [email protected]
- Update packaging for new tarball.
* Wed Aug 16 2006 - [email protected]
- Change 'icons' line in %files to pick up files.
* Sat Aug 12 2006 - [email protected]
- change datadir/icons permissions back to root:other since it's a stable
  interface and wasn't supposed to be changed
* Wed Jul 26 2006 - [email protected]
- Update packaging for new tarball (icons moved).
* Fri Jul 14 2006 - [email protected]
- update %post/%postun/etc scripts to support diskless client setup,
  part of 6448317
* Thu Jun 29 2006 - [email protected]
- update postrun scripts
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Thu May 25 2006 - [email protected]
- use post/preun scripts to install schemas into the merged gconf files
* Wed May 10 2006 - [email protected]
- merge -share pkg(s) into the base pkg(s)
* Sun Feb 19 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Tue Nov 29 2005 - [email protected]
- remove javahelp stuff
* Fri Oct 28 2005 - [email protected]
- Complete dependency listing.
* Wed Oct 26 2005 - [email protected]
- Resurrect bug-buddy, and get it to work with pstack