SUNWgnome-python-extras.spec
author dkenny
Mon, 14 Jul 2008 14:46:05 +0000
branchgnome-2-22
changeset 12467 6830bb7a5bbd
parent 12395 0f7caf8cc8b3
child 12799 04ceadac2747
permissions -rw-r--r--
2008-07-14 Darren Kenny <[email protected]> * base-specs/evince.spec, patches/evince-03-static-enum.diff: Add patch to fix crash when using presentation mode (bug#6724495), and logged upstream bugzilla bug#542924.

#
# spec file for package SUNWgnome-python-extras
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: dkenny
#

%include Solaris.inc
Name:                    SUNWgnome-python-extras
Summary:                 Supplemental Python bindings for GNOME
URL:                     http://ftp.gnome.org/pub/GNOME/sources/gnome-python-extras
Version:                 2.19.1
Source:                  http://ftp.gnome.org/pub/GNOME/sources/gnome-python-extras/2.19/gnome-python-extras-%{version}.tar.bz2
# date:2008-02-18 owner:dkenny type:feature
Patch1:                  gnome-python-extras-01-libgksu-missing-funcs.diff
# Build with Firefox3 when "--with-ff3" is specified 
%if %option_with_ff3
# date:2008-05-29 owner:evan type:bug bugzilla #532856
Patch2:                  gnome-python-extras-02-using-firefox3.diff
%endif
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build
Requires:                SUNWPython
Requires:                SUNWgnome-python-libs
Requires:                SUNWfirefox
Requires:                SUNWgksu
BuildRequires:           SUNWgnome-python-libs-devel
BuildRequires:           SUNWfirefox-devel
BuildRequires:           SUNWgksu-devel

%include default-depend.inc

%define pythonver 2.4

%prep
%setup -q -n gnome-python-extras-%version
%patch1 -p1
%if %option_with_ff3
%patch2 -p1
%endif

%build
autoconf
./configure --prefix=%{_prefix}
make

%install
rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT

# move to vendor-packages
mkdir -p $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages
mv $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages/* \
   $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/vendor-packages/
rmdir $RPM_BUILD_ROOT%{_libdir}/python%{pythonver}/site-packages

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%files
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/python%{pythonver}/vendor-packages/gtk-2.0/*
%dir %attr (0755, root, other) %{_libdir}/pkgconfig
%{_libdir}/pkgconfig/*
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/pygtk/*
%{_datadir}/gtk-doc/*

%changelog
* Fri May 30 2008 - [email protected]
- Add option "--with-ff3" to enable building with Firefox3
- Add patch gnome-python-extras-02-using-firefox3.diff
* Wed May 21 2008 - [email protected]
- Add Build/Requires: SUNWfirefox/-devel and SUNWgksu/-devel after
  check-deps.pl run.
* Wed Feb 20 2007 - Darren Kenny <[email protected]>
- Move from spec-files-other since it's GNOME related.
* Mon Feb 18 2007 - Darren Kenny <[email protected]>
- Import into svn.opensolaris.org/spec-files-other
* Tue Jul 10 2007 - Brian Cameron <[email protected]>
- Bump to 2.19.1
* Fri Feb 9 2007 - Irene Huang <[email protected]>
- created