SUNWgnome-utils.spec
author dkenny
Mon, 14 Jul 2008 14:46:05 +0000
branchgnome-2-22
changeset 12467 6830bb7a5bbd
parent 11958 9a5520e3cc7a
child 13302 c70285546daf
permissions -rw-r--r--
2008-07-14 Darren Kenny <[email protected]> * base-specs/evince.spec, patches/evince-03-static-enum.diff: Add patch to fix crash when using presentation mode (bug#6724495), and logged upstream bugzilla bug#542924.

#
# spec file for package SUNWgnome-dictionary, SUNWgnome-search-tool
#
# includes module(s): gnome-utils
#
# Copyright 2008 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
# Owner: mattman
#
%include Solaris.inc

%use gnome_utils = gnome-utils.spec

Name:                    SUNWgnome-utils
Summary:                 GNOME utilities: dictionary, search tool
Version:                 %{default_pkg_version}
Source:                  %{name}-manpages-0.1.tar.gz
SUNW_BaseDir:            %{_basedir}
SUNW_Copyright:          %{name}.copyright
BuildRoot:               %{_tmppath}/%{name}-%{version}-build
%include default-depend.inc
BuildRequires: SUNWgnome-panel-devel
BuildRequires: SUNWgnome-print-devel
BuildRequires: SUNWgnome-libs-devel
BuildRequires: SUNWgnome-config-devel
BuildRequires: SUNWgnome-base-libs-devel
BuildRequires: SUNWgnome-component-devel
BuildRequires: SUNWgnome-doc-utils
BuildRequires: SUNWlibgtop-devel
Requires: SUNWgnome-panel
Requires: SUNWgnome-libs
Requires: SUNWgnome-print
Requires: SUNWgnome-base-libs
Requires: SUNWgnome-config
Requires: SUNWgnome-component
Requires: SUNWlibgtop

%package -n SUNWgnome-search-tool
Summary:                 GNOME file search tool
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: SUNWgnome-search-tool-root
Requires: SUNWgnome-base-libs
Requires: SUNWgnome-config
Requires: SUNWgnome-libs
Requires: SUNWgnome-panel
Requires: SUNWgnome-vfs
Requires: SUNWpostrun
Requires: SUNWxcu4

%package -n SUNWgnome-search-tool-root
Summary:                 GNOME file search tool - / filesystem
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWgnome-config
Requires: SUNWpostrun-root

%package -n SUNWgnome-dictionary
Summary:                 GNOME dictionary tool
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: SUNWgnome-dictionary-root
Requires: SUNWgnome-libs
Requires: SUNWgnome-panel
Requires: SUNWgnome-print
Requires: SUNWgnome-base-libs
Requires: SUNWgnome-config
Requires: SUNWlibms
Requires: SUNWpostrun

%package -n SUNWgnome-dictionary-root
Summary:                 GNOME dictionary tool - / filesystem
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWpostrun-root
Requires: SUNWgnome-config

%package -n SUNWgnome-screenshot
Summary:                 GNOME screenshot tool
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: SUNWgnome-screenshot-root
Requires: SUNWgnome-config
Requires: SUNWgnome-base-libs
Requires: SUNWgnome-libs
Requires: SUNWgnome-vfs
Requires: SUNWlibms

%package -n SUNWgnome-screenshot-root
Summary:                 GNOME screenshot tool - / filesystem
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWpostrun-root
Requires: SUNWgnome-config

%package -n SUNWgnome-log-viewer
Summary:                 GNOME log viewer
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: SUNWgnome-log-viewer-root
Requires: SUNWgnome-base-libs
Requires: SUNWgnome-config
Requires: SUNWgnome-libs
Requires: SUNWgnome-panel
Requires: SUNWgnome-vfs
Requires: SUNWpostrun
Requires: SUNWlibms

%package -n SUNWgnome-log-viewer-devel
Summary:                 GNOME log viewer development files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: SUNWgnome-log-viewer-root
Requires: SUNWgnome-base-libs
Requires: SUNWgnome-config
Requires: SUNWgnome-libs
Requires: SUNWgnome-panel
Requires: SUNWgnome-vfs
Requires: SUNWpostrun
Requires: SUNWlibms

%package -n SUNWgnome-log-viewer-root
Summary:                 GNOME log viewer - / filesystem
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWpostrun-root
Requires: SUNWgnome-config

%package -n SUNWgnome-disk-analyzer
Summary:                 GNOME disk usage analyzer
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires: SUNWgnome-base-libs
Requires: SUNWgnome-config
Requires: SUNWgnome-libs
Requires: SUNWgnome-vfs
Requires: SUNWlibgtop

%package -n SUNWgnome-disk-analyzer-root
Summary:                 GNOME disk usage analyzer - / filesystem
SUNW_BaseDir:            /
%include default-depend.inc
Requires: SUNWpostrun-root

%if %build_l10n
%package l10n
Summary:                 %{summary} - l10n files
SUNW_BaseDir:            %{_basedir}
%include default-depend.inc
Requires:                %{name}
%endif

%prep
rm -rf %name-%version
mkdir %name-%version
%gnome_utils.prep -d %name-%version
cd %{_builddir}/%name-%version
gzcat %SOURCE0 | tar xf -
cd %{_builddir}/%name-%version/gnome-utils-%{gnome_utils.version}

%build
export PKG_CONFIG_PATH=%{_pkg_config_path}
export CFLAGS="%optflags -I%{_includedir}"
export RPM_OPT_FLAGS="$CFLAGS"
export LDFLAGS="%_ldflags"
%gnome_utils.build -d %name-%version

%install
rm -rf $RPM_BUILD_ROOT
%gnome_utils.install -d %name-%version
rm -f $RPM_BUILD_ROOT%{_mandir}/*/*.gz
cd %{_builddir}/%name-%version/sun-manpages
make install DESTDIR=$RPM_BUILD_ROOT
install --mode=0644 %{_builddir}/%name-%version/gnome-utils-%{gnome_utils.version}/logview/gnome-system-log.1 \
	 $RPM_BUILD_ROOT%{_mandir}/man1
install --mode=0644 %{_builddir}/%name-%version/gnome-utils-%{gnome_utils.version}/logview/pipelog.conf.4 \
	 $RPM_BUILD_ROOT%{_mandir}/man4
install --mode=0644 %{_builddir}/%name-%version/gnome-utils-%{gnome_utils.version}/logview/grablogs.conf.4 \
	 $RPM_BUILD_ROOT%{_mandir}/man4

rm $RPM_BUILD_ROOT%{_libdir}/gnome-system-log/plugins/*.la

# Remove gnome-dictionary menu entry, developer files and documentation.
echo "NoDisplay=true" >> $RPM_BUILD_ROOT%{_datadir}/applications/gnome-dictionary.desktop
rm -r $RPM_BUILD_ROOT%{_datadir}/gnome-system-log
rm -r $RPM_BUILD_ROOT%{_datadir}/gtk-doc
rm -r $RPM_BUILD_ROOT%{_includedir}/gdict*
rm -r $RPM_BUILD_ROOT%{_libdir}/pkgconfig

# Never install English locales because should support full functions
# on English locales as same as Solaris.
rm -r $RPM_BUILD_ROOT%{_datadir}/gnome/help/baobab/en_GB
rm -r $RPM_BUILD_ROOT%{_datadir}/locale/en_GB
rm $RPM_BUILD_ROOT%{_datadir}/omf/baobab/baobab-en_GB.omf
rm $RPM_BUILD_ROOT%{_datadir}/omf/gnome-system-log/gnome-system-log-en_GB.omf
rm $RPM_BUILD_ROOT%{_datadir}/omf/gnome-dictionary/gnome-dictionary-en_GB.omf
rm $RPM_BUILD_ROOT%{_datadir}/omf/gnome-search-tool/gnome-search-tool-en_GB.omf

%if %build_l10n
%else
# REMOVE l10n FILES
rm -rf $RPM_BUILD_ROOT%{_datadir}/locale
rm -rf $RPM_BUILD_ROOT%{_datadir}/gnome/help/[a-z]*/[a-z]*
rm -f $RPM_BUILD_ROOT%{_datadir}/omf/*/*-[a-z][a-z].omf
rm -f $RPM_BUILD_ROOT%{_datadir}/omf/*/*-??_??.omf
%endif

%{?pkgbuild_postprocess: %pkgbuild_postprocess -v -c "%{version}:%{jds_version}:%{name}:$RPM_ARCH:%(date +%%Y-%%m-%%d):%{support_level}" $RPM_BUILD_ROOT}

%clean
rm -rf $RPM_BUILD_ROOT

%post -n SUNWgnome-disk-analyzer
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS_wait
( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
  echo '/usr/bin/scrollkeeper-update'
) | $BASEDIR/lib/postrun -b -u -c JDS

%post -n SUNWgnome-log-viewer
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS_wait
( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
  echo '/usr/bin/scrollkeeper-update'
) | $BASEDIR/lib/postrun -b -u -c JDS

%postun -n SUNWgnome-log-viewer
test -x $BASEDIR/lib/postrun || exit 0
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS
( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
  echo '/usr/bin/scrollkeeper-update'
) | $BASEDIR/lib/postrun -b -u -c JDS

%post -n SUNWgnome-search-tool
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS_wait
( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
  echo '/usr/bin/scrollkeeper-update'
) | $BASEDIR/lib/postrun -b -u -c JDS

%postun -n SUNWgnome-search-tool
test -x $BASEDIR/lib/postrun || exit 0
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS
( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
  echo '/usr/bin/scrollkeeper-update'
) | $BASEDIR/lib/postrun -b -u -c JDS

%post -n SUNWgnome-dictionary
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS_wait
( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
  echo '/usr/bin/scrollkeeper-update'
) | $BASEDIR/lib/postrun -b -u -c JDS

%postun -n SUNWgnome-dictionary
test -x $BASEDIR/lib/postrun || exit 0
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS
( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
  echo '/usr/bin/scrollkeeper-update'
) | $BASEDIR/lib/postrun -b -u -c JDS

%post -n SUNWgnome-screenshot
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS_wait
( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
  echo '/usr/bin/scrollkeeper-update'
) | $BASEDIR/lib/postrun -b -u -c JDS

%postun -n SUNWgnome-screenshot
test -x $BASEDIR/lib/postrun || exit 0
( echo 'test -x /usr/bin/update-desktop-database || exit 0';
  echo '/usr/bin/update-desktop-database'
) | $BASEDIR/lib/postrun -b -u -c JDS
( echo 'test -x /usr/bin/scrollkeeper-update || exit 0';
  echo '/usr/bin/scrollkeeper-update'
) | $BASEDIR/lib/postrun -b -u -c JDS

%post -n SUNWgnome-disk-analyzer-root
%include gconf-install.script

%preun -n SUNWgnome-disk-analyzer-root
test -x $BASEDIR/var/lib/postrun/postrun || exit 0
( echo 'test -x $PKG_INSTALL_ROOT/usr/bin/gconftool-2 || {';
  echo '  echo "WARNING: gconftool-2 not found; not uninstalling gconf schemas"';
  echo '  exit 0';
  echo '}';
  echo 'umask 0022';
  echo 'GCONF_CONFIG_SOURCE=xml:merged:$BASEDIR/etc/gconf/gconf.xml.defaults';
  echo 'GCONF_BACKEND_DIR=$PKG_INSTALL_ROOT/usr/lib/GConf/2';
  echo 'LD_LIBRARY_PATH=$PKG_INSTALL_ROOT/usr/lib';
  echo 'export GCONF_CONFIG_SOURCE GCONF_BACKEND_DIR LD_LIBRARY_PATH';
  echo 'SDIR=$BASEDIR%{_sysconfdir}/gconf/schemas';
  echo 'schemas="$SDIR/baobab.schemas"';
  echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $schemas'
) | $BASEDIR/var/lib/postrun/postrun -i -c JDS -a

%post -n SUNWgnome-log-viewer-root
%include gconf-install.script

%preun -n SUNWgnome-log-viewer-root
test -x $BASEDIR/var/lib/postrun/postrun || exit 0
( echo 'test -x $PKG_INSTALL_ROOT/usr/bin/gconftool-2 || {';
  echo '  echo "WARNING: gconftool-2 not found; not uninstalling gconf schemas"';
  echo '  exit 0';
  echo '}';
  echo 'umask 0022';
  echo 'GCONF_CONFIG_SOURCE=xml:merged:$BASEDIR/etc/gconf/gconf.xml.defaults';
  echo 'GCONF_BACKEND_DIR=$PKG_INSTALL_ROOT/usr/lib/GConf/2';
  echo 'LD_LIBRARY_PATH=$PKG_INSTALL_ROOT/usr/lib';
  echo 'export GCONF_CONFIG_SOURCE GCONF_BACKEND_DIR LD_LIBRARY_PATH';
  echo 'SDIR=$BASEDIR%{_sysconfdir}/gconf/schemas';
  echo 'schemas="$SDIR/logview.schemas"';
  echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $schemas'
) | $BASEDIR/var/lib/postrun/postrun -i -c JDS -a

%post -n SUNWgnome-search-tool-root
%include gconf-install.script

%preun -n SUNWgnome-search-tool-root
test -x $BASEDIR/var/lib/postrun/postrun || exit 0
( echo 'test -x $PKG_INSTALL_ROOT/usr/bin/gconftool-2 || {';
  echo '  echo "WARNING: gconftool-2 not found; not uninstalling gconf schemas"';
  echo '  exit 0';
  echo '}';
  echo 'umask 0022';
  echo 'GCONF_CONFIG_SOURCE=xml:merged:$BASEDIR/etc/gconf/gconf.xml.defaults';
  echo 'GCONF_BACKEND_DIR=$PKG_INSTALL_ROOT/usr/lib/GConf/2';
  echo 'LD_LIBRARY_PATH=$PKG_INSTALL_ROOT/usr/lib';
  echo 'export GCONF_CONFIG_SOURCE GCONF_BACKEND_DIR LD_LIBRARY_PATH';
  echo 'SDIR=$BASEDIR%{_sysconfdir}/gconf/schemas';
  echo 'schemas="$SDIR/gnome-search-tool.schemas"';
  echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $schemas'
) | $BASEDIR/var/lib/postrun/postrun -i -c JDS -a

%post -n SUNWgnome-dictionary-root
%include gconf-install.script

%preun -n SUNWgnome-dictionary-root
test -x $BASEDIR/var/lib/postrun/postrun || exit 0
( echo 'test -x $PKG_INSTALL_ROOT/usr/bin/gconftool-2 || {';
  echo '  echo "WARNING: gconftool-2 not found; not uninstalling gconf schemas"';
  echo '  exit 0';
  echo '}';
  echo 'umask 0022';
  echo 'GCONF_CONFIG_SOURCE=xml:merged:$BASEDIR/etc/gconf/gconf.xml.defaults';
  echo 'GCONF_BACKEND_DIR=$PKG_INSTALL_ROOT/usr/lib/GConf/2';
  echo 'LD_LIBRARY_PATH=$PKG_INSTALL_ROOT/usr/lib';
  echo 'export GCONF_CONFIG_SOURCE GCONF_BACKEND_DIR LD_LIBRARY_PATH';
  echo 'SDIR=$BASEDIR%{_sysconfdir}/gconf/schemas';
  echo 'schemas="$SDIR/gnome-dictionary.schemas"';
  echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $schemas'
) | $BASEDIR/var/lib/postrun/postrun -i -c JDS -a

%post -n SUNWgnome-screenshot-root
%include gconf-install.script

%preun -n SUNWgnome-screenshot-root
test -x $BASEDIR/var/lib/postrun/postrun || exit 0
( echo 'test -x $PKG_INSTALL_ROOT/usr/bin/gconftool-2 || {';
  echo '  echo "WARNING: gconftool-2 not found; not uninstalling gconf schemas"';
  echo '  exit 0';
  echo '}';
  echo 'umask 0022';
  echo 'GCONF_CONFIG_SOURCE=xml:merged:$BASEDIR/etc/gconf/gconf.xml.defaults';
  echo 'GCONF_BACKEND_DIR=$PKG_INSTALL_ROOT/usr/lib/GConf/2';
  echo 'LD_LIBRARY_PATH=$PKG_INSTALL_ROOT/usr/lib';
  echo 'export GCONF_CONFIG_SOURCE GCONF_BACKEND_DIR LD_LIBRARY_PATH';
  echo 'SDIR=$BASEDIR%{_sysconfdir}/gconf/schemas';
  echo 'schemas="$SDIR/gnome-screenshot.schemas"';
  echo '$PKG_INSTALL_ROOT/usr/bin/gconftool-2 --makefile-uninstall-rule $schemas'
) | $BASEDIR/var/lib/postrun/postrun -i -c JDS -a


%files -n SUNWgnome-log-viewer
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/gnome-system-log
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/gnome
%{_datadir}/gnome/help/gnome-system-log/C
%{_datadir}/omf/gnome-system-log/gnome-system-log-C.omf
%dir %attr (0755, root, other) %{_datadir}/applications
%{_datadir}/applications/gnome-system-log.desktop
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*
%{_mandir}/*/*system-log*
%{_mandir}/*/*.conf.4
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/gnome-system-log/*

%files -n SUNWgnome-log-viewer-devel
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %dir %{_includedir}
%{_includedir}/*

%files -n SUNWgnome-log-viewer-root
%defattr (-, root, sys)
%dir %attr (0755, root, sys) %{_sysconfdir}
%{_sysconfdir}/gconf/schemas/logview.schemas

%files -n SUNWgnome-search-tool
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/gnome-search-tool
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/gnome
%{_datadir}/gnome/help/gnome-search-tool/C
%{_datadir}/omf/gnome-search-tool/gnome-search-tool-C.omf
%dir %attr (0755, root, other) %{_datadir}/applications
%{_datadir}/applications/gnome-search-tool.desktop
%dir %attr (0755, root, other) %{_datadir}/pixmaps
%{_datadir}/pixmaps/gsearchtool
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*
%{_mandir}/*/*search*

%files -n SUNWgnome-search-tool-root
%defattr (-, root, sys)
%dir %attr (0755, root, sys) %{_sysconfdir}
%{_sysconfdir}/gconf/schemas/gnome-search-tool.schemas

%files -n SUNWgnome-dictionary
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/gnome-dictionary
%dir %attr (0755, root, bin) %{_libdir}
%{_libdir}/libgdict*
%{_libdir}/bonobo/servers/GNOME_DictionaryApplet.server
%{_libexecdir}/gnome-dictionary-applet
%dir %attr (0755, root, sys) %{_datadir}
%dir %attr (0755, root, other) %{_datadir}/applications
%{_datadir}/applications/gnome-dictionary.desktop
%dir %attr (0755, root, other) %{_datadir}/gnome
%{_datadir}/gnome/help/gnome-dictionary/C
%{_datadir}/omf/gnome-dictionary/gnome-dictionary-C.omf
%{_datadir}/gnome-2.0/ui/GNOME_DictionaryApplet.xml
%dir %attr (-, root, other) %{_datadir}/icons
%dir %attr (-, root, other) %{_datadir}/icons/hicolor
%{_datadir}/gdict-1.0/*
%{_datadir}/gnome-dictionary/*
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*
%{_mandir}/*/*dict*

%files -n SUNWgnome-dictionary-root
%defattr (-, root, sys)
%dir %attr (0755, root, sys) %{_sysconfdir}
%{_sysconfdir}/gconf/schemas/gnome-dictionary.schemas

%files -n SUNWgnome-screenshot
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/gnome*screenshot
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/gnome-screenshot
%dir %attr (0755, root, other) %{_datadir}/applications
%{_datadir}/applications/gnome-screenshot.desktop
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*
%{_mandir}/*/*screenshot*

%files -n SUNWgnome-screenshot-root
%defattr (-, root, sys)
%attr (0755, root, sys) %dir %{_sysconfdir}
%{_sysconfdir}/gconf/schemas/gnome-screenshot.schemas

%files -n SUNWgnome-disk-analyzer
%defattr (-, root, bin)
%dir %attr (0755, root, bin) %{_bindir}
%{_bindir}/baobab
%dir %attr (0755, root, sys) %{_datadir}
%{_datadir}/baobab
%dir %attr (0755, root, other) %{_datadir}/applications
%{_datadir}/applications/baobab.desktop
%dir %attr (0755, root, other) %{_datadir}/gnome
%{_datadir}/gnome/help/baobab/C
%{_datadir}/omf/baobab/baobab-C.omf
%dir %attr (-, root, other) %{_datadir}/icons
%dir %attr (-, root, other) %{_datadir}/icons/hicolor
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/24x24
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/24x24/apps
%{_datadir}/icons/hicolor/24x24/apps/baobab.png
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/scalable
%dir %attr (-, root, other) %{_datadir}/icons/hicolor/scalable/apps
%{_datadir}/icons/hicolor/scalable/apps/baobab.svg
%dir %attr(0755, root, bin) %{_mandir}
%dir %attr(0755, root, bin) %{_mandir}/*
%{_mandir}/*/*baobab*

%files -n SUNWgnome-disk-analyzer-root
%defattr (-, root, sys)
%attr (0755, root, sys) %dir %{_sysconfdir}
%{_sysconfdir}/gconf/schemas/baobab.schemas

%if %build_l10n
%files l10n
%defattr (-, root, bin)
%dir %attr (0755, root, sys) %{_datadir}
%attr (-, root, other) %{_datadir}/locale
%dir %attr (0755, root, other) %{_datadir}/gnome
%{_datadir}/gnome/help/[a-z]*/[a-z]*
%{_datadir}/omf/*/*-[a-z][a-z].omf
##%{_datadir}/omf/*/*-[a-z][a-z]_[A-Z][A-Z].omf
%endif

%changelog
* Thu Jan  3 2008 - [email protected]
- use gconf-install.script instead of an inline script
* Wed Oct 10 2007 - [email protected]
- Remove 'Requires: SUNWgnome-doc-utils' as it is only used during building;
  change SUNWgnome-doc-utils-devel to SUNWgnome-doc-utils to match change in
  SUNWgnome-doc-utils.spec.
* Fri Sep 28 2007 - [email protected]
- delete Nevada X deps
- delete some unneeded env vars
* Fri Sep 07 2007 - [email protected]
- Remove icons. See bugzilla #470287.
* Thu Aug 16 2007 - [email protected]
- Delete more en_GB files in %install.
* Wed Apr 04 2007 - [email protected]
- Set NoDisplay=true for dictionary item.
* Wed Feb 14 2006 - [email protected]
- Delete en_GB files in %install.
* Wed Feb 14 2007 - [email protected]
- Add to %files l10n to include baobab-en_GB.omf.
* Thu Jan 25 2007 - [email protected]
- Delete *.la in %install. Add SUNWgnome-doc-utils/-devel dependencies so that
  the log viewer is built. Remove the code that deleted %{_localstatedir}
  because it isn't installed.
- Undo removal of SUNWgnome-log-viewer-devel. Will try to find out what pkg
  that SUNWgnome-utils should be added to the dependencies.
* Wed Jan 24 2007 - [email protected]
- Remove SUNWgnome-log-viewer-devel package as no files are installed for it.
  Remove other files that are no longer installed. Remove -f from rm calls.
* Fri Nov 24 2006 - [email protected]
- Update %files (baobab icons) for 2.17.0 tarball.
* Wed Nov 15 2006 - [email protected]
- Remove unneeded chmod call. It changed help xml files to 0755 for no obvious 
  reason.
* Mon Nov 13 2006 - [email protected]
- Added logview plugin
* Fri Sep 08 2006 - [email protected]
- Remove "rm" of _mandir during %install
* Wed Sep 06 2006 - [email protected]
- Turn to NROFF gnome-system-log manpage
* Mon Sep 04 2006 - [email protected]
- New Manpage tarball
* Tue Aug 29 2006 - [email protected]
- Add post/un rules for SUNWgnome-disk-analyzer
* Fri Aug 25 2006 - [email protected]
- Add gnome-panel-screenshot.1 shadown manpage pointing to gnome-screenshot.1
* Wed Aug 16 2006 - [email protected]
- Change 'icons' line in %files to pick up files.
* Sat Aug 12 2006 - [email protected]
- change datadir/icons permissions back to root:other since it's a stable
  interface and wasn't supposed to be changed
* Tue Aug 08 2006 - [email protected]
- Add Requires list for SUNWgnome-disk-analyzer after check-deps.pl run.
* Sat Jul 29 2006 - [email protected]
- Add Build/Requires SUNWlibgtop/-devel.
* Fri Jul 14 2006 - [email protected]
- update %post/%postun/etc scripts to support diskless client setup,
  part of 6448317
* Thu Jun 29 2006 - [email protected]
- update postrun scripts
* Thu Jun 29 2006 - [email protected]
- update %post/%preun gconf scripts
* Sun Jun 11 2006 - [email protected]
- change group from other to bin/sys
* Thu May 25 2006 - [email protected]
- use post/preun scripts to install schemas into the merged gconf files
* Fri May 12 2006 - [email protected]
- Small update to dependency list after check-deps.pl run.
* Wed May 10 2006 - [email protected]
- merge all remaining -share pkg(s) into the base pkg(s)
* Thu May 04 2006 - [email protected]
- merge SUNWgnome-screenshot-share into the base SUNWgnome-screenshot
* Fri Apr 21 2006 - [email protected]
- Add gnome-dictionary and gdict-1.0 to dictionary-share package since these
  are needed.
* Thu Apr 20 2006 - [email protected]
- Remove gnome-utils-01-disable-logview-dictionary.diff
- Add gnome-utils-01-logview.diff. Enable build logview
* Wed Mar 15 2006 - [email protected]
- Add Build/Requires SUNWgnome-component/-devel for ORBit2.
* Tue Mar 14 2006 - [email protected]
- Remove code that deleted gnome-dictionary .a and .la files. No longer present.
* Mon Feb 20 2006 - [email protected]
- Complete update of Build/Requires after running check-deps.pl script.
* Fri Feb 17 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Thu Feb 16 2006 - [email protected]
- Update Build/Requires after running check-deps.pl script.
* Sun Jan 22 2006 - [email protected]
- Add gnome-screenshot.desktop, from new tarball.
* Wed Jan 18 2006 - [email protected]
- More %files updates for 2.13.4 tarball (gnome-dictionary related).
* Fri Jan 06 2006 - [email protected]
- Update %files for new tarball, incl adding gnome-dictionary files.
* Sat Dec  3 2005 - [email protected]
- add %post script that runs update-desktop-database
* Tue Nov 29 2005 - [email protected]
- remove javahelp stuff
* Fri Oct 14 2005 - [email protected]
- Remove javahelp references. Obsolete.
* Wed Sep 14 2005 - [email protected]
- define SUNWgnome-screenshot*
- install gconf schemas and add files to -root packages
* Wed Aug 30 2005 - [email protected]
- Add Build/Requires SUNWgnome-print(-devel) as required by gnome-utils.
* Fri Jul 01 2005 - [email protected]
- remove the gucharmap parts that Brian moved to SUNWgnome-character-map.spec
* Sat Oct 02 2004 - [email protected]
- added %pkgbuild_postprocess
* Wed Aug 25 2004 - [email protected]
- Updated files section to extract l10n help contents into l10n pkg
* Wed Aug 18 2004 - [email protected]
- Change manpage perms for Solaris integration.
* Wed Aug 18 2004 - [email protected]
- javahelp also should get installed for gucharmap.
* Tue Jun 22 2004 - [email protected]
- changed install location to /usr/lib and /usr/bin
* Mon Jun 14 2004 - [email protected]
- Enable back gucharmap into the build.
* Wed Jun  2 2004 - [email protected]
- added "BuildRequires: SUNWgnome-panel-devel" to SUNWgnome-character-map so
  gnome-desktop-2.0 can be found during configure
* Wed Jun  2 2004 - [email protected]
- Added %{_datadir}/locale to install l10n messages
* Mon May 03 2004 - [email protected]
- renamed to SUNWgnome-utils.spec, even though none of the packages is
  called SUNWgnome-utils (;
- added SUNWgnome-search-tool* and SUNWgnome-dictionary* package definitions
  and %files.
* Mon Mar 29 2004 - [email protected]
- Corrected packaging so man is installed as root/bin.  This
  corrects install failure.
* Wed Mar 24 2004 - [email protected]
- Added SGML man page integration
* Fri Mar 05 2004 - [email protected]
- Add SUNWgnome-character-map package.