gnome-speech.spec
author dcarbery
Mon, 06 Nov 2006 17:15:48 +0000
changeset 8513 6d4bff5f397c
parent 8018 a406b0ef7b16
child 8564 df62c23d2955
permissions -rw-r--r--
2006-11-06 Damien Carbery <[email protected]> * gnome-python.spec: Bump to 2.16.2. * gnome-speech.spec: Bump to 0.4.6. * gnome-utils.spec: Bump to 2.16.2. Remove upstream patch, 05-dictionary-multihead. * patches/gnome-utils-05-dictionary-multihead.diff: Removed, upstream.

#
# spec file for package gnome-speech
#
# Copyright (c) 2005 Sun Microsystems, Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#
Name:         gnome-speech
License:      LGPL
Group:        System/Libraries
Version:      0.4.6
Release:      201
Distribution: Java Desktop System
Vendor:       Sun Microsystems, Inc.
Summary:      GNOME text-to-speech engine
Source:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/0.4/%{name}-%{version}.tar.bz2
URL:          http://developer.gnome.org/projects/gap/
BuildRoot:    %{_tmppath}/%{name}-%{version}-build
Docdir:       %{_defaultdocdir}/%{name}
Autoreqprov:  on
Prereq:	      /sbin/ldconfig

%define libbonobo_version 2.4.0
%define java_access_bridge_version 1.4.6
%define freetts_version 1.2.1

BuildRequires: jdk
BuildRequires: libbonobo-devel >= %{libbonobo_version}
BuildRequires: java-access-bridge >= %{java_access_bridge_version}
BuildRequires: freetts >= %{freetts_version}
Requires:      jdk
Requires:      libbonobo >= %{libbonobo_version}
Requires:      freetts >= %{freetts_version}

%description
gnome-speech module is the GNOME text-to-speech engine.

%package devel
Summary:      GNOME text-to-speech engine
Group:        Development/System/Libraries
Autoreqprov:  on
Requires:     %name = %version
Requires:     libbonobo-devel >= %{libbonobo_version}

%description devel
gnome-speech module is the GNOME text-to-speech engine.

%prep
%setup -q


%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l | tr -d ' '`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

%ifos solaris
CFLAGS="-I/usr/jdk/jdk1.5.0/include -I/usr/jdk/jdk1.5.0/include/solaris $RPM_OPT_FLAGS"			\
%else
%define jdk_version 1.5.0_03
export PATH="/usr/java/jdk%{jdk_version}/bin:$PATH"
CFLAGS="-I/usr/java/jdk%{jdk_version}/include -I/usr/java/jdk%{jdk_version}include/linux $RPM_OPT_FLAGS"			\
%endif
./configure --prefix=%{_prefix}			\
            --sysconfdir=%{_sysconfdir}		\
            --mandir=%{_mandir}			\
            --with-freetts-dir=%{_datadir}/lib/freetts
make -j $CPUS

%install
make DESTDIR=$RPM_BUILD_ROOT install
#Clean up unpackaged files
rm $RPM_BUILD_ROOT%{_libdir}/*.la
rm $RPM_BUILD_ROOT%{_libdir}/orbit-2.0/*.la
rm -f $RPM_BUILD_ROOT%{_bindir}/theta-synthesis-driver
rm -f $RPM_BUILD_ROOT%{_libdir}/bonobo/servers/GNOME_Speech_SynthesisDriver_Theta.server

%clean
rm -rf $RPM_BUILD_ROOT

%post
/sbin/ldconfig

%postun
/sbin/ldconfig

%files
%defattr(-,root,root)
%{_bindir}/festival-synthesis-driver
%{_bindir}/freetts-synthesis-driver
%{_bindir}/test-speech
%{_libdir}/bonobo/servers/*
%{_libdir}/orbit-2.0/*.so
%{_libdir}/*.so*
%{_datadir}/jar/*.jar
%{_datadir}/gnome-speech
%{_datadir}/idl/gnome-speech-1.0/*

%files devel
%defattr(-,root,root)
%{_includedir}/gnome-speech-1.0/*
%{_libdir}/pkgconfig/*.pc

%changelog
* Mon Nov 06 2006 - [email protected]
- Bump to 0.4.6.

* Tue Aug 29 2006 - [email protected]
- Bump to 0.4.5.

* Tue Aug 22 2006 - [email protected]
- Bump to 0.4.4.

* Mon Aug 07 2006 - [email protected]
- Update to 0.4.3

* Mon Jul 24 2006 - [email protected]
- Update to 0.4.2

* Wed Jul 12 2006 - [email protected]
- Update to 0.4.1

* Wed Jun 14 2006 - [email protected]
- Add patch for festival core dump (see bugzilla bug 341405)

* Thu Feb 23 2006 - [email protected]
- Bump to 0.3.10

* Mon Nov 14 2005 - [email protected]
- Bump to 0.3.9

* Tue Oct 11 2005 - [email protected]
- Bump to 0.3.8

* Tue Aug 23 2005 - [email protected]
- Add variable to make updating JDK version easier.

* Tue May 10 2005 - [email protected]
- Upgrade to gnome-speech 0.3.7; completes fix for bug #6216633.
- Remove unnecessary patch 1 which is now in the tarball.
- Remove Theta drivers if they happen to have been built.

* Mon May 09 2005 - [email protected]
- New jdk (1.5.0_03)

* Mon Feb 28 2005 - [email protected]
- Upgrade to FreeTTS 1.2.1, fix for bug #6228329.

* Fri Oct 08 2004 - [email protected]
- Added patch gnome-speech-01-freetts-perf.diff, part of fix for bug
  #5087408.

* Mon Sep 20 2004 - [email protected]
- new path for JDK 1.5.0

* Mon Aug 30 2004 - [email protected]
- Removed patch (it's in CVS now), and bumped to 0.3.5.

* Wed Aug 18 2004 - [email protected]
- removed --disable-gtk-doc since this isn't an option this module's
  configure takes.

* Thu Jul 22 2004 - [email protected]
- Add patch to fix CLASSPATH in freetts-synthesis-driver script.
  (Please remove patch when upgrading to gnome-speech-0.3.4)

* Thu Jul 22 2004 - [email protected]
- Remove source1 tarball. Incorrectly overwrites source with old files.

* Mon Jul 12 2004 - [email protected]
- ported to rpm4

* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Thu Jun 10 2004 - [email protected]
- Upgrade to version 0.3.3, depend on FreeTTS 1.2 beta.

* Tue Jun 01 2004 - [email protected]
- Correct JDK path in CFLAGS for Solaris.

* Sun May 30 2004 - dermot.mccluskey
- new JDK

* Mon May 03 2004 - [email protected]
- moved Java to 1.5.0

* Thu Apr 15 2004 - [email protected]
- Move bin and jar files from devel to root rpm.

* Mon Mar 15 2004 - [email protected]
- Add JDK path to CFLAGS and PATH for Linux.

* Thu Mar 11 2004 - [email protected]
- Bump ver to 1.3.2. Reset release. Add --with-freetts-dir configure switch.
- Add files created for freetts support.

* Tue Mar 02 2004 - [email protected]
- Correct line for .so files - was omitting libgnomespeech.so.

* Tue Feb 24 2004 - [email protected]
- Created new spec file for gnome-speech