libsoup.spec
author dc144907
Mon, 12 Jul 2004 06:40:06 +0000
changeset 3315 724897b9c964
parent 3263 3c14210c0b99
child 3320 1b6af4da604e
permissions -rw-r--r--
Increment tarball number to 14, for build 14.

#
# License (c) 2003 Sun Microsystems Inc.
# This file and all modifications and additions to the pristine
# package are under the same license as the package itself.
#

%define t_suffix -build14-cb
%{?nightly:%define t_suffix -%(TZ=GMT date +%Y%m%d)}

Name:     	libsoup
Version: 	1.99.23
Release:	335
Vendor:		Sun Microsystems, Inc.
Distribution:	Java Desktop System, Release 3
Copyright:	LGPL/GPL
BuildRoot:	%{_tmppath}/%{name}-%{version}-root
Docdir:         %{_datadir}/doc
Autoreqprov:    on
URL:		http://www.sun.com/software/javadesktopsystem/
Source:		%{name}-%{version}%{t_suffix}.tar.bz2
#Patch0:         libsoup.patch

%define libxml2_devel_version 2.4.23
%define glib2_version 2.0

BuildRequires:	glibc-devel
BuildRequires:	libtool
BuildRequires:	glib2-devel
BuildRequires:	libxml2-devel >= %{libxml2_devel_version}
BuildRequires:	popt
BuildRequires:	zlib-devel
BuildRequires:	gnutls-devel	
Summary:	Simple Object Access Protocol implementation
Group:		System Environment/Libraries
Requires:	glib2 >= %{glib2_version}
Requires:	popt
Requires:	libxml2

%description
Soup provides an queued asynchronous callback-based mechanism for sending and
servicing SOAP requests, and a WSDL (Web Service Definition Language) to C
compiler which generates client stubs and server skeletons for easily calling
and implementing SOAP methods.

%files
%defattr(-, root, root)
%doc COPYING ChangeLog AUTHORS INSTALL NEWS TODO README
%{_libdir}/lib*.so.*


%post
ldconfig

%package -n libsoup-devel
Summary:	Simple Object Access Protocol implementation
Group:		Development/Libraries
Requires:	%{name} = %{version}-%{release}
Requires:	glib2-devel
Requires:	libxml2-devel

%description -n libsoup-devel
Soup provides an queued asynchronous callback-based mechanism for sending and
servicing SOAP requests, and a WSDL (Web Service Definition Language) to C
compiler which generates client stubs and server skeletons for easily calling
and implementing SOAP methods.

This package allows you to develop applications that use the Soup library.

%files -n libsoup-devel
%defattr(-, root, root)
%{_libdir}/lib*.so
%{_libdir}/pkgconfig/*.pc
%{_includedir}/*


# $RPM_COMMAND is an environment variable used by the SUN build
# system to control the build process with finer granularity than RPM
# normally allows.  This specfile will function as expected by RPM if
# $RPM_COMMAND is unset.  If you are not the SUN build system,
# feel free to ignore it.

%prep
case "${RPM_COMMAND:-all}" in
dist)
%setup  -q -D -n %{name}-%{version}
    ;;
all)
%setup  -q -n %{name}-%{version}
    ;;
esac
#case "${RPM_COMMAND:-all}" in
#dist|all)
#%patch -p1 -P 0
#    ;;
#esac

%build
%ifos linux
if [ -x /usr/bin/getconf ]; then
  CPUS=`getconf _NPROCESSORS_ONLN`
fi
%else
  CPUS=`/usr/sbin/psrinfo | grep on-line | wc -l`
%endif
if test "x$CPUS" = "x" -o $CPUS = 0; then
  CPUS=1
fi

MAKE=${MAKE:-make}
RPM_COMMAND=${RPM_COMMAND:-all}
DESTDIR=${DESTDIR:-"$RPM_BUILD_ROOT"}
ARCH=%{_target_platform}
export MAKE RPM_COMMAND DESTDIR ARCH
case "$RPM_COMMAND" in
prepare|all)
    libtoolize
    aclocal $ACLOCAL_FLAGS -I %{_datadir}/aclocal/gnome2-macros
    autoheader
    automake -a -f -c
    autoconf
    ./configure --prefix=%{_prefix} --sysconfdir=%{_sysconfdir} --mandir=%{_mandir} --infodir=%{_datadir}/info --localstatedir=/var --enable-more-warnings=no --enable-gtk-doc=no  --with-gnutls-libs=%{_libdir} --with-gnutls-includes=%{_includedir}
    ;;
esac
case "$RPM_COMMAND" in
clean|all)
    if [ "/" != "$DESTDIR" ]; then
	rm -rf "$DESTDIR"
    fi
    ;;
esac
case "$RPM_COMMAND" in
build|all)
    ${MAKE} -j $CPUS
    ;;
esac

%install
MAKE=${MAKE:-make}
DESTDIR=${DESTDIR:-"$RPM_BUILD_ROOT"}
# export DESTDIR
case "${RPM_COMMAND:-all}" in
install|all)
    ${MAKE} install prefix=${DESTDIR}%{_prefix} sysconfdir=${DESTDIR}%{_sysconfdir} mandir=${DESTDIR}%{_mandir} infodir=${DESTDIR}%{_datadir}/info localstatedir=${DESTDIR}/var
    ;;
esac

%clean
DESTDIR=${DESTDIR:-"$RPM_BUILD_ROOT"}
export DESTDIR
case "${RPM_COMMAND:-all}" in
clean|all)
    if [ "/" != "$DESTDIR" ]; then
	rm -rf "$DESTDIR"
    fi
    ;;
esac


%changelog
* Wed Jul 07 2004 - [email protected]
- added "-j $CPUS" to make to speed up builds

* Fri Jun 25 2004 - [email protected]
- bump src tarball to build13
* Thu Jun 10 2004 - [email protected]
- bump src tarball to build12
* Sun May 30 2004 - [email protected]
- bump src tarball to build11
* Fri May 14 2004 - [email protected]
- bump src tarball to build10
* Fri Apr 30 2004 - [email protected]
- bump src tarball to build09